Suddenly my pc wakes instantly from sleep? Sigh

Discussion in 'PC Hardware' started by klepp0906, Aug 9, 2016.

  1. klepp0906

    klepp0906 MDL Novice

    Jul 17, 2014
    26
    5
    0
    I'm soo frustrated! Days of tweaking and I'm almost done and run into an issue like this.

    I put the pc to sleep and it turns back on instantly.

    I've narrowed it down to my Ethernet/lan but the thing is - it's always worked before.

    Now if I disable the Ethernet connections it will sleep fine.

    The only settings I changed were the receive and transmit buffers (which should have no effect?) and the disabling of admittedly a lot of services. (All researched and 90% had been disabled before without killing sleep). Also the group policy tweak to reserve more bandwidth (again no clue how this could affect it)

    Could have nothing to do with services but I'm kinda stuck on how to proceed with my troubleshooting. Don't want to have to re dump Windows ugh! Do any services regulate net connections to that end?

    I know I can likely turn off wake on lan and resolve it but two things stop me. 1) it wasn't necessary to be off before and 2) I intend to use wol as my pc is going to double as a media server.

    Little help here gents :)
     
  2. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,491
    1,503
    180
    sounds like bios lan rom efi or both efi and legacy
     
  3. GoNz0

    GoNz0 MDL Novice

    Feb 27, 2010
    40
    6
    0
    Check the WOL settings are only magic packet and not wake on pattern match?
     
  4. Katzenfreund

    Katzenfreund MDL Expert

    Jul 15, 2016
    1,372
    814
    60
    It doesn't take long to re-enable the services you disabled to see what happens. And if necessary, you can disable them again, though it may not be the best idea in any case. Even if disabled services are not the cause of this problem, they could well be of another, future one.
     
  5. klepp0906

    klepp0906 MDL Novice

    Jul 17, 2014
    26
    5
    0
    Bios is ruled out. Haven't changed anything in it for literally a couple years now.

    The services I did re enable quite a few with no luck. Some are pretty vague regarding what they're for as far as file sharing/workgroups/lan related.

    I'm going to try a complete removal and reinstallation of the lan drivers today and if that doesn't do it I'll give the services one more go.

    I should have kept track of what I disabled and tested as I went but I always get hasty at the end lol. I've dumped every time I found something broken and adjusted it. This time I thought I was there! End of the night put it to sleep and I almost died!

    I mean to make a backup but always figure "one more tweak" or "I'm almost done I'll do it when it's done" and it bites me in the rear!

    Also hoping nothing like disabling uac via registry and removing things like defender/Windows firewall etc can effect it.

    Looks like another full day of trial and error.

    Thank you for the replies folks - this is one of the best forums on the net :p
     
  6. T-S

    T-S MDL Guru

    Dec 14, 2012
    3,988
    1,318
    120
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. hb860

    hb860 MDL Addicted

    May 7, 2010
    996
    1,812
    30
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. klepp0906

    klepp0906 MDL Novice

    Jul 17, 2014
    26
    5
    0
    Ty for the links guys. I did run just the bare power config last wake command and as expected it returned my nic(s).

    I was unaware you could dig deeper and ascertain any services involved.

    Tried re enabling all the defaults with no luck (services) so I can only assume it's something else that changed or came with anniversary update.

    For the time being I checked the "only with magic packet" box which should be amicable assuming the only app I want to wake my pc would be plex and I assume it would send/use a magic packet.

    Still - I'd love to know the root cause so I may uncheck and go through those links now.

    I tried unplugging all my usb items as well as rolling back from Intel to MS Ethernet drivers.

    All to no avail.

    Wondering if all the tracking/telemetry stuff I uninstalled affected it. I'll see what I can dig up. First time this has happened and I been running Windows 10 since day 1.

    As always, thanks a bunch!
     
  9. klepp0906

    klepp0906 MDL Novice

    Jul 17, 2014
    26
    5
    0
    Well fwiw between all that I was able to find via command line and event viewer - turns out it was the network card (one of them) and that's all the info I could get.

    After a dumping (to my chagrin) I went down my list of tweaks putting my pc to sleep intermittently.

    Not sure what "exactly" yet as I've done it every "couple" tweaks to save time but it's definitely caused by something near the bottom of winaero tweaker.

    If I had to guess - it has an overzealous "disable telemetry" setting which seems to be the potential culprit.

    Still - this left me dumping AGAIN. Lol.

    I swear one day I'll have it up n running.

    (Then I get to break it again trying to update my metadata icons for my iPhone since my 6s and Windows 10 don't seem to be viewed as anything other than a generic image device)

    Ayeyeye
     
  10. klepp0906

    klepp0906 MDL Novice

    Jul 17, 2014
    26
    5
    0
    Yep - it's the telemetry setting in winaero ftr use other means to disable telemetry (tons exist!)

    So the only two issues I now have are Windows update telling me my early access/version settings need attention in annoying red text

    Aaaaaand

    When i restart the pc it says "restarting" but there's no spinning dots anymore.

    Ugh!

    Admittedly minor but I'm anal/ocd which is half the reason I spend so much time configuring!

    Aaaanyways
     
  11. jeff69dini

    jeff69dini MDL Addicted

    Nov 22, 2008
    767
    181
    30
    cmd prompt, run powercfg /waketimers
     
  12. atgpud2003

    atgpud2003 MDL Member

    Apr 30, 2015
    238
    30
    10
    Try disable LAN WAKE UP?? this will cause kick the computer on from sleep mode.. :) I believe in BIOS Setup and also may need uncheck WAKE UP LAN on your nic card device properties.
     
  13. John Sutherland

    John Sutherland MDL Addicted

    Oct 15, 2014
    670
    941
    30
    It might be the NSA. WAKE UP! All your data is now our data! :D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. coromonadalix

    coromonadalix MDL Senior Member

    Jul 21, 2009
    429
    85
    10
    it was the same for me unchecked the wake on lan in my mobo .... and the power configs/sleep the allow wake timers .... turned all of them off, no more problems, check your mouse and or keyboard, if they are wireless ones, they can wake you computer too, had theses problems with my firsts win10 installations, before finding this cause.

    IE: almost fully discharged battery, had to change them for ones with a power switch ???
     
  15. MS_User

    MS_User MDL Guru

    Nov 30, 2014
    2,837
    475
    90
    he also never mention how old is the computer...old hardware do all kinds of weird things on win10 mostly has to do with old driver issues.
     
  16. klepp0906

    klepp0906 MDL Novice

    Jul 17, 2014
    26
    5
    0
    Nah hardware is brand new. 4970k/ocforce/sli 1080 etc.

    I did check and disable wake timers with no change.

    Did remove non cordless mouse/kb as well.

    It was the integrated nics for 100% sure and they were fine until I enabled winaero telemetry disable. Boom would no longer sleep.

    This time didn't use winaero I used a small exe called disablewintracking and sleeps fine.

    Not technical enough to know what winaero disables that disablewintracking does not but whatever it is breaks sleep.

    Thanks for all the replies folks :)
     
  17. Hadron-Curious

    Hadron-Curious MDL Guru

    Jul 4, 2014
    3,548
    526
    120
    Do you want him to have cardiac arrest? You are very funny!:biggrin::biggrin::biggrin:
     
  18. master44tr

    master44tr MDL Novice

    Nov 25, 2013
    36
    3
    0
    PDW syndrom = Panic Disorder of Windows Syndrom.:p