Surface 2 RT (64GB) - Touchscreen stopped working

Discussion in 'Mobile and Portable' started by itsmemario1, Jan 5, 2018.

  1. itsmemario1

    itsmemario1 MDL Senior Member

    Sep 10, 2012
    275
    24
    10
    #1 itsmemario1, Jan 5, 2018
    Last edited: Jan 5, 2018
  2. itsmemario1

    itsmemario1 MDL Senior Member

    Sep 10, 2012
    275
    24
    10
    I just installed Update 3 (Startmenu) and 170 additional KBs via Update.
    I used the official image by entering my serial number on the MS site.
    The touchscreen still wont work.

    May I ask which image you did use to do your fresh install and/or which Firmware you are using (2.15 or 2.17) or if anything "newer" is available for HID Touchscreen then 21.06.2006 (6.3.9600.18341)
    Did you ever have touchscrene problems ?

    An yes, Im active on xda as well. But Im at a point where I tried everythign already. :S
     
  3. maddogster

    maddogster MDL Member

    Mar 23, 2015
    107
    22
    10
    i remember years back update problem but ms resolved it online with a newer update and my windows update started working; touchsceen or my touch keyboard/usb mouse not working usually a reboot starts it working again so i have never had problem after reboot like yours - i will check and let you know the above versions on my surface rt ( mine is the original surface rt 64gb so not the surface 2 rt like yours so it has older hardware )
     
  4. maddogster

    maddogster MDL Member

    Mar 23, 2015
    107
    22
    10
    same version hid touch screen driver as you but i have under firmware 5 different firmwares

    surface rt system aggregator firmware 1.1.6.0
    surface rt touch configuration settings 1.30.0.0
    surface rt touch firmware 37.170.0.0
    surface rt uefi 3.31.500.0
    surface touch cover firmware 2.7.26218.0
     
  5. itsmemario1

    itsmemario1 MDL Senior Member

    Sep 10, 2012
    275
    24
    10
  6. maddogster

    maddogster MDL Member

    Mar 23, 2015
    107
    22
    10
    did you try the battery drain down to empty and then charge it up and see if that works as it helped a few on the forums for some unfounded reason :)
     
  7. itsmemario1

    itsmemario1 MDL Senior Member

    Sep 10, 2012
    275
    24
    10
    1st thing I tried, see my 1st post. = )