svchost problem its using 100% cpu

Discussion in 'Windows 7' started by rishivivek, Feb 20, 2014.

  1. rishivivek

    rishivivek MDL Novice

    Oct 31, 2012
    2
    0
    0
    Can any one help me, i recently installed windows Update , after finished the update i facing this problem, svchost constantly using 100% of cpu. i already disabling the Upnphost, SSPD service, but no use in that , still am in the same condition , any one please help to solve this problem........
     
  2. Kamrul08

    Kamrul08 MDL Member

    Dec 28, 2013
    101
    12
    10
    Go to msconfig and try to disable some unnecessary service and startup programs. You can also stop automatic update of drivers and other software that keep the CPU continuously busy.
     
  3. rishivivek

    rishivivek MDL Novice

    Oct 31, 2012
    2
    0
    0
    I already did the all possible sloution but i cant find what causes this porblem.... every time i changing the os, i facing this problem in 64 bit...
     
  4. mabaega

    mabaega MDL Senior Member

    Dec 30, 2010
    269
    164
    10
    open TaskManager and go to Details
    Is there TiWorker.exe running?

    If yes, maybe u need Upgrade your device driver.
    or wait till Tiworker.exe job finish.
     
  5. Kamrul08

    Kamrul08 MDL Member

    Dec 28, 2013
    101
    12
    10
    I think windows didn’t complete update. After download all hotfix will be installed and windows will be configured as hotfix settings. It might take above an hour. During this time CPU uses it’s full performance. So your Windows might be slow. You can do two things.


    1. Let your windows time to be configured. During this time stop all of your works.

    Or


    1. You can manually update your windows installing update packs. It is better and I do it.


    You can get more information in taskmgr as mabaega advised.