SVR2012 - Odd HDD issue

Discussion in 'Windows Server' started by RyanThaDude29, Nov 22, 2012.

  1. RyanThaDude29

    RyanThaDude29 MDL Novice

    Oct 4, 2008
    11
    0
    0
    I decided to piece together an old system to run Server 2012. It has several hard drives, 2 SATA and 2 PATA. All the disks work great except for one, a SATA Maxtor 6 L100M0. This disk has always worked in any other operating system but for some reason it doesn't in Server 2012.

    The operating system has no problem seeing and identifying the drive but what's strange is that it shows a capacity of 0.00 B. Again, this disk worked great in all other OSs. I wiped the drive, re-partitioned using a recovery boot disk using MBR and still fails to show a capacity other than 0.00 B. In Server 2012's disk management it won't initialize or reset. Both end up in an unknown error.

    Anyone know how to fix?

    Thanks!

    The motherboard is a Gigabyte EP35-DS3L, Q6600, 4GB DDR2, GeForce 7100.
     
  2. PGHammer

    PGHammer MDL Senior Member

    Oct 14, 2011
    361
    73
    10
    Weird - especially since I dual-boot 8 and Server 2012 on an ASUS P5G41-M LX2/GB - like your Gigabyte, not a typical server motherboard by any stretch.

    The two OSes are on completely separate (both SATA) HDDs; in fact, Windows Server is on a former HP 80 GB SATA HDD.

    Both OSes see both HDDs (8 Pro is on a 1 TB ex-MyBook WD10EADS); in fact, because of the massive capacity difference, I also use the 8 HDD to store my VMs that I run on Server 2012.

    It might well be how the drive is formatted that is causing the woe - I had a similar issue with a 200GB Maxtor 6LS200 that was originally used for *Hack* duties. (The GPT formatting threw things out of whack.) Blanking the drive entirely in Windows client let Windows Server use the drive.
     
  3. RyanThaDude29

    RyanThaDude29 MDL Novice

    Oct 4, 2008
    11
    0
    0
    The drive was part of a Hackintosh setup but I don't believe I ever formatted it via GPT as another drive was setup to boot MacOS. I did zero the drive, too. Odd. Nevertheless I pulled it and put it to good use in a Linux box. Works flawlessly.
     
  4. im bored

    im bored MDL Member

    Aug 17, 2009
    166
    157
    10
    I had a similar issue with a 3TB drive where I had to use gparted to redo the GTP for the drive and my drive started working. Maybe you have to do something similar. I can't remember the exact wording anymore but it was something along the lines or initialize with MBR or initialize with GTP and than format.
     
  5. user_hidden

    user_hidden MDL Expert

    Dec 18, 2007
    1,026
    977
    60
    reformat the drive and reset the MBR