"There's a problem with PC settings"?

Discussion in 'Windows 8' started by Espionage724, Jan 20, 2015.

  1. Espionage724

    Espionage724 MDL Addicted

    Nov 7, 2009
    902
    255
    30
    I've only seen this happen twice (on two different Windows installs) since that last major 8.1 update (update 3?), but PC Settings will stop working, and I don't know why. Starting it gives a "This app can't open" bar with "There's a problem with PC settings. Refreshing your PC might help fix it.".

    I reinstalled Windows a few weeks ago, and PC settings was working fine up until recently. I don't recall doing anything significant aside from running Windows Update a few days ago, and it picked up a few recent updates.

    I haven't tried it yet this time; but sfc /scannow didn't help before.

    Anyone have any ideas?
     
  2. abbodi1406

    abbodi1406 MDL KB0000001

    Feb 19, 2011
    7,716
    25,014
    240
    #2 abbodi1406, Jan 20, 2015
    Last edited by a moderator: Apr 20, 2017
    Try this in powershell
    Code:
    Add-AppxPackage -register $Env:SystemRoot\ImmersiveControlPanel\AppxManifest.xml -DisableDevelopmentMode
    
    or this in cmd:
    Code:
    Dism /Online /Cleanup-Image /RestoreHealth
    
     
  3. Espionage724

    Espionage724 MDL Addicted

    Nov 7, 2009
    902
    255
    30
    #3 Espionage724, Jan 22, 2015
    Last edited by a moderator: Apr 20, 2017
    (OP)
    I tried the DISM command and it didn't work. I ran it once, it said it repair corruption, but PC setting still wouldn't open. Ran it again, and it said it repaired corruption again. PC settings still didn't work even after a reboot.

    Not sure if I just have to keep re-running the dism command until it says it didn't repair anything.
     
  4. Mr.X

    Mr.X MDL Guru

    Jul 14, 2013
    5,861
    13,407
    180
    What about powershell?
     
  5. ZaForD

    ZaForD MDL Expert

    Jan 26, 2008
    1,180
    177
    60
    Just an FYI guys...

    I got a HP Stream for the little one at Xmas.
    Due to the limited storage on it I removed all the HP 'Junk' and as soon as I did it had this same problem. I tried a number of solutions I found on the net (including the three above) but nothing worked.

    The two solutions I found that worked were:
    1. A full restore from the HP image. :(
    2. A new clean install, I had to use Core, as I couldn't find a copy of 'with Bing' that its key worked with. :confused:
    But... I gained an extra 5gb of storage :biggrin: