Toshiba Satellite Pro A300-PSAG9E BIOS Recovery help needed

Discussion in 'BIOS Mods' started by FailSauce, Dec 28, 2010.

  1. FailSauce

    FailSauce MDL Novice

    Dec 28, 2010
    Hey guys, I have a Toshiba Satellite Pro A300-PSAG9E here. Tried flashing to the latest BIOS version 2.20 from Toshiba's site, but the power cut out mid-way through the flash process. The laptop's not booting up anymore.

    I've looked up the thread on the Insyde BIOS recovery mode where you place the BIOS file on a USB drive (it's FAT16 formatted) and performe a routine by holding down a key combination, plugging in AC and starting up. I've already tried this, to no avail with several different key combinations (Fn+Esc, Fn+F, Win+B, Fn+B). Could anyone help me out?

    Laptop is out of warranty so calling up Toshiba isn't really an option. The BIOS filename is PO10220M.FD. I've used the SLIC tool to find out it should be named BIOS.FD. For reference, the BIOS can be downloaded from hxxp://

    If the recovery fails, could the BIOS chip be reflashed by someone with the appropriate programming tool?