TP-Link TL-WN722N Drivers: (

Discussion in 'Windows 8' started by daemonix, Sep 27, 2012.

  1. daemonix

    daemonix MDL Novice

    Sep 27, 2012
    1
    0
    0
    Cards looking for drivers for TP-Link TL-WN722N in windows 8 x64 because of the manufacturer do not work
    Help :(((((((((((((((((((((
     
  2. sararocs

    sararocs MDL Novice

    Jan 13, 2008
    28
    2
    0
    I'm using TP-linl tl-wn722n wireless adapter and it works ok on windows 8 with latest driver update from their website.
     
  3. robonzio

    robonzio MDL Junior Member

    Sep 13, 2012
    53
    13
    0
    You could try the Chipset Drivers from Atheros. The TP-Link TL WN722N use the AR9271 Chipset. You can download them from atheros.cz
     
  4. 123Zbyniek

    123Zbyniek MDL Novice

    Sep 21, 2012
    11
    1
    0
    #4 123Zbyniek, Sep 27, 2012
    Last edited: Nov 3, 2012
    Try driver from TP-Link site (date 21-11-2011).
    Version 2.0.0.62 (for Windows 7 x64).
    It works fine for me (Win 8 x64 Enterprise).

    Update (03-11-2012):
    It works also with Win 8 Pro x64.
    After installing Win 8 Pro update driver through device manager --> manual procedure --> from disk (where you have files) --> show file "netathurx.inf".
     
  5. Trailertrash

    Trailertrash MDL Novice

    Aug 19, 2012
    4
    0
    0
    Hi, I used Win7 drivers for my TP-link, but had to boot into win8 with driver "signing off" to install them.

    After install you can do normal boot and they should work fine.
     
  6. enobil

    enobil MDL Novice

    Jan 25, 2012
    2
    1
    0
    Hi


    I had a driver problem with tp-link tl wn722n in windows 8. (solved myself but tried all the things on the internet)
    The errors I got were:
    Windows encountered a problem installing the driver software for your device
    Windows found driver software for your device but encountered an error while attempting to install it.
    The hash for the file is not present in the specified catalog file. The file is likely corrupt or the victim of tampering.


    And, also when I try to install the software utilities on windows 8, i got blue screen and I fixed using refresing windows 8.
    Then I tried lots of manual installation things, but only that one worked for me


    go to www . tp-link . com/en/support/download/?model=TL-WN722N&version=V1 (you need to establish some other internet connection of course)
    download TL-WN722N_100629
    or direct download via this link www . tp-link . com/resources/software/TL-WN722N_100629.zip
    extract zip file
    run devmgmt.msc (device manager)
    click on (or highlight with keyboard) USB2.0 WLAN
    open context menu (right click or press context menu key)
    click/hit enter on update driver software
    select browse my computer
    locate the folder you've got after extraction
    next
    you're done


    I've tried so many things with the driver in the cd coming within package, none of them worked. (tried to install atheros chip driver, got same error)
    I searched web and since win8 is new, there was no help form there. Tried described things in websites but none of them worked.
    Now it's perfect.
    I did restarted my windows 8 and didn't get BSOD. I'm very relaxed right now. :D


    For hope of search engines:
    windows 8 tp-link tl wn722n driver
    windows 8 tp-link tl wn722n driver download
    windows 8 tp-link tl wn722n driver installation problem
    windows 8 tp-link tl wn722n driver problem
    windows 8 tp-link tl wn722n driver hash
    windows 8 tp-link tl wn722n driver corrupt
    windows 8 tp-link tl wn722n driver victim
    windows 8 tp-link tl wn722n driver BSOD


    I noticed that connection gets lost after sleep. But it may be a general issue, I don't know.
     
  7. sztosz

    sztosz MDL Novice

    Apr 21, 2008
    1
    0
    0
    #7 sztosz, Nov 3, 2012
    Last edited: Nov 3, 2012
    This is due to windows power management policy. Just go to device manager, this device, and on power tab, check out the proper "tick". I'm sorry but i really don't know how it's called in English system version.

    PS. there are some win 8 beta drivers on tp-link site, but i was unable to install them, does give me an error

    [qoute]
    !!! sig: Driver package INF file hash is not present in catalog file. Filename = netathurx.inf, Error = 0xE000024B
    !!! sig: Driver package appears to be tampered, and Code Integrity is enforced.
    !!! sig: Driver package failed signature validation. Error = 0xE000024B
    [/quote]
     
  8. buksnatata

    buksnatata MDL Member

    Oct 22, 2011
    212
    92
    10
    I have plugged in windows recognized it as Atheros and it works normally :)
     
  9. 123Zbyniek

    123Zbyniek MDL Novice

    Sep 21, 2012
    11
    1
    0
    #9 123Zbyniek, Nov 3, 2012
    Last edited: Nov 3, 2012
    [/QUOTE]

    Info for daemonix:

    See up-dated post #4.
     
  10. cbq

    cbq MDL Novice

    Nov 7, 2012
    1
    0
    0
    I just registered here to thank you for this post. It worked for me :biggrin: