troubles saving the bios with afudos.exe but not afuwin.exe

Discussion in 'BIOS Mods' started by grml4d, Jun 24, 2012.

  1. grml4d

    grml4d MDL Junior Member

    Sep 14, 2011
    56
    3
    0
    i have a tyan s7025 and there were some bios made these days .
    i am very unhappy of the latest beta they made .

    to sum up the things : to flash bios they make a 4 Mo file that is loaded by tflash.exe and passed to afudos.exe .

    i made backups using afudos.exe /o of the 3 latest bios i flashed and size of file made by afudos is 2 Mo

    this morning , i wanted to check if save is working well before doing a new flash , then i saw that afudos.exe gets stucks at 3% ... i tried the 3 releases i had with bioses or directly at ami website .
    they all get stuck at this point .
    i tried with afuwin64 under win 7 x64 and win xp x64 and it saved the bios without trouble : a 2 Mo file

    i wonder if i do reflash in dos using tflash , or use one backup of 2 Mo and use afudos or afuwin ?
    my choice is afuwin64 but if that fails.. may be dos is more easy to launch a recovery
     
  2. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,264
    1,422
    180
  3. grml4d

    grml4d MDL Junior Member

    Sep 14, 2011
    56
    3
    0
    #3 grml4d, Jun 24, 2012
    Last edited: Jun 25, 2012
    (OP)
    thanks for the link , i made an other usb disk , i made it using me io.sys and added himem.sys and it worked like a charm .
    as it was working well under win , my idea was that memory was not big enough ;'] [ according to tyan support , boot disk should be made with only win98 io.sys , that was what i was using until today. ]
    after that i flashed the bios with a 109 beta that is not public yet

    the link you gave is cool but a bit outdated , by the way , i tried to use the /s switch of afudos : /S Display current system’s BIOS ROM ID
    i used tflash.exe that has the same switches as afudos.exe . i wanted to know if the bios of the lsi 1068e is in the 4 Mo bios file .
    in fact the result was that afudos flashed something instead of listing some rom in the bios like the intel boot agent or ahci ..

    i mean the bios for the lsi is not in the 2 Mo file i get with backup , i found an update at lsi for bios with one card they make : http://www.lsi.com/products/storagecomponents/Pages/LSISAS3801E.aspx

    i wonder if i can launch the flashing without any risk ?
    for the rest i uploaded at tyan support the more recent firmware i found , so they should make the mix without me taking risk of killing the board ;']


    edit : after re-reading the bat file that does the flash process and editing it slightly , i made the lsi firmware update without troubles ;']