trying to fix office 2007

Discussion in 'Windows 7' started by dragonfire665, Nov 20, 2009.

  1. dragonfire665

    dragonfire665 MDL Member

    Sep 17, 2008
    248
    0
    10
    Ok so here is something weird. While trying to change my icons and folders last name which by the way i didnt actually do, i lost my icons for M$ office 2007 and other programs. Instead for example of showing my M$ Word icon it will show a missing Icon. So i tried to unistall office 2007 but now it gives me an unsuccessful unistallation, and it will not unistall. Then if i try to run the CD to repair it will give me an STOP ERROR trying to send error to windows and find a answer. So i can not even install it or unistall it. Any suggestion? n btw i already try SafeMode
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. dakota42784

    dakota42784 MDL Junior Member

    Jul 16, 2009
    73
    6
    0
    #2 dakota42784, Nov 20, 2009
    Last edited: Nov 20, 2009
    Always make a Backup,Always make a Backup,Always make a Backup,Always make a Backup.

    Download Free Revo Uninstaller.........and run.
    When it asks you to select uninstall mode........Select Advanced & let it do its thing.
    When it finds Leftover files.....Select All, then select Delete.
    hit next......if it finds more files, select all..........then Delete.

    Do Not Restart if it asks you...............Until Revo is done. (Very Important).


    After Uninstallation is done..........Re-Install Office 2007

    And Please Back up your system while it's running good!!!!! :D:):rolleyes:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. dragonfire665

    dragonfire665 MDL Member

    Sep 17, 2008
    248
    0
    10
    thanks and i have my system backup before this, i just didnt want to go thru all that process. I know there is another method to fix this issue which u gave me. I would use my system back up when something serious happens to my windows files. So i will say thank you for the reminding, trust me there is never enough reminders lol. I think im going to place ur icon over my reminder callendar to backup periodically my system lol
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. bambara

    bambara MDL Junior Member

    Oct 18, 2009
    92
    1
    0
    The icons do not show up but the programs work fine, yes? If that's the case, then it may be the same problem I faced. Either right-click the icon, choose properties, and choose a different icon. OR, right-click it, properties, and choose to run in Vista SP2 compatibility mode. See if any of these work.
     
  5. dragonfire665

    dragonfire665 MDL Member

    Sep 17, 2008
    248
    0
    10
    yea they still work but the icons are showing as missing icons
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. gentoo

    gentoo MDL Senior Member

    Oct 6, 2009
    394
    7
    10
    Have you rebuilt your icon cache to see if that fixes it?

    1. Close all folder windows that are currently open.
    2. Launch Task Manager using the CTRL+SHIFT+ESC key sequence, or by running taskmgr.exe.
    3. In the Process tab, right-click on the Explorer.exe process and select End Process.
    4. Click the End process button when asked for confirmation.
    5. From the File menu of Task Manager, select New Task (Run…)
    6. Type CMD.EXE, and click OK
    7. In the Command Prompt window, type the commands one by one and press ENTER after each command:
    CD /d %userprofile%\AppData\Local
    DEL IconCache.db /a
    EXIT
    8. In Task Manager, click File, select New Task (Run…)
    9. Type EXPLORER.EXE, and click OK.



    Also have you done any registry tweaks that affect icons? If so try to remove them and see if it fixes it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. SCBrigth

    SCBrigth MDL Senior Member

    May 9, 2009
    479
    65
    10
    I had the same problem some time ago when I used JV16 PowerTools to clean my registry, all of the OF2007 icons were broken and disabled.

    The office installation became broken and all the repair attempts that I made had no effect. The only way to repair the issue was to clean using a similar procedure as described by dakota42784 and reinstalling office.

    I never used again JV16 utility. :eek:

    I also advise a periodic backup and very care when you will move in the registry.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. dragonfire665

    dragonfire665 MDL Member

    Sep 17, 2008
    248
    0
    10
    #8 dragonfire665, Nov 21, 2009
    Last edited: Nov 21, 2009
    (OP)
    it still does not work while using Revo. At one point it will go to Office 2007 owns unistaller and it will still give me a error. it will say M$ office 2007 unistall unsuccessful. So now i do not know what to do. Because even when now i also try to run the CD or from the HDD Office 2007 installer it will give me an error, Setup has stop working. So i seriously do not know what to do
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. dakota42784

    dakota42784 MDL Junior Member

    Jul 16, 2009
    73
    6
    0
    #9 dakota42784, Nov 21, 2009
    Last edited: Nov 21, 2009
    Wow, It doesn't work with Revo?
    Did you try gentoo's suggestion?

    We'll, Your going to have to Uninstall, whatever way you can.
    CCleaner has an Uninstaller, so doe's TuneUp Utilities,etc.
    Or use windows uninstaller.
    Last resort search for all Office files & delete directorys & files .
    Then try to Re-Install.
    Last resort............Re-Install Windows 7 & then Office 2007

    Good Luck :D:rolleyes:

    Don't forget a Good Backup program for after you get your problem resolved.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. dragonfire665

    dragonfire665 MDL Member

    Sep 17, 2008
    248
    0
    10
    yea i use CCleaner already lol i used everything and is only with office 2007 cuz everything else runs great and i can install anything else (as i tried to make sure) but with Office is giving me hell
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. genuine555

    genuine555 MDL Expert

    Oct 3, 2009
    1,639
    56
    60
  12. exorcist

    exorcist MDL Junior Member

    Oct 31, 2007
    51
    2
    0
    You could give Windows Installer CleanUp Utility a try from microsoft had a similar problem with office and it worked a treat. :)
     
  13. dakota42784

    dakota42784 MDL Junior Member

    Jul 16, 2009
    73
    6
    0
    I am now wondering about your Office 2007 Disk.
    Any chance you got it from internet & might be corrupted?

    If you do try to delete directorys & files individually.........you will have to go into the registry & delete leftover Office files, which can be dangerous if you don't know what your doing. I do it all the time & use a program called "Registrar Registry Manager", (Free) & I search for the program that I want to find Leftover files from, and then select all found files & Delete.
    But, then I also have a backup in case something goe's wrong. But usually everything is fine.

    Again, Good Luck :D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. dragonfire665

    dragonfire665 MDL Member

    Sep 17, 2008
    248
    0
    10
    this disc is perfect heck i have actually 2 copies and i even have an extracted copy on one of my HDD to run it from n all 3 gave me the same error. Heck i wish i could get to the REPAIR option with the CD but it wont let me or even the HDD extracted. It will goes straigh to SETUP HAS STOP WORKING error. Yea is kinda weird

    and i have deleted nothing of Office 2007. As i said when i got to Unistall it wont go no where the progress bar wont move. It will go straigh the error, M$ OFFICE UNSUCCESSFUL UNISTALLER

    attached is a copy of what i get when i try to unistall Office 2007 plus i also copy Revo as you can see is not done yet looking for Registry and it has being 1hr already running
     

    Attached Files:

    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. dakota42784

    dakota42784 MDL Junior Member

    Jul 16, 2009
    73
    6
    0
    #15 dakota42784, Nov 21, 2009
    Last edited: Nov 21, 2009
    OK, RIGHT there on that Revo Screen........Select All & then select Delete.
    Have you done that??
    No way Revo should take that long........You have a virus or something.
    I would run my virus tools & if nothing found, I would Re-Install Windows & Office
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. dakota42784

    dakota42784 MDL Junior Member

    Jul 16, 2009
    73
    6
    0
    After re-reading your post again, I see that you have a backup, but don't seem to want to use. Why?
    Restoring from a backup is pretty simple to do, depending on your backup program.
    Keep us posted on your progress.:D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. urie

    urie Moderator
    Staff Member

    May 21, 2007
    8,644
    3,003
    300
    If you read any of dragonfire665's posts there is always something wrong with his system. been advised before to scrub it and start from scratch:(
     
  18. dakota42784

    dakota42784 MDL Junior Member

    Jul 16, 2009
    73
    6
    0
    Ohh I see, Thanks for heads up :D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...