Turn Off Autoplay Pop-Up Window?

Discussion in 'Windows 7' started by jetjock, Dec 22, 2011.

  1. jetjock

    jetjock MDL Senior Member

    Mar 6, 2010
    281
    15
    10
    I give up! I have turned off everything I can think of in my Win 7 Ultimate Group Policy Editor concerning "Autoplay", but everytime I plug in my external USB drive I still get that damned pop-up window asking me what I want: "Open a folder to view files" or "Use this drive for backup using Windows Backup". I don't want either. I just want to get rid of that damned pop-up!! :mad:

    I have also tried going to Control Panel and making changes there, but no matter what changes I make there, they are deleted immediately when I close the window. When I go back there the box at the top (Use AutoPlay for for all media and devices) is rechecked and all the possibilities are reset to "Chose a Default". Help!!!

    jetjock:plane:
     
  2. sticky74

    sticky74 MDL Novice

    Sep 7, 2009
    14
    2
    0
    Here is the solution:

    spotht.com/2010/12/how-to-disable-autoplay-pop-up-window.html
     
  3. Humphrey

    Humphrey MDL Expert

    Dec 13, 2011
    1,458
    982
    60
    #3 Humphrey, Dec 22, 2011
    Last edited by a moderator: Apr 20, 2017
    How about disabling autorun completely with a reg file.

    Code:
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoDriveTypeAutoRun"=dword:000000ff
    or just autoplay with this reg file:
    Code:
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AutoplayHandlers]
    "DisableAutoplay"=dword:00000001
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. jetjock

    jetjock MDL Senior Member

    Mar 6, 2010
    281
    15
    10
    That worked fine once I rebooted. Thanks alot.

    jetjock :plane:
     
  5. jetjock

    jetjock MDL Senior Member

    Mar 6, 2010
    281
    15
    10
    #5 jetjock, Dec 23, 2011
    Last edited by a moderator: Apr 20, 2017
    (OP)
    Thanks, but not sure if that would work or not. I found an earlier post from someone with a similar question, where someone suggested just removing "NoDriveTypeAutoRun" so I did. That didn't work at all. See the post from Sticky 74 to see what did. I appreciate the interest.

    jetjock :plane:
     
  6. Humphrey

    Humphrey MDL Expert

    Dec 13, 2011
    1,458
    982
    60
    Np, I integrate it into my Win7 iso's so that autorun doesn't start usb drives, the computers worlds WHORE. :tooth:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. acyuta

    acyuta MDL Expert

    Mar 8, 2010
    1,638
    371
    60
    Control panel-autoplay-untick autoplay for all media and devices

    Very easy and has always worked for me.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...