Unable to RDP & Browse UNC - FIXED

Discussion in 'Windows 7' started by TheGreatDl, Sep 28, 2010.

  1. TheGreatDl

    TheGreatDl MDL Novice

    Sep 23, 2010
    Seems as if windows 7 is at it again with installing unnecessary adapters. This fix addresses the inability to RDP & browse UNC shares due to excessive 6to4 adapters appearing in Device Manager.

    To view these pesky things, open Device Manager and show hidden devices. Then expand Network adapters. If you see any 6to4 adapters, and would like to remove them. Download devcon.exe from microsoft support, then run this command.

    "devcon remove *6to4mp"

    This process may take a while, especially if you have 100's of them. :D
  2. subpsyke

    subpsyke MDL Junior Member

    Aug 14, 2009
    #2 subpsyke, Sep 29, 2010
    Last edited by a moderator: Apr 20, 2017
    That's a good way of cleaning your system of duplicate 6to4 adapters, but it won't address the cause. Therefore, duplicate 6to4 adapters will continue being installed each time you reboot your system. The real issue is documented as KB980486*, but the solution presented in the article is not ideal (as it requires manual steps to be performed before each reboot).

    The best way is to disable the "hostednetwork" function entirely. Run this from an administrator command prompt:
    netsh wlan set hostednetwork mode=disallow
    Reboot, and uninstall any remaining 6to4 adapters from your system. No further adapters will get installed on your system.

    P.S. Two points: One, the KB article mentions in the conditions that "[y]ou enable the wireless Hosted Network feature to use the Virtual WiFi function on this computer". On all my vanilla installations of Windows 7 Ultimate, I have never used, or deliberately enabled this "Virtual WiFi" function, but I still see the symptoms of the problem manifest. Perhaps it is enabled by default in Ultimate, but not other editions. Two: having many 6to4 adapters installed can cause more than network problems - it slows down the initial boot, and causes the entire system to feel quite sluggish. I recommend all users of Windows 7 with wireless cards (but don't need Virtual WiFi) to follow this advice.

    * I still can't post links due to my low post count. Google the KB article yourself.