Unlock Acer V5-471 - Phoenix UEFI BIOS (In progress)

Discussion in 'BIOS Mods' started by asxzy, Aug 22, 2013.

  1. asxzy

    asxzy MDL Novice

    Aug 10, 2013
    2
    0
    0
    #1 asxzy, Aug 22, 2013
    Last edited: Aug 22, 2013
    Hi everyone.

    I own a laptop Acer V5-471 and I need to change the video memory of HD4000 in order to work with Mac OS. To do so, the BIOS advanced option need to be unlocked.

    Here is the info of my bios

    -Manufacturer & Motherboard Model: Acer V5-471
    -Bios revision: 2.17
    -Bios Type: Phoenix BIOS
    Cause I am new to this forum, the system would not allow me to post a topic with links. I will add the links later.


    I asked for help in some forums, including mydigitallife, but nobody would like to help. It is pretty sad, so I dig lots of posts and articles and manage to mod this BIOS by myself. Basically, this Bios shares the same structure with V5-471PG, V5-471G, even other V5 series like V5-571.


    The work is still under progressing and I am not sure if I can get it done. I post this topic and kindly ask for some help. Hope there would be someone would come and help me work it out.


    Here is what I have got for now.


    Accroding to (UEFI) Dell XPS 15/15z L502x/L511z BIOS MOD HOWTO


    1.This is a Phoenix SecureCore Tiano BIOS, same structure with Dell UEFI Bios but not exactly the same.
    2.Bios can be extracted with phoenixtool V2.14.
    3.There is a "EFI IFR SUPPRESS IF" code in the PlatformHiiAdvancedDxe.efi(CFEF94C4-***.efi) and SystemSetupMainDxe.efi(76016A54-***.efi). But all the pattern 0A 82 45 8A (**) is set as 0A 82 45 8A (01) already. So basically, the advanced menu may not suppressed, at least not in this part.
    I tried to find this pattern in all the files extracted from Bios and did not find any luck.
    After that, I tried to mod it into 0A 82 45 8A (00), but the flash program would not allow me to flash it -- ERROR 234 - SecureFlash verification fail!
    4.Native speed steep can be enabled in PowerManagement2.efi (F7731B4C-***.efi) by changing (75) 08 0F BA E8 0F into (EB) 08 0F BA E8 0F (to enable native speed steep)


    What I am trying to do next is to find a way to fix the ERROR 234 then find out where Acer blocked the advanced Menu.


    Other options
    1.Access Bios options through EFI shell, provied by [HOWTO] access you BIOS settings through EFI shell.
    This is a way to access options in Insyde. However, I could not find the map for my Bios and the EFIshell not working on my laptop.
    2.Unlock the Video Memory statement.
    Since I only require to mod the video memory which showed in Main Menu, and the block looks like a Locked selector. According to the define of EFI_IFR_LOCKED, we may try to disable this statement and access the selector. However, i am not able to find the hex pattern of this part. I would be appreciated if anyone would verify this idea or help me find this pattern.


    Honestly, I have no idea what to do next. Any advice and help would be great.



    Thank you and sorry about my English
     
  2. nexus76

    nexus76 MDL Addicted

    Jan 25, 2009
    783
    296
    30
    #2 nexus76, Aug 22, 2013
    Last edited by a moderator: Apr 20, 2017
    Powermanagement patched

    Code:
    $> pmpatch BIOS.cap BIOS-pmpatched.cap
    PMPatch 0.5.13
    PowerManagement modules not found.
    PowerMgmtDxe/PowerManagement2.efi modules not found.
    AMI nest modules not found.
    Trying to apply patch #1
    Nested PowerMgmtDxe/PowerManagement2.efi module at 002ADA78 patched.
    Phoenix nest module at 00068218 patched.
    CpuPei modules not found.
    Output file generated.
    
    > http://rghost.net/48307787

    try to pflash from DOS
    if the lock is an issue have a look at fpt and the biosrefl option at least ;)
    last resort would be a SPI programmer to burn your ROM.

    belonging the unlock of video memory option I tried with j-bios.py but it can't be done the easy way.
    maybe a real expert like Yen can help you?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...