[Unsolved] Launching Non-Microsoft Apps from Desktop

Discussion in 'Windows 8' started by Voyevoda, Dec 16, 2012.

  1. Voyevoda

    Voyevoda MDL Novice

    Oct 30, 2012
    21
    2
    0
    #1 Voyevoda, Dec 16, 2012
    Last edited: Dec 16, 2012
    SOLVED - We have launched the Google Search app though PowerShell. Currently working on a script to launch the app. If we get that nailed down, should be all good. Will post a tutorial in a short while.

    Over the past day or so myself and a friend have been trying to open Metro applications through the desktop that aren't made by Microsoft. So far most people know that creating a shortcut with the link eg: bingnews:// will open the Bing News Metro app. But links like these do not work for most other apps. The app we have tried to launch from desktop is the Google Search Metro app.

    So far the easiest solution is to launch the app from "%windir%\explorer.exe shell:::{4234d49b-0245-4df3-b780-3893943456e1}" named the Applications folder. Attempts to find this folder in the Windows root folder have been unsuccessful. On further digging in the C:\Program Files\WindowsApps the executables off the apps are located thereunder their respective folders the Google Search App being named "google-search.exe". It cannot be launched, running it results in the following error: "This application can only run in the context of an application container."

    Finally we managed to locate the link: "%windir%\explorer.exe shell:::{308dc145-6851-487d-b83b-1223a3b52dc2}" using the Google Search app's ID number from it's Windows Store URL. Trying to navigate to this link results in the following error: "This file does not have a program associated with it for performing this action. Please install a program, or if one is already installed, create an association in the Default Programs control panel."

    I am not overly Windows savvy, if my information is of any help. I hope someone who can find use of it for those who like their metro apps but loathe the metro start screen.

    And I did notice that I forgot to put the word "Metro" in the title of the thread.