[Update] Realtek High Definition Audio

Discussion in 'Application Software' started by stasio, Nov 30, 2016.

  1. chillgates

    chillgates MDL Member

    Dec 15, 2010
    214
    109
    10
    First thing i do after w10 installation is i activate admin user , log in to it and open group editor and disable all things those are linked with updates. So my w10 update button also disables and never install updates in the default user. In 3 or 6 months when i get mood or need, i re-install pre-updated w10 iso downloaded from cloud.mail.ru links. So i don't need to bother about those random m$ updates which mess my system. In the name of security m$ adding more and more telemetry to w10. A proof of that is when we perform some update, new m$ executable files try to connect home. My firewall control notifies me.
     
  2. nurofen

    nurofen MDL Novice

    Nov 27, 2017
    23
    1
    0
    Where has our friend @Mokichu gone?
     
  3. Yanta

    Yanta MDL Senior Member

    May 21, 2017
    311
    150
    10
    DDU doesn't uninstall 9205 Audio driver, but it does break it such that it can't be uninstalled from programs and features. Maybe 9205.1 is too new
    So restored from an image from a few months ago that had 9075 installed.
    Then ran DDU and it uninstalled the drivers correctly.
    Reinstalled 9205, but it seems to only be getting partially installed. No software at all. No system tray or control panel HD Audio manager. Nothing in programs files and only RTL Updater in program files (x86).
    Nothing else.
    So, back to 9075 which likewise has nothing installed but drivers.
    Then tried 8881 which doesn't support ALC4080 but does support ALC1220, and is known to have the HD Audio manager. Stii HD Audio manager won't install.

    Found a later chipset driver so installed that and tried 9205 again. No luck.

    So I'm on 9205 but I have no HD Audio manager in control panel or tray. There is no software installed at all, just the base drivers.
    All attempts were done with Internet disconnected and drivers removed with DDU before each attempt.

    Yes, I think LTSC 2019 is fairly stable now. I am planning to stop installing updates at the end of the year.
     
  4. chillgates

    chillgates MDL Member

    Dec 15, 2010
    214
    109
    10
    Since he is doing updates only for Asus hardware , he sticked to ASUS ROG forum updates section. People here are annoying with same question why he is not doing drivers for other hardware etc. So he disappeared.
     
  5. erpsterm35

    erpsterm35 MDL Expert

    May 27, 2013
    1,225
    864
    60
  6. Yanta

    Yanta MDL Senior Member

    May 21, 2017
    311
    150
    10
    #2507 Yanta, Oct 7, 2021
    Last edited: Oct 7, 2021
    See attached screenshots. As you can see the Z590 and the X299 both have the same driver installed The X299 has the realtek HD Audio Manager in Control panel and the Z590 doesn't.
    The Z590 has two audio devices. The USB 2.0 drive I assume is the ALC4080.
    The X299 is FF03 and the Z590 is FF00.
    Both were installed from exactly the same package/driver file download.
    On the X299 folder C:\Program Files\Realtek\Audio\HDA exists, whereas it is not present on the Z590
    I've also attached a list of all of the drivers I have
     

    Attached Files:

  7. chillgates

    chillgates MDL Member

    Dec 15, 2010
    214
    109
    10
    try driver store explorer as erp said. run it as admin and look under "sound,video and game controllers" look for the word "high definition audio device". select all the lines that having these words and select "force delete" button on right side of window. restart system and install your hda driver. remind you again keep internet off for whole process. only after seeing your hda tray icon after reboot, switch on internet.
     
  8. Yanta

    Yanta MDL Senior Member

    May 21, 2017
    311
    150
    10
    #2509 Yanta, Oct 8, 2021
    Last edited: Oct 8, 2021
    I'll try this on the Z590. The X299 is working fine. So I'll leave that alone. I wonder if this is because the Z590 is ALC4080 and the X299 is ALC1220?

    Will let you know how it goes.

    I do keep my PC off internet. In fact, I left it off for 2 days.... I completely forgot to reconnect it :)

    UPDATE

    OK. Used rapr to delete all drivers. There were many but none with a device name of High Definition Audio Device
    Rebooted. Install 9205.1 again
    rapr now only shows the one device
    Still nothing in control panel or system tray.

    Don't know whats going on with all those drivers in firsts screenshot.
     

    Attached Files:

  9. chillgates

    chillgates MDL Member

    Dec 15, 2010
    214
    109
    10
    1) Delete all that says "Realtek semi conductor corp" there and try re-installing again.If that works it is ok. or
    2) Go to this path and see if you have following files --

    C:\Program Files\Realtek\Audio\HDA

    RAVBg64.exe
    RAVCpl64.exe
    RtkNGUI64.exe

    If they are there execute each one of them once.
    Go to classic control panel and see if it shows Realtek HD Audio Manager is there. If it is there from now onwards execute it and set your settings or you can run the regfile i provided here which will put Realtek Manager in startup in registry.

    Save this code as .reg file on desktop and execute it. Add to registry. Then restart system and see if Realtek manager shows in tray icon.
     
  10. Yanta

    Yanta MDL Senior Member

    May 21, 2017
    311
    150
    10
  11. chillgates

    chillgates MDL Member

    Dec 15, 2010
    214
    109
    10
    More tech person should help your case. By seeing your list of drivers in attachment i am feeling there is lot of mess in the system. What happened to your original drivers from manufacturer ? Did you try ?
    If you are convenient to re-install whole wind0ws do it again and try original drivers from manufacturer. And also in admin login group policy , stop updates.
     
  12. Yanta

    Yanta MDL Senior Member

    May 21, 2017
    311
    150
    10
    Yes, I have spent many, many hours trying to fix this.

    I recently tried some older drivers, then installed the later drivers over the top to see if that would work That would explain all the drivers.

    No matter what I try nothing works.

    Having just re-read erpsterm35's post, I am going to install that USB driver on to a clean system with no drivers and then install the HDA drivers and see what happens.

    The MSI website only provides a 13mb UAD driver and nothing else.

    Updates are blocked already. I use WSUS and nothing gets downloaded or installed until approved in WSUS. I've also set "Do not include drivers..." and "do not connect any Microsoft Internet locations..." in group policy. I'm also keeping PC offline for now.
     
  13. chillgates

    chillgates MDL Member

    Dec 15, 2010
    214
    109
    10
    From 6 months i too have problem with UAD drivers. On a fresh 10 install, i tried to install UAD drivers by pal or mokichu and then m$ wont install realtek console manager on my system. It starts install but never ends. I even tried offline uwp app to install console manager, it won't install. Then i sticked permanently with HDA drivers. My mobo is Asus B350. 4 years old.
     
  14. nurofen

    nurofen MDL Novice

    Nov 27, 2017
    23
    1
    0
    help me find the driver for the sound for the ASUS-L210 laptop

    Версия V6.0.9008.1
    2021/04/22
    the asus website is very old
     
  15. Yanta

    Yanta MDL Senior Member

    May 21, 2017
    311
    150
    10
    Yes, I think my mistake was buying the latest tech. I won't buy ASUS because they are under-featured and way overpriced for what you get. At least where I live, which is prison Island. So I'm stuck with MSI or ASRock. I just sent a mobo back for warranty and they are trying to scam me. It had a dead CPU socket, and they told me I damaged the USB 3 connector and want to charge me for repairs. I've built and repaired thousands of PCs and never damaged a mobo ever... so I won't be buying MSI again... Sorry I digress.

    I thought upgrading to ALC 4080 would be a good thing. Seems it was a dumb idea. No fracking console. I've tried may be 10 driver versions now using RAPR to remove the previous drivers, with the internet disconnected and none of them give me a console. I tried many versions on my spare PC, and every single one of them give me the console. The spare PC has ALC1220. Tried an ASRock Z590 Extreme Wifi. It has ALC1220 - again no problems getting the console to work on different versions The ASRock is nahimic (which I don't use), and both the FF00 and FF03 drivers work.
     
  16. chillgates

    chillgates MDL Member

    Dec 15, 2010
    214
    109
    10
    #2517 chillgates, Oct 9, 2021
    Last edited: Oct 9, 2021
    simple solution just buy new sound card from creative. :D I also like built-in graphics and sound so we don't have to spend extra. but i always keep on medium level cpu and board. won't go for high becoz any hardware is going to die after 5 to 8 years.

    Asus prices are high because they give extra warranty than others. Asrock is also a good choice but here in India there is no proper service for it so vendors discourage to buy it.

    My Asus B350 bios spoiled when i was upgrading firmware online. Before that i upgraded firmware continuously for 10 times when new version available. Since it is within warranty , i sent mobo through my seller and they repaired it free and returned in one week. I am using that only now on a 2400g cpu
     
  17. erpsterm35

    erpsterm35 MDL Expert

    May 27, 2013
    1,225
    864
    60
  18. angel1610

    angel1610 MDL Member

    Apr 4, 2009
    183
    30
    10