Upgrade problem: win 10 1607 upgrade to 1709: SOLVED NOW !!!!

Discussion in 'Windows 10' started by snofte, Mar 6, 2018.

  1. snofte

    snofte MDL Member

    Jan 10, 2013
    102
    16
    10
    This automatic upgrade locks up at 75 %. Must power off.
    After restart, it contines to 81 %, then locks up again.
    Power off again, At restart, it says it will reinstall old version 1607.
    Tried manual upgrade, same thing happens, but also a
    message at the end:
    «Windows 10

    Something went wrong.

    Microsoft can`t install important security updates on your PC.

    Please Contact Microsoft for help with this error.

    Please provide the support representative with this error code: 0x80070652”

    Several other similar pc-s upgrade ok, but not this one as mentioned above.
    Tried a lot of things, but stuck. Any suggestions ?

    regards
    snofte
     
  2. kaljukass

    kaljukass MDL Addicted

    Nov 26, 2012
    975
    327
    30
    Usually is two reasons, ie current version is not good, there may be some damaged files, not probably working services, third party firewall or antivirus, which blocks etc.
    And the second which usually afects is not cleaned old installation files, ie there may be too much old .bak files, %Windir%\SoftwareDistribution\Download folder may be full of outdated or damaged downloads etc.
    Has also happened, that user has been blocked so called spying functions and with them also have been blocked updates.
    So, first clean up computer, then run sfc.exe /scannow if needed enable what You have previously disabled, turn off third party antivirus or/and firewall, restart computer and try again.
    C:\Windows\system32\cmd.exe (Run as Administrator)
    sfc.exe /scannow
    Get error list
    findstr /c:"[SR]" %windir%\logs\cbs\cbs.log >%userprofile%\Desktop\sfcdetails.txt
    or use this .bat file
    Code:
    @echo off
    findstr /c:"[SR]" %windir%\logs\cbs\cbs.log >%userprofile%\Desktop\sfcdetails.txt
    Start notepad "%userprofile%\Desktop\sfcdetails.txt"
    exit
    You may also need run dism command to clean windows.

    Deployment Image Servicing and Management tool - DISM

    1. Dism.exe /online /Cleanup-Image /AnalyzeComponentStore
    2. Dism.exe /online /Cleanup-Image /StartComponentCleanup
    3. DISM /Online /Cleanup-Image /StartComponentRestoreHealth
    4. DISM /Online /Cleanup-Image /SPSuperseded (Remove backups after Servicepack is installed)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,492
    1,505
    180
    run a chkdsk /f (cmd right click run as admin) Y to schedule on reboot.
    after done try malwarebytes antirootkit (had one recently infected would not work)
    also tweaking.com windows repair portable. do permissions or win updates preset and check reboot box.
    after done try again.
    also try with mediacreationtool for w10.. that does 1709.. i dload iso and extract with 7-zip.org to folder to run setup.exe
     
  4. snofte

    snofte MDL Member

    Jan 10, 2013
    102
    16
    10
    Thanks both for prompt and good advise. Tried sfc, chkdsk, 4xdism, update troubleshooter.
    No alarms from any of these, and manual upgrade still locks up.
    Also tried media creation tool, it also locks up. Will continue with check of firewall, AV,
    download folder, spying functions, antirootkit, tweaking.com win repair. Will report back
    later (at present busy with other pressing pc-repair stuff for others).
     
  5. mehargags

    mehargags MDL Member

    Dec 1, 2008
    104
    6
    10
    I'm in a same situation with one PC. I've given up the update now and just sitting at what I have now. Will see when I can clean instal 1709.... but very bad update from Microsoft.
     
  6. kaljukass

    kaljukass MDL Addicted

    Nov 26, 2012
    975
    327
    30
    win 10 1607 to 1709 is not like usual update, if to use Windows update system, very often happens, that after last auto restart windows will not start correctly, often stops on the black screen etc.
    Also so or so You need to re-istall some programs, because otherways they will not work correcly, ie some registry data is missing, some shortcuts are missing, some dll's is not registered etc.
    So I recommend the clean install, ie download .esd or iso or media creation tool, make iso, backup Your data and make clean instal and everything is OK.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. snofte

    snofte MDL Member

    Jan 10, 2013
    102
    16
    10
    CASE SOLVED !
    Tried everything under the sun. I also tried a clean install of w10 1709,
    it also gave an error during install. I almost gave up.Until I suddenty came across a post
    somwhere that an add-on card for wifi (Anatel) could cause problems with 1709 Creators fall upgrade.
    This card was found inside the Asus M11AD case, took it out, and BINGO !! A clean install worked
    fine ! The old 1607 disk (the one with the error after upgrade from 1607 to 1709) however, could not be saved.
    All the missing upgrades had messed things up for good. A serious bug in 1709, a wifi card causing lockups
    instead of a normal error warning or whatever if driver could be found ?
    Seems this wifi card creates problems also for other brands, take a look at this post:

    I found the problem on my system and suspect many other "store bought" computers have this same problem. It is a "hardware" problem caused by the WI FI plug-in card made by Anatel. This card has been in my system for four years and was a factory installed Component part of the Gateway DX4860. I connect to the Internet via Cat6 cable so never used the WIFi feature. Many upgrades to Windows have been done on the system without any problem. However, Version 16299 Upgrade does NOT want this WiFi card installed. Pull the WiFI card and the update goes smoothly. Prior to this change the update failed at least 10 times as I searched the Internet for a solution and changed components in my system such as Memory and Hard Drives. If you are getting the "hang at 82%" error, check your internal WiFi card. If it is an Anatel Brand RT3090PCIE, replace it with a different brand or remove it and hook up to the internet with a Cat5 or Cat6 cable. I think many Store purchased systems may have this card installed.
    Disclaimer: I am not claiming there is any defect with the Anatel card. I have not tried any other brand to see if the same Version 16299 hang occurs.
    Hope this solution works for you also.
    T