UWP apps override maximum processor frequency?

Discussion in 'Windows 10' started by will5, Oct 12, 2019.

  1. will5

    will5 MDL Senior Member

    Jun 21, 2007
    260
    38
    10
    Hi guys.

    Using latest windows 10 1903 x64.

    I have some energy profiles on my laptop. Using windows energy profiles.

    I have set maximum processor frequency to 60%, that way cpu goes to a maximum of 1.5ghz instead of 2.8ghz.

    I tried every program and cpu never pass the 1.5ghz mark.

    Even tried intel burn test and cpu stays at 1.5ghz, as expected.

    But I installed some uwp games from windows store. And noticed that cpu goes to 2.2ghz or more. Even if I set maximum processor frequency to 10%.

    So, uwp apps somehow overrides windows maximum cpu frequency?

    There is a way to avoid this?

    Thanks.
     
  2. kaljukass

    kaljukass MDL Expert

    Nov 26, 2012
    1,692
    596
    60
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    26,810
    38,836
    390
    So all non store apps are regulated to the settings you made?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. AndyMutz

    AndyMutz MDL Member

    Jun 30, 2011
    223
    462
    10
    interesting, would be nice to know your hardware @will5

    -andy-
     
  5. toyo

    toyo MDL Senior Member

    Aug 14, 2009
    375
    245
    10
    There's a chance some app changes the power plan when a game is launched. For example, Process Lasso can do that.

    You should be able to track potential changes to the power plan in the Event Viewer>System, as:

    Code:
    EventID 12, UserModePowerService
    
    Process C:\Windows\explorer.exe (process ID:6456) reset policy scheme from {dc5e5dd6-7e13-460f-8abe-73386a0e19cd} to {381b4222-f694-41f0-9685-ff5bb260df2e}

    Vaguely remember that Game Mode/Game Bar can do this sort of power plan switching as well.
     
  6. will5

    will5 MDL Senior Member

    Jun 21, 2007
    260
    38
    10
    Hi guys. Thanks for all that info.

    Sure, all apps are restricted to 60%. Intel burn test is a burn in program to get the maximum performance from the cpu. And it can't pass the 1.5ghz mark.

    Only some store app are getting more than 60%.

    For the info you posted, there are some power plan overrides on store apps.


    Wonder if can be easily deactivated.

    Im using an old i5 3340m. No bios options to reduce speed. But maximum processor frequency on windows power plan was working so well that I can even made profiles for 1.5, 1.8, 2.0, etc. And never gets ignored, until I tried some game store apps and found this.

    Most games are from gameloft. Cant remember about forza street, but I think it respect the power plan.
     
  7. HPLC

    HPLC MDL Novice

    Nov 15, 2016
    24
    13
    0
    Have you tried the Intel Extreme Tuning Utility? I believe it's W7 and W10 only (tho it's not hard to get working on 8 anyway), which works on my i7. If you google "Intel XTU" it should come up. It lets you undervolt/clock etc. I use it to prevent my laptop from turning into a fireball since they boost it 1.2 GHz over it's normal max, I just went in and reduced the clock multiplier, it'd be exactly what you'd wanna do too.
     
  8. will5

    will5 MDL Senior Member

    Jun 21, 2007
    260
    38
    10
    Hi. This cpu line doesnt allow undervolt. Thats why I never used intel xtu or throttlestop

    But if this cant be deactivated I could try them to set a lower speed.

    Laptop gets way too hot with those speeds and most of the time are not needed for the programs I use.

    And windows power management is perfect to set maximum speed. Well it was, until I found this behavior.
     
  9. HPLC

    HPLC MDL Novice

    Nov 15, 2016
    24
    13
    0
    Yea, I'm not sure if it's a undervolt or it just hard limits the speed. But for my application the XTU application worked between power plans (Lenovo's battery thing changes my power plan constantly) and keeps my laptop personally a bit less skin burningly hot. Good luck to ya :)
     
  10. toyo

    toyo MDL Senior Member

    Aug 14, 2009
    375
    245
    10
    #10 toyo, Oct 13, 2019
    Last edited: Oct 13, 2019
    Just to confirm, are you seeing the type of Event 12/UserModePowerService entry in the Event Viewer logs? Which app is responsible for the change of power plan if yes?

    If you don't have apps like "generic Game Booster" or Process Lasso types, it might be the Game Mode. I'll try a test as well with a frequency cap on one power plan, see if Game Mode switches to High Performance from Balanced or Power Saver, for example, and report back, but you can try to disable it in Settings>Gaming>Game Mode, see if anything changes.

    ----

    Tested, it's Game Mode. Disable it, reboot.

    If you're in game mode and run an UWP game (only one i have installed is Gears 5 so that's what I tried with), it will switch (reset?) power plans, it shows rundll as the responsible app:

    Code:
    Process C:\Windows\System32\rundll32.exe (process ID:8476) reset policy scheme from {381b4222-f694-41f0-9685-ff5bb260df2e} to {381b4222-f694-41f0-9685-ff5bb260df2e}

    Edit: Screw the above, this log entry is for me modifying the plan. Looks like the change performed by Game Mode is "muted", or I dunno where to look for it.

    In my case, I modified Balanced to only allow 60% max CPU, but with Game Mode enabled the CPU boosted normally. Had to disable it (and game bar) and reboot, now the 60% limit is respected in Gears 5.
     
  11. will5

    will5 MDL Senior Member

    Jun 21, 2007
    260
    38
    10
    #11 will5, Oct 13, 2019
    Last edited: Oct 13, 2019
    (OP)
    Hi. Disabled game mode and rebooted the laptop.

    Launched zombie anarchy, still goes beyond 60%.

    My power plans are based on power saver plans. Not sure if this has something to do.

    Will try to disable game bar too, but not sure if will help.

    Edit. Disabled game bar too and still boost to more than 60% with zombie anarchy.

    Edit2. Modified balanced power plan to 60%, still boost higher with zombie anarchy.
     
  12. toyo

    toyo MDL Senior Member

    Aug 14, 2009
    375
    245
    10
    #12 toyo, Oct 13, 2019
    Last edited: Oct 13, 2019
    Check the Event Viewer, see if you have any entries for power plan changes when you launch the games.

    Also try this:

    - set the power plan to Balanced
    - edit Balanced to 60% max CPU
    - make sure Game Mode/Bar are disabled with reboot after changing the setting
    - run the problem games

    Edit: if I modify Power Saver instead of Balanced, even with Game Mode enabled the CPU won't get past the 60% cap.
     
  13. will5

    will5 MDL Senior Member

    Jun 21, 2007
    260
    38
    10
    #13 will5, Oct 13, 2019
    Last edited: Oct 13, 2019
    (OP)
    Hi. Have you tried even lower values? Maybe the game doesnt need that much speed if you have a powerful cpu?

    Will have to check the event viewer and report back. Not very familiar with this. Will try to read a little.


    Edit. I can see an event 12 UserModePowerService from some minutes ago. But doenst show again if I relaunch the game.

    Edit2. Seems like event 12 appears when I change between power plans.

    Seems like games are not messing with event 12.
     
  14. toyo

    toyo MDL Senior Member

    Aug 14, 2009
    375
    245
    10
    Yes the events appear if something, or somebody changes the power plan. However, Game Mode seems to operate at a different level.

    My CPU is a 8700K (with a 1070ti and a 144Hz monitor, and the boost behavior is very consistent and reliable, it will boost to 4300MHz for more demanding games, and between 4.4-4-5, very rare 4.6 for old games. It kinda gets stuck at that frequency unless there's some menu or 30 fps cutscene etc.

    With a 60% cap it would instead boost to 2.2 GHz instead and stay there. With Game Mode it will boost back to 4.3, but only in UWP/Store games. Other games are not affected.

    It just might be the case that something else is boosting your CPU. You'll probably have to test until you find the culprit, see if it occurs on a clean Windows install etc. You could also try to buy a laptop cooler pad, or open up the laptop and clean it/reapply thermal paste. If you never opened it to clean it, chances are it will be incredibly dirty inside after years of usage.
     
  15. will5

    will5 MDL Senior Member

    Jun 21, 2007
    260
    38
    10
    Hi. Thanks. Yes, im pretty sure the problem is uwp games.

    Im using a clean install. But never tried uwp games before.

    Will change more parameters and play a little more with game mode to see if can stop boost beyond frequency set.
     
  16. jumy

    jumy MDL Novice

    Mar 3, 2013
    5
    1
    0
    a tip, it won't be the solution for your problems but try ThrottleStop, in techpowerup. (i can't put links)
     
  17. kaljukass

    kaljukass MDL Expert

    Nov 26, 2012
    1,692
    596
    60
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...