V-Tools - toolkit for modifying all MS virtualization products

Discussion in 'MDL Projects and Applications' started by FelixV, Mar 24, 2016.

  1. FelixV

    FelixV MDL Novice

    Nov 5, 2009
    29
    62
    0
    New version released
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. raja16in

    raja16in MDL Novice

    Dec 6, 2009
    2
    0
    0
    the latest version is not able to modify the vmwp.exe of windows 2012. I see that the file size is increasing by 200kb. and SLIC still shows MSFT 2.0. I tried to add dell 2.3. Anyone facing similar issue?
     
  3. achat

    achat MDL Novice

    Feb 20, 2017
    21
    1
    0
    The Slic seems to work, I've tried a few SLP files with no luck.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. FelixV

    FelixV MDL Novice

    Nov 5, 2009
    29
    62
    0
    I'm try to mod vmwp.exe v6.3.9600.18790 (Server 2012 R2) It's modded without any problem. Can you share your original exe?

    Are you use vm gen.1 or gen.2 ?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. sacdmyd

    sacdmyd MDL Novice

    Apr 30, 2011
    13
    0
    0
    Hi,FelixV
    Today,I updated the system to win10 1709 and the vmchipset.dll file updated to 10.0.16299.15. I used V-Tools_1.3.0.21 Mod the vmchipset.dll file OK. But
    it can not work. I can not start my VM. Jump the error window. say about the Digital signatures.....
     
  6. John Smyth

    John Smyth MDL Novice

    Nov 30, 2017
    1
    0
    0
    #66 John Smyth, Dec 7, 2017
    Last edited: Dec 8, 2017
    Hi

    Is there any way to use these tools to update the DMI info in module 6 only?

    I'm using Hyper-V's vmchipset_v10.0.15063.00413.dll file and I'd like to put in custom serial and product etc strings into Type 1. I've hex edited the extracted 06 bin file (from the multi mod) and manually replaced the module in mmtool2, and then replaced the resource in Resource Hacker with the new 13500.rom file, but when putting it back into system32, no VM will start. I'm guessing it's due to the "unlocking" of the BIOS bin to rom which I need to reverse.

    Thanks
     
  7. jackmonter5

    jackmonter5 MDL Senior Member

    Jul 27, 2009
    424
    143
    10
    it seems this software dosen't work with 1703/1709.

    was anyone successful?
     
  8. sebus

    sebus MDL Guru

    Jul 23, 2008
    6,049
    1,858
    210
    I am amazed that it worked as long as that. Digital signature was not introduced last year, it was just MS that chose to ignore its requirement in Hyper-V
    Seems no more...
     
  9. Mrothyr

    Mrothyr MDL Novice

    Nov 10, 2011
    1
    0
    0
    Hi, thanks for your phantastic work. Any chance to implement a function to change the BGRT image? Greets
     
  10. rockenrod

    rockenrod MDL Novice

    Feb 3, 2019
    1
    0
    0
  11. thekidz

    thekidz MDL Novice

    Sep 19, 2009
    7
    0
    0
    Hi there all

    I am thinking about upgrading my server 2012r2 to 2016. I really liked the abilitiy to inject the slic tables into vmwp.exe in 2012. Does this tool still work for 2016? Are there any additional steps required? I don't want to upgrade without confirmation first. Any help would be greatly appreciated,

    thanx
    Craig
     
  12. BuLLets

    BuLLets MDL Novice

    Sep 1, 2010
    10
    0
    0
    Been trying today to get it working on a 2016 server. No good so far.

    Also, just updated my 2012 r2 and modded vmwp.exe from 12/2018, now no 2016 guest will start due to digital signature issue.

    Any help would be appreciated.


     
  13. mbguest

    mbguest MDL Novice

    Jul 24, 2019
    1
    0
    0
    在完成10%时,我也出现同样的问题

    Display: Error allocating Memory.
    There is a solution to this error:

    在原有的中文下改成英文无效
     
  14. steavenku

    steavenku MDL Novice

    Nov 12, 2010
    3
    0
    0
    Is there any updates here?In the latest hyper-v 2016, I can modify the file, but guest stuck at the Hyper-V logo.