Vista has internet connection but can't load homepage

Discussion in 'Windows Vista' started by suziebear, Aug 12, 2009.

  1. suziebear

    suziebear MDL Novice

    Aug 12, 2009
    2
    0
    0
    Please be gentle with me..!!

    I have 2 identical Vista laptops brought at the same time. Mine is working fine but my Son's won't open the internet even though the connection is there. I have tried going to a previous restore point which works until I next turn the laptop on. I have Kaspersky anti-virus. Could it be something on the Windows Update that is causing it.. Please help. My Son is gutted, he's only 5 and I don't want him to lose interest in using his laptop as he's actually very good with it for his age!:confused:
     
  2. Lenmaer

    Lenmaer MDL Addicted

    Jul 3, 2009
    579
    3
    30
    Can he load other pages?
    What are the errors given?
    Do you have some kind of parental control on?

    Maybe try to disable Kaspersky just once and give it a try
     
  3. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    491
    180
    .......................OOOOOKKKKKKKKAAAAYYYYYY>>>>>>>>>>:D:cool:

    depending on the computer, be sure the LAn is on. There is usually a key on the top function bar that activates/inactivates LAN.

    Any hard switch is on..
    Then....

    I would go as far back as possible with the restore, then uninstall the kapersky.(I have an intense dislike for this..find a good free A/V)

    You can install another browser to see if it helps. Which are you using??

    Repair the connection at the network adapter.

    Check the router to be sure no blockage is there(security,mac blocking, etc.). maybe restore the router to factory defaults.

    Have you installed any new games or something that access the internet??

    maybe a driver update crapped it out. Do no accept hardware driver updates from windows unless you know they are good.

    Maybe a repair install of the vista. Restoration of Activation will be a snap ,most likely if this is needed.

    Check the lan switch first..this can be a stinker..LOL If you let me know the type of laptop, it may be easier...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. suziebear

    suziebear MDL Novice

    Aug 12, 2009
    2
    0
    0
    Hi again,
    I've uninstalled Kaspersky, and removed a Ben 10 game that my Son downloaded!! I have tried to repair the network connection (Windows Mail still shows a connection).
    The laptop is a nice and basic Emachines D620.
    In the Control Panel in Network Connections it is showing the Wireless Network Connection as full strength.
    How do I install another browser without using Internet Explorer?? I must sound so thick to all you with tech heads out there!!?!?
    Thanks for trying to help me this one.. :eek:
     
  5. potpotjeng

    potpotjeng MDL Novice

    May 29, 2009
    43
    2
    0
    if you still cannot access the internet, you could try to open the browser,click on tools,internet connections,then click on connections tab and click on lan settings,then choose automatically detect settings.about other browsers, you could download from the site it self on which browser you choose.When the download dialog appears just choose run instead of save.In this way it will download the file and when it is finished it will automatically begin the installation phase.
     
  6. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    491
    180
    download firefox to thumbdrive and install it to the sons machine.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    491
    180
    Check the File download at the far left of the top menu bar.

    Drop down and be sure "work offline" is not checked..
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...