VMware modded BIOS

Discussion in 'Virtualization' started by Loki1973, Aug 10, 2009.

  1. Loki1973

    Loki1973 MDL Novice

    Apr 13, 2009
    8
    0
    0
    #1 Loki1973, Aug 10, 2009
    Last edited: Aug 10, 2009
    Thanks for this fantastic forum!!!

    I found modded BIOS's for all of my systems here, but the final "machine" I want to work with SLIC 2.1 is my VMware ESX Server to have the 2.1 SLIC. I know there has been a (Binbin) BIOS around somewhere but that one doesn't work with Version 7 VM's and only has the 2.0 SLIC.

    In the past (for Vista and W2K8) I've used the tutorial to put in the _ASUS_Notebook SLIC 2.0 which worked like a charm. I used the most recent BIOS included in VMware Workstation 6.5.

    It seems however, that this tut doesn't work anymore for SLIC 2.1.

    I would like to try and mod this BIOS myself, but if someone could put me in the right direction that would be great.

    What I've done so far:

    • I've used the instructions in the tutorial and modified the SLIC to match "DELL " and "M09 "
    • I've copied the DELL.BIN to the TEMP folder of the Phoenix BIOS editor.
    • I've modified the ROM.SCR
    • I modified a DMI string (replaced "VMware Inc." to "VMware Inc"
    • I have built the BIOS
    • I put in the "bios440.filename" option, and I CAN see SLIC inside ACPI when I run RW-Everything. The original BIOS doesn't show that tab.
    • I have installed both the OEM key and the DELL cert.

    It still says "28 days to activate" :mad:

    I know there is a Phoenix topic on this forum, but it is closed, so that's why I'm posting it here.

    Hope someone is able to help me out here.

    Thanks a million.
     
  2. garnichda

    garnichda MDL Novice

    Jul 21, 2009
    7
    0
    0
    i have downloaded it for a while and store it on my hdd. i think someone has extracted the rom file from vmware workstation and did it with phoenix bios editor pro.
     
  3. Loki1973

    Loki1973 MDL Novice

    Apr 13, 2009
    8
    0
    0
    Ah, ok, so you haven't done it yourself. :) No worries, and thanks again.
     
  4. sr71

    sr71 MDL Junior Member

    May 9, 2008
    85
    0
    0
    Thank you. The file also works with VMWare Fusion 4.1.2 on Mac OSX. I could activate WIndows 7 x64 without any problem.
     
  5. Corporal

    Corporal MDL Novice

    Jun 25, 2012
    27
    1
    0
    virtual box is better