VMWare Workstation 10: No internet on guest on NAT Settings

Discussion in 'Virtualization' started by chukwe, Dec 2, 2013.

  1. chukwe

    chukwe MDL Novice

    Aug 1, 2009
    17
    0
    0
    I've a Lenovo W520 running Windows 7 Ultimate X64. I've VMWare Workstation 10 installed as I use it for my SharePoint Development. I've several images ranging from Windows Server 2008 R2 to Windows 2012 R2.

    The problem is that almost 95% of the time, there is no internet on the guest. Sometimes it come & goes, most times none. I always use the default network "NAT".

    How can I fix this issue?

    Thanks
     
  2. MrMagic

    MrMagic MDL Guru

    Feb 13, 2012
    5,702
    3,705
    180
    "VMWare Bridge Protocol" installed on the host network adapter ?
     
  3. trungpt

    trungpt MDL Addicted

    Dec 15, 2009
    517
    48
    30
    I think you should search and ask the official vmware community.

    I don't know why but in my case, my firewall has to allow all vmware services to run and connect to the network. There are about 5 services of vmware running in background: vmware dhcp service, vmware nat service, ... :D

    Hope this helps :D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. jumpup

    jumpup MDL Novice

    Dec 21, 2013
    1
    0
    0
    Ah, my first post! :)

    Back to the question: I had this exact same issue with a fresh install of VMW 10.0.1. At the time, I was connected with wifi on a laptop. I could not get the NAT to pass through an address. @MrMagic is right: check to see if you have the VMWare Bridge Protocol installed with whatever NIC is supplying your network connection. It is the same process if you were adding/removing IPv4 or IPv6. However, instead of a Protocol, select Install->Service
    , and you should see it. .

    These screenshots were taken from a Windows 8.1 session

    bridge1.jpg bridge2.jpg bridge3.jpg


     
  5. warpdrive

    warpdrive MDL Novice

    Sep 11, 2014
    1
    0
    0
    I went into Settings of the VM, selected Network Adapter and went into Advanced and reset the MAC Address. Then I removed the network adapter and while the settings window is open, I re-added another adapter and applied it.

    Got my internet back finally on the guest VM!!!
     
  6. james071

    james071 MDL Novice

    Jul 6, 2014
    28
    2
    0
    tell me more about your setup. are you having a domain controller? did you install vmware tools on each guest ?