[WIN9926] \\sharename is not accessible.

Discussion in 'Windows 10' started by megasound, Jan 24, 2015.

  1. megasound

    megasound MDL Novice

    Jan 8, 2010
    5
    0
    0
    i use a Qnap nas with NO security enabled.
    i can connect from my windows 8.1 machine , i can connect from windows 10 9888

    i CAN NOT connect from my windows 10 9926 machine
    it's giving me the message :

    huh.png

    \\sharename is not accessible. You might not have permission to use this network resource.
    Contact the administrator of the server to find out if you have access permissions.
    The account is not authorized to log in from this station.


    When i make a : net use Z: \\sharename\shareddisk /user:username it goes OK and i can connect true this Z drive.
    But this is not what i (we) want.


    please help us here ...
     
  2. farmers

    farmers MDL Junior Member

    Nov 20, 2011
    85
    38
    0
    I'm seeing this now with my connections to my samba server. Also the 'Windows insider' forum has a thread about this, so it looks like workgroup networking could be completely broken in this build.
     
  3. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,814
    1,997
    210
    Could have several reason!

    I assume you forwarded the Port correctly for the NAS Drive in your Router/Modem? And you have DHCP Server enabled in Router/Modem? That has to be done correctly as well as you should assign for each connected computer and fixed IP because even if you use an Name for the NAS Drive, that is translated back to an fixed IP!

    Than, it's depend on the configuration of that NAS Drive software and driver! Each connecting machine will need to have it;s own Username and Password, which are may hard- or soft coded. Although, if the NAS Drive has some kind Firewall, in and outgoing traffic must be allowed.

    Check the whole settings.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,814
    1,997
    210
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,814
    1,997
    210
    You may didn't need Workgroup, just the IP is enough!

    In Windows Explorer' Addressbar you type 2 backslash followed by the IP of the NAS Drive. Let say those ip is 192.168.1.65 you type in addressbar: \\192.168.1.65 following by press enter That should open the Log On Screen of your NAS Drive.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. farmers

    farmers MDL Junior Member

    Nov 20, 2011
    85
    38
    0
    As I replied above, a number of people seem to be encountering this error with network connections in build 9926. In my case, I'm using a Samba server - others have seen the error with connections to shares on other Windows machines. In all cases, the connections were working before the upgrade.

    Personally I'm aware that it's possible to try either the \\machinename or \\ip_address. Both are giving this error. If I open the \\machinename only, I can actually see the shares but trying to open them gives this error again.
     
  7. farmers

    farmers MDL Junior Member

    Nov 20, 2011
    85
    38
    0
    Ok, thanks to a reply on Technet I have a workaround for this that seems to work !



    Using REGEDIT it's necessary to create a DWORD value called 'AllowInsecureGuestAuth' in HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters and set this new value to 1. A reboot will also be necessary.
     
  8. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,814
    1,997
    210
    Check the Windows internal Firewall! The whole is simply an Config Problem!

    Right click on the Start Buttom and chose Control Panel, go the Windows Firwall and chek all settings. You'll need to allow in- and out going Traffic, even if those runs within your LAN! Also check on the same place that the Private Network is enabled and configured! It's Not an problem of windows, it's just an problem of configuration and security of your network!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. farmers

    farmers MDL Junior Member

    Nov 20, 2011
    85
    38
    0
    If you see my more recent reply, someone posted a workaround on Technet when I asked there about the issue. It seems to be about 'Guest' type shares, and apparently the latest build of Win10 deals differently with them. Nothing to do with the Networking side.
     
  10. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,814
    1,997
    210
    It simply has a lot to do with Network and Network Security! Network is much more than just connect some computers together using an wired or wireless connection! Proper configuration is the A & O (Alpha & Omega/Start & End) of an network.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. farmers

    farmers MDL Junior Member

    Nov 20, 2011
    85
    38
    0
    Yes, it's the security side of it. Apparently the latest build handles things slightly differently, in a way that breaks 'guest' type connections sometimes.
     
  12. st_7

    st_7 MDL Junior Member

    Dec 19, 2009
    99
    3
    0
    @Pisthai, If you re-read all the posts of @farmers carefully, his problem isn't in his configuration(network or firewall) but in the latest build(how can many others have same issue if the problem is not with the latest build). And he also posted a fix for the issue(registry workaround) that is given on the technet thread.

    He(OP, to whom you replied) clearly mentioned that he intentionally a network drive Z: to connect to NAS because he couldn't connect directly or normally. And as far as I know, you can make a network drive from any share(whether it's NAS or folder or whole drive shared on the network), so it isn't something to be surprised.

    And @farmers, thanks for posting the fix, it will certainly help others.
     
  13. L0giX

    L0giX MDL Novice

    Jun 25, 2014
    2
    0
    0
    Had the same problem this morning, Spent hours pulling my hair out.
    Finally fixed it by..

    1) Go to Credential Manager, typed Credential in search
    2) Click on Windows Credentials
    3) Clicked 'Add a Windows Credential'
    4) Typed in the name of my NAS in. Did try the ip address but did not work. If it is already there, Delete it and re add.
    5) Added user name and password for the admin account of the NAS

    It now works for both username/pass and guest accounts where it worked for neither before. you may need to restart PC.
    Hope this works for you too..
     
  14. tonyh2004

    tonyh2004 MDL Member

    Aug 2, 2011
    147
    30
    10
    just to let you know I tried for hours to sort it too but your method works like a charm perfect and so easy thank you for the post :worthy:
     
  15. L0giX

    L0giX MDL Novice

    Jun 25, 2014
    2
    0
    0

    Glad it worked for you mate :)