Windows 10 network connections crash after updates

Discussion in 'Windows 10' started by Erik B, Jul 28, 2015.

  1. Erik B

    Erik B MDL Junior Member

    Oct 10, 2008
    74
    18
    0
    #1 Erik B, Jul 28, 2015
    Last edited: Jul 28, 2015
    I have a small Active Directory network. My new Windows 10 pro machine had no trouble to find the network and make the right settings on install. I registered the machine in the AD from the Windows 10 System window and everything just went smooth and easy.

    Now after Windows Update had done some updates I somehow lost some network settings (or they got altered during boot) and Windows 10 can no longer find the AD servers (I guess DNS failure). If I try to check network adapter settings the Network connections window crash immediately. Things gets a bit complicated as I also have a Hyper V switch (which is thus the main adapter by the way Hyper V works).

    I think the last update was KB3074678 but I'm not sure it is the one that crashed the network. Anyone with KB3074678 have the same problem with the Network connections window?

    edit:
    Or: How to change DNS server without the Network connections window?
     
  2. AzTec

    AzTec MDL Member

    Aug 4, 2009
    117
    27
    10
    KB3074681 caused the problem, jus check for update KB3074683, it fixes the problem, there are threads here talking about it if you look
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Erik B

    Erik B MDL Junior Member

    Oct 10, 2008
    74
    18
    0
    #3 Erik B, Jul 28, 2015
    Last edited by a moderator: Apr 20, 2017
    (OP)
  4. MrMagic

    MrMagic MDL Guru

    Feb 13, 2012
    5,706
    3,711
    180
    #4 MrMagic, Jul 28, 2015
    Last edited by a moderator: Apr 20, 2017
  5. Erik B

    Erik B MDL Junior Member

    Oct 10, 2008
    74
    18
    0
    #5 Erik B, Jul 28, 2015
    Last edited: Jul 28, 2015
    (OP)
    Ah, thank you! :worthy: And the KB3074683 just appeared in Windows Update, installing now. Hope hope hope

    edit:
    It worked, everything is OK now, thanks all