Windows 10 Recovery issues with winre.wim

Discussion in 'Windows 10' started by Timi, Aug 10, 2015.

  1. Timi

    Timi MDL Novice

    Mar 22, 2012
    5
    0
    0
    #1 Timi, Aug 10, 2015
    Last edited by a moderator: Apr 20, 2017
    Hi all,

    i was wondering if anyone can help me with the issue i am having on a tablet i have.
    the tablet is a linx7 but there are many about. it has 1gb ram, an z3735 atom and 32gb emmc.

    i managed to install a clean version of window 8 pro while wiping the drive. that included the recovery drive which had the wimboot files. i then did a windows 10 upgrade.

    after the 10 upgrade, i did a "normal" clean 10 install but never connected to the internet. i didnt want to activate and wanted to test a few things. after i was happy with 10 and it's performance on this device, i wanted to try create a wimboot for the device. i couldn't find a guide for "dummies" but eventually found and followed this guide(cant post links).
    Code:
    instructables.com/id/How-to-Create-a-Wimboot-Installation-of-Windows-81/?ALLSTEPS
    i changed a few things though. for the install i used a 10.iso and added all the drivers i needed. this is so touch would work during install/set up/when i want to reset the pc.
    also rather than doing the image set up in a virtual pc, i used the actual tablet.
    during the procedure, i noticed i did not have winre.wim in the system32/recovery directory. a quick search said not to worry and that i can extract winre.wim from boot.wim. i followed the guide and ran the relevant dism commands and had a dumo of winre.wim in the folder i had assigned it to.
    everything went smooth after that.
    i activated my image and did the relvant updates while in sysprep.
    once the system rebooted, i did another reboot before sealing the image and running oobe.
    i then captured the image.
    wiped the emmc on the device.
    set up the partitions, dumped the images onto the recovery drive i just created. instead of using the folder "sources" i used the name "images"

    i registered the recovery environment as instructed
    Code:
    W:\Windows\System32\reagentc /setreimage /path R:\Images /target W:\Windows
    once completed i did a reboot.
    was extremly happy that everything was working as planed, or so i thought.
    only used 2.8 GB for the install and recovery partition i created was 4GB (only required 3.4gb)

    now after the set up, i went into settings, update & security, reovery.
    i click get started below "reset this pc"
    i then click remove everything.after a few seconds, i get an error messege that it could not find the recovery environment.
    it asks me to insert my windows installation or recovery media.
    a bit gutted as i never had to when it arrived with 8.1. i understand it had to in 8.1 pro as i didn't have the files on the drive.
    i checked under advanced start up and sadly no recovery options there either.

    so i tried to investigage and opened reagent.xml in c:\windows\system32\recovery\

    it has the correct imagelocation path, i.e."\Images"

    i dont work in IT and just try learn stuff as a hobby. the guys here always teach me useful things

    thanks for any help in advance.
     
  2. ColdZero

    ColdZero MDL Addicted

    Nov 9, 2009
    637
    2,887
    30
    Hi,
    Windows 10 does not use Wimboot...
    Now it is called "Compact" (Dism command /compact).
    You should deploy Windows to your tablet by using "Compact". (Complicated IT stuff if you are a beginner)

    If you did a clean installation without using "Dism commands" then you don't have a Recovery mode.
    But it is not a big deal...
    Just build a Pendrive with the Windows Setup files... and while in recovery just insert it and done!
    :tea:
     
  3. Timi

    Timi MDL Novice

    Mar 22, 2012
    5
    0
    0
    #3 Timi, Aug 15, 2015
    Last edited by a moderator: Apr 20, 2017
    (OP)
    Thanks for the reply ColdZero.
    any idea how i can go about making it a "compact" install then?
    if i did a normal install, recovery works fine with 10 actually. it resets. but its taking up a lot of space in comparison to a wimboot install.

    after a lot of trial and error i have managed to get wimboot to work though.
    i hope that this might help someone who tries something similar.

    disclaimer?
    Code:
    i would like to say i am not an expert but i like learning new things and play around with computers a lot. what ever you do with your device, you decided to do it
    Tools before i started
    Code:
    Hirenboot CD on a usb - i know, it doesn't work with uefi
    windows 10 usb
    wireless keyboard and mouse (k400)
    a usb hub
    on the go cable
    a usb with a image capture i created after activating in sysprep
    i booted from win10 usb and installed 10 again.
    i didn't connect to the internet or anything. setup was finished and i was at the desktop.
    i rebooted device and selected my windows 10 usb again.
    i pressed shift + f10. this opened a command promt window on top of the setup.
    i did diskpart, list volume. this was to see what was mounted and where. i made a note of this. then exit diskpart
    i typed in D:\hbcdmenu.cmd to open hirenboot cd menu which was mounted on. i used the partition tool on this.
    i deleted c completly and moved the system partition and then enlarged the recovery partition to 4096MB. i knew after i put my captured image in this partition i would still have some room to spare-i could have made it 3.5gb but thought it was best i leave it to 4gb.
    i did a reboot, back into the windows 10 usb and again shift f10.
    did a diskpart, select volume 0 (which was were c:\ was mounted) and format quick fs=ntfs label="win10"
    assigned a letter to it. then i selected the recovery parition which was now 4gb.
    i copied over my install.wim into a newly created folder called win_image using robocopy command.
    then applied the install image using dism apply-image command from the recovery drive to the c drive.
    i then opened hirenboot cd again looking for notepad++
    i changed the location values off reagent.xlm on the recovery partition and on the system32/recovery.

    i restarted the device and windows started to initial setup (screen where you add user name etc)
    after windows logged in, i did a system, recovery, reset pc. and to my suprise it worked.

    my conclusion is i'm not setting up reagent.xlm properly if i do it the correct way, or i'm not setting up the boot parameters properly.

    i will play around with it more despite it working for me. heck i like learning thats why :)

    peace and love to all at MDL