Windows 7 doesn't remember wireless network & password

Discussion in 'Windows 7' started by spiderpc, Aug 9, 2012.

  1. spiderpc

    spiderpc MDL Novice

    Jul 31, 2012
    6
    1
    0
    Hi,

    I bought a new laptop (Samsung NP300E5Z-S07RO), I installed Windows 7 Home Premium and installed all needed drivers but I have a frustrating problem which I didn't solve it yet.

    Each time I start Windows (actually each time I connect to an wireless network), I need to manually connect to my wireless network and manually add password even if it is checked to connect automatically next time. Why it is not remembered?

    Wireless network adapter is Intel Centrino Wireless-N 130.

    I need some help, thanks. :worthy:
     
  2. logicwatch

    logicwatch MDL Member

    Jan 26, 2011
    247
    22
    10
    #2 logicwatch, Aug 9, 2012
    Last edited: Aug 9, 2012
    is there an updated driver you can try for your wireless card I have had similar issues in the past and either 1. updated driver 2.different connection software ie.
    dont use intels wireless manager try using windows in built software instead 3. use a different wifi adaptor ie. mini usb wifi adaptor only cost less than £10 4. security encryption settings on your router ?
    one of these methods will usually sort the issue out
    good luck ;)
     
  3. hbhb

    hbhb MDL Expert

    Dec 15, 2010
    1,017
    263
    60
    yes for the above, also adding the connection manually helps at time, meaning go to your wireless settings, add your SSID, password, encryption and all :D
     
  4. spiderpc

    spiderpc MDL Novice

    Jul 31, 2012
    6
    1
    0
    #4 spiderpc, Aug 9, 2012
    Last edited: Aug 9, 2012
    (OP)
    1. I installed the newest driver available (15.1.1.1) from Intel website but the issue is still reproducing.

    2. I am not using a specific connection software, connection to wireless network is done using Windows (default mode to connect to an wireless network). But I see something installed in C:\Program Files\Intel\WiFi\Drivers, there is an executable named iprodifx.exe. If I execute it I see an icon on the screen and wireless connection is disconnected and I need to reconnect it again manually. I was thinking this might cause the issue but I'm not sure how...

    Capture.JPG

    3. I don't want to use an external wifi adaptor just for this, I believe it can be fixed, but it is something tricky. The would be the ultimate solution.

    4. I also think security settings on my router are not related to my problem, because it happens with any wireless network, even with the ones created with mobile phone while other laptop works fine.

    Any other ideas?:unsure:


    That's weird. I went to "Manage wireless networks" from Control Panel, but I don't see any wireless network there. And if I'm trying to add one, I get access denied when trying to save credentials of the new network.
     
  5. urie

    urie Moderator
    Staff Member

    May 21, 2007
    8,707
    3,064
    300
    By that do you mean anything trying to connect to your wireless router ? I still think that's where the problem is when you set it up at first with first laptop you would have probably added encryption later.
     
  6. spiderpc

    spiderpc MDL Novice

    Jul 31, 2012
    6
    1
    0
    Anything else trying besides my new laptop can connect to my router automatically, after first connection was done (because the network is saved).

    Also, I was saying that I tried to connect with my new laptop to another wireless network (created via tethering from a mobile phone) and the result is the same: the network and password is not remembered after first connection, I always need to do it manually.

    I still think the problem is in Windows.
     
  7. logicwatch

    logicwatch MDL Member

    Jan 26, 2011
    247
    22
    10
    #7 logicwatch, Aug 9, 2012
    Last edited: Aug 10, 2012
    try installing intels wireless application instead of using windows wireless app.

    Wireless_15.2.0_Ds32.exe
    Version:15.2.0

    go to intels site and try the above program remember its the wireless application that your interested in trying instead of the standard windows method if all goes well it installs new icon on your desktop and task bar so try re-connection with this instead.

    ]
     
  8. FFManHole

    FFManHole MDL Member

    Nov 27, 2009
    183
    66
    10
    @ spiderpc

    Firstly, this will more than likely will not apply in your situation, let alone your specific laptop model, since I didn't keep the page / link. And you probably have already tried these simplistic options (if available) anyway.

    A workaround to access the wireless switch after laptop has booted up is using the Function key, F12, which is nothing more than a shortcut. And I think you still need to add password manually anyhow.

    Another suggestion was to turn off 'Eco Mode' which can be found in the laptop's Easy Settings / Power Management. Not sure what this would achieve (other than keeping the wireless connection 'always' active) and cannot see how that would help with your issue of adding network / password every time you boot up.

    As I said, they are only options, not solutions ... which you've probably investigated already.

    +1 @logicwatch suggestion
     
  9. spiderpc

    spiderpc MDL Novice

    Jul 31, 2012
    6
    1
    0
    #9 spiderpc, Aug 10, 2012
    Last edited: Aug 10, 2012
    (OP)
    Well, none of the suggestions given didn't solved the problem (not even by installing Intel software for wireless networks). BUT what I was saying in the previous post gave me a hint: "
    I get access denied when trying to save credentials of the new network." --> from here I presumed it might be a writing permission issue for saving the network profile whenever I was trying to connect a an wireless network. :Lighten:

    I investigated a little to see where network profile is saved, then I understood I need to take ownership of the following folder c:\ProgramData\Microsoft\Wlansvc\Profiles\ . After I did this, I went to control panel, I added the network manually (as suggested by hbhb), network was succesfully saved, then, after restart, connection to wireless network was done automatically. :yeahyeah:


    Take Ownership thing is :mad2:...
     
  10. logicwatch

    logicwatch MDL Member

    Jan 26, 2011
    247
    22
    10
    great well done pleased the mystery is finally solved :thumbsup:
     
  11. hbhb

    hbhb MDL Expert

    Dec 15, 2010
    1,017
    263
    60
    good job, perseverance pays:D
     
  12. mohitkumarsen

    mohitkumarsen MDL Novice

    Sep 5, 2012
    25
    8
    0
    Thanks to all. While thanks specially to hbhb for remembering again "perseverance pays", I would like to place my recent networking problem. Since last few days (may be wrongly use of advanced system optimiser software) I have been facing a problem.Each time I start Windows or restarts (actually each time I connect to a wired network i.e. Broadband),
    I need to manually add username id & password to Connect Broadband wizard.
    I am unable to check (i.e. to put a tick) the boxes meant for that to save this user name and password for the following users for its next time usage (i) for me only or (ii) for anyone who uses this computer.
    Why it is not remembered? I need help, Please help me. Each time I have call the wizard "Connect Broadband" & put data.
    Network adapter is Realtek PCIe GBE Family Controller. Mine is a desktop PC
    . Username & password.jpg
     
  13. PhaseDoubt

    PhaseDoubt MDL Expert

    Dec 24, 2011
    1,448
    278
    60
    @mohitkumarsen Should I interpret the "Thank You" to mean your problem is solved?
     
  14. bencasina

    bencasina MDL Novice

    Jul 12, 2009
    31
    3
    0
    the window you are showing here is for a dial up connection you don't need this for broadband, wired or wireless. go into internet options and tick box never use a dial up connection,.
     
  15. mohitkumarsen

    mohitkumarsen MDL Novice

    Sep 5, 2012
    25
    8
    0
    #16 mohitkumarsen, Nov 8, 2012
    Last edited: Nov 8, 2012
    Hello Sir PhaseDoubt, Excuse me, I am a bit of late to report back, as I was outside. My problem has not yet solved. After every booting/restarting I am to put my user id and password afresh to make a connection as because all the save buttons of the network connection wizard appears to have been dead. Thank you,

    @bencasina sir, as advised I went to internet options and found that there was a tick/check in the box never use a dial-up connection.
    mohitkumarsen