Windows 7 Permission and Saving Errors

Discussion in 'Windows 7' started by EneergE, Feb 27, 2010.

  1. EneergE

    EneergE MDL Novice

    Dec 13, 2009
    15
    0
    0
    Just out of curiosity, has anyone else been running into an unusual amount of "permission denied" and "file is in use by another process, can't save to this location" type errors in their Windows 7 system?

    I seem to get this everyday while working with something. For an example, I downloaded a file, copied it to another drive, then decided to delete the source. Permission denied resulted. The file had already completed transferring to the destination (was a small file).

    Also, I just opened up one of my batch scripts to modify a few things, and when I went to save, it gives me a "file in use, cannot save to this location" crap.

    And more on, when I'm working on a coding project in Visual Studio 2008 SP1, up-to-date, I usually run into the same stuff. The compiler will not work, because it cannot gain access to the files within the bin or release folder. This was a fairly common issue, it seems, and you could fix it by creating a pre-compile script to delete the files before running. However, this fix didn't seem to work all of the time for me and I still run into the error about 60-70% of the time if I do too many quick compiles within a certain time range.

    I'm running the original Windows 7, direct from Microsoft (checksum passed). I've only integrated a few updates into my image using dism.

    I have a program that is suppose to "unlock" a file so I can do whatever I want to with it, but by the time I actually find that app buried somewhere 10 folders deep on some drive, I can just delete it normally. After about 2 minutes or so, I will regain access to these files. I can't afford to wait 2 minutes to do a basic delete operation.

    Has anyone else here noticed an overwhelming number of these lock issues? Perhaps this could be attributed to a service I have disabled? Anyone have any ideas?
     
  2. venu

    venu MDL Addicted

    Oct 16, 2009
    894
    99
    30
    1. Run Command Prompt as Administrator.

    2. type: net user administrator /active:yes

    3. Log out

    4. Choose Administrator

    This is the full administrator that M$ disables by default, use this to install software or as a general account if you want.
     
  3. EneergE

    EneergE MDL Novice

    Dec 13, 2009
    15
    0
    0
    Thanks for the answer.

    However, I'm not sure that this is actually the problem. Whenever the permission error pops up, it brings up the UAC prompt asking me to continue. Even after I continue, I still get these errors.

    I'm not sure it's a case of "permissions" but more of a case of it "thinking there's a permissions" problem. I'm going to disable UAC the next time I work on something and see if that helps, but I think I did this once before and it did not work, either.

    Also, I'm not sure that that's really the best solution since I, fairly common, edit scripts and delete files. I would have to log in as Admin all of the time, which isn't really a good idea.

    Still open for suggestions.

    Thanks
     
  4. venu

    venu MDL Addicted

    Oct 16, 2009
    894
    99
    30
    Well, i recall having similar file saving problems and file in use problems when I first switched from vista to win7. Try this:
    Give yourself full permission on each of the drives on your computer.
    E.g. D: drive-right click-properties-security-Users-Edit-check all the boxes under Allow-OK
     
  5. Phazor

    Phazor MDL Expert

    Sep 1, 2009
    1,145
    517
    60
    This can be caused by resident on-access virus scanners.

    The process goes like this:


    0) You or your app requests access to a file (save/delete operation)

    1) Windows processes the request

    2) The AV, just as it should, intercepts the request and initiates an on-access scan

    3) The on-access scanner doesnt release the file fast enough

    4) Windows sees the file as 'in use' and pops up the error

    5) The request fails


    Of course this does not necessarily have to be the problem in your case, but its one thing i know that can cause such errors...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. dabits

    dabits Guest

    #6 dabits, Aug 28, 2010
    Last edited by a moderator: Aug 28, 2010
    I have been searching for hours, and this thread comes close to my problem.

    I have an Asus notebook with Windows 7 Home Premium x64, and I have no problems with that.
    Yesterday I installed "The Official Windows 7 Repository" x64 version on my desktop, and I have lots of problems.

    - I opened an existing textfile somewhere on my D: drive and got an error when trying to save it.
    - After moving the personal folders from C:\Users\MyName to D:\MyName I got the same error there.
    I could not open a new textfile in My Documents, then edit it and save it.
    - I did a fresh install, opened a new textfile in My Documents (still in C:\Users\MyName) edited it and saved it ... no problem.

    I simply Cut and Pasted the folders from C:\Users\MyName to D:\MyName.
    I did that on the notebook and it worked there.
    I tried it again, changing their location one by one, but i had the same problem.

    UAC is set the same way on both machines.
    Why can I edit + save textfiles on one machine and not on the other?
    What is the difference, or what am I doing wrong?

    I restored an old Acronis-Vista Image, and use that now, but I will install Windows 7 again later today.
    But I would like to be able to edit and save textfiles/documents when they're outside of C:\Users\MyName.

    I will try venu's tip, and give myself full permission on all of the drives.
    I found a TakeOwnership regfile, can anybody tell me if that works?
    Any help would be appreciated.
    What drives me crazy is the fact that I have the problem on one machine and not on the other.
    Or did Asus solve the problem for me?
    The notebook has a legal Windows 7 on it, but also all the pre-installed software that you don't need.
    I was going to install a clean Windows 7 on it, but only after I solve this problem ...
     
  7. Matrix Leader

    Matrix Leader MDL Addicted

    Dec 8, 2009
    857
    175
    30
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. EneergE

    EneergE MDL Novice

    Dec 13, 2009
    15
    0
    0
    I know this thread is old, but I just noticed this and thought I would go ahead and answer the issue so the thread would be complete.

    My issue turned out to be with the Application Experience (AeLookupSvc) service being disabled. When it's disabled, apparently the OS still tries to check for compatibility problems. I'm just guessing at this, but it appears that even after closing program, sometimes it continues to wait for a response from the Experience service about the compatibility. Then when you go to delete or overwrite it, you can't because it's locked.

    Not exactly sure about the ultimate details on this one, but to fix it, I went into gpedit.msc (Pro and up only, sorry) and selected "Turn off Application Compatibility Engine".

    If you still get the error, you can try re-enabling this service to fix the problem (sc config AeLookupSvc start= Auto | sc start AeLookupSvc).