Windows 7 Ultimate--firewall settings, tell me what i can disable--cpu usage too high

Discussion in 'Windows 7' started by stayboogy, Jun 9, 2011.

  1. stayboogy

    stayboogy MDL Addicted

    May 1, 2011
    716
    116
    30
    #1 stayboogy, Jun 9, 2011
    Last edited: Jun 9, 2011
    please tell me what i can disable in the firewall settings so that just regular internet browsing and file downloading and windows update will work correctly with a all time wired ethernet connection, never use wireless because there is no sense in a million and one crap services running all @ once and 13+ svchost.exe processes running all the time.

    please, some expert advice...

    almost regretting even trying to use 7 @ all--about ready to go back to full XP use over this crap...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. DAz999

    DAz999 MDL Member

    May 19, 2007
    132
    35
    10
    #2 DAz999, Jun 9, 2011
    Last edited: Jun 9, 2011
    ok, you have given little details, but if you are running 64bit Win7, then with your spec I would run 32bit, cause you have such a low spec, plus you are running ultimate which is way too heavy for your spec, I would recommend you install Windows 7 home Basic, which I have installed on your type of system and the load is much lighter on the system. to unlock all versions of of win 7 delete the ei.cfg from the sources directory in your install iso or you can use a tool in the "The Official Windows 7 Repository" then use DAZ loader to licence your system.

    Then you will find your system running much better
     
  3. stayboogy

    stayboogy MDL Addicted

    May 1, 2011
    716
    116
    30
    already got the DAZ loader loaded and i'm activated and just finished with windows updates, and my dual boot working perfectly so there's no way i'm doing another clean install--this took hours to get all done.

    i'm using x86 version already from the "universal" dvd. i just think it's ridiculous to have 13+ svchost.exe process running and they are all due to all these crap firewall settings. that's all i'm trying to figure out as i'm pretty sure that will fix my performance issues because other than those processes, it runs absolutely great with my specs...

    i did have to set my own pagefile size which has helped a lot since my first post, still would like some ideas on what all can be disabled in firewall and in services though...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. UVAIS

    UVAIS MDL Expert

    Mar 17, 2011
    1,333
    1,890
    60
    Stop unnecessary Services & Programs from Startup ;)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...