windows 8 internal hard drive recognized as removable device

Discussion in 'Windows 8' started by bertikul, Aug 24, 2012.

  1. bertikul

    bertikul MDL Member

    Nov 2, 2007
    204
    21
    10
    Hi everyone

    Windows 8 internal hard drives are recognized as removable device. Is there a registry hack to change that? The windows 7 workaround:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci\Controller0\Channel0]
    "TreatAsInternalPort"=dword:00000001

    doesn't work for windows 8.

    Anyone has a solution for that?
    Thanks
     
  2. CATALINZX

    CATALINZX MDL Novice

    Jul 11, 2011
    42
    7
    0
    I have this problem too....I have an nvidia chipset but I can't use their drivers because they don't support TRIM, so If anyone could make TreatAsInternalPort reg tweak work for windows 8 would be awesome!:worthy:
     
  3. bertikul

    bertikul MDL Member

    Nov 2, 2007
    204
    21
    10
  4. CATALINZX

    CATALINZX MDL Novice

    Jul 11, 2011
    42
    7
    0
    I have an NVIDIA Chipset, intel rapid storage driver works ony on intel chipset:negative:
     
  5. NTAuthority

    NTAuthority MDL Novice

    Dec 20, 2007
    6
    0
    0
    This registry value still is read from storahci.sys; you could try changing 'msahci' to 'storahci'.
     
  6. CATALINZX

    CATALINZX MDL Novice

    Jul 11, 2011
    42
    7
    0
    I tried and it does not work:(
     
  7. CATALINZX

    CATALINZX MDL Novice

    Jul 11, 2011
    42
    7
    0
    For me it does matter....I don't like that stupid icon in the right corner:rifle:
     
  8. CATALINZX

    CATALINZX MDL Novice

    Jul 11, 2011
    42
    7
    0
    Nvidia drivers don't support TRIM(I have an SSD), I must use the default Microsoft AHCI driver:wallbash:
     
  9. bamse

    bamse MDL Novice

    Dec 16, 2009
    8
    0
    0
    i just disabled autorun on win8 with my ssd disk. everything else still runs normal and smooth :)
     
  10. tithitoy

    tithitoy MDL Novice

    Aug 27, 2007
    42
    2
    0
    #11 tithitoy, Sep 19, 2012
    Last edited: Sep 19, 2012
    you can try enable TRIM manual: (Because TRIM is supported by OS, not by Driver)

    Go to the Command Prompt (Admin) and type:

    fsutil behavior set disabledeletenotify 0

    You can also check TRIM status:

    In the Elevated command Prompt windows, type the following:

    fsutil behavior query disabledeletenotify
    Results explained below:
    DisableDeleteNotify = 1 (Windows TRIM commands are disabled)
    DisableDeleteNotify = 0 (Windows TRIM commands are enabled)