Windows 8 pro help with unsigned drivers

Discussion in 'Windows 8' started by dancer_69, Jul 26, 2013.

  1. dancer_69

    dancer_69 MDL Novice

    Nov 23, 2012
    19
    1
    0
    I want to install an unsign driver on windows 8 pro, and I cannot find a way to do it. I've found some solutions but none works.
    First tried the advanced startup options from Settings-> General -> Advanced startup
    but there is no option advanced startup on Trubelsooting. Just there isn't one there.

    I tried the command:
    bcdedit /set loadoptions DDISABLE_INTEGRITY_CHECKS
    which suggested and in a thread here, but it doesn' t work too. I get the error:
    The boot configuration data store could not be opened.

    I also tried with msconfig.exe, but I cannot find an option there, and I cannot check any of checkboxes on Second tab(Boot computer or something similar is the title) or buttons as "Advanced", "set as default", "delete". This tab is completely unreachable.

    I tried some repair and diagnostic options of windows 8, but doesn't change anything.
    Can someone help me?
     
  2. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,816
    1,998
    210
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. dancer_69

    dancer_69 MDL Novice

    Nov 23, 2012
    19
    1
    0
    #3 dancer_69, Jul 26, 2013
    Last edited: Jul 26, 2013
    (OP)
    No it doesn't, the problem is that after step 7. Troubleshooting, I have the Advanced options entry, but not the Startup Settings.
     
  4. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,816
    1,998
    210
    Please post a screenshot of that page!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,816
    1,998
    210
    #5 pisthai, Jul 26, 2013
    Last edited: Jul 26, 2013
    It;s precisely:

    under Advanced options: Start-up Settings

    The other options are:
    System Image Recovery
    Automatic Repair
    Coammnd Prompt
    and final: Start-up Options!!!!!!!!!!

    I using Windows 8 Pro with WMC, legal activated
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,816
    1,998
    210
    And just before anybody start's complaining it has problems under Windows 8.1: that did NOT work in Windows 8.1!

    Note: while the computer is restarting it gives you the option from 1-10 include the driver Digital Signature Enforcement or you could carry on and boot to Windows 8.

    This is a temporary solution for to disable the Driver Signature Enforcement!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. dancer_69

    dancer_69 MDL Novice

    Nov 23, 2012
    19
    1
    0
    I don't have that. I have:

    System restore
    System Image Recovery
    Automatic Repair
    Command Prompt
    only.

    Sorry I cannot post links or images yet.
    Using windows 8 64bit pro with WMC
     
  8. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,574
    15,383
    340
    #8 Tito, Jul 26, 2013
    Last edited by a moderator: Apr 20, 2017
    Type the following in Run:
    Code:
    Shutdown -r -o -f -t 00
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,816
    1,998
    210
    OK, try this:

    To disable the Driver Signature Enforment in Windows 8 (NOT 8.1) permanent, do the following:



    • Open the command promt as "Run as Administrator".
    • Type: "bcdedit -set loadoptions DDISABLE_INTEGRITY_CHECKS" (without the "").
    • Type: "bcdedit -set TESTSIGNING ON" (without the "").
    • Reboot and you're done.
    Note: the double DDISABLE is correct!

    To re-enable it run these commands

    Open the command promt as "Run as Administrator"

    • Type: "bcdedit -set loadoptions ENABLE_INTEGRITY_CHECKS" (without the "")
    • Type: "bcdedit -set TESTSIGNING OFF" (without the "")
    • Reboot and you're done.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. chinobino

    chinobino MDL Member

    Jul 28, 2009
    160
    56
    10
    #10 chinobino, Jul 26, 2013
    Last edited by a moderator: Apr 20, 2017
    The only way I have found to run unsigned drivers (without issue) is by using test mode.

    So if you want to try test mode, open an elevated command prompt and type the following 2 lines;
    Code:
    bcdedit -set loadoptions DISABLE_INTEGRITY_CHECKS
    bcdedit -set TESTSIGNING ON
    Then reboot.

    Note that you will have the "test mode" watermark on the desktop afterwards and Windows will stay in test mode unless you disable it again.

    [Edit] Looks like Pisthai beat me to it.
     
  11. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,816
    1,998
    210
    #11 pisthai, Jul 26, 2013
    Last edited by a moderator: Apr 20, 2017
    And your code isn't correct: DDISABLE!!!! Not DISABLE!:D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. dancer_69

    dancer_69 MDL Novice

    Nov 23, 2012
    19
    1
    0
    Thanks for your help both, but you didn' t notice my first post in which I wrote that this doesn't work also:


    C:\Windows\system32>bcdedit -set loadoptions DDISABLE_INTEGRITY_CHECKS
    The boot configuration data store could not be opened.
    The requested system device cannot be found.
     
  13. chinobino

    chinobino MDL Member

    Jul 28, 2009
    160
    56
    10
    Works for me :).
     
  14. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,816
    1,998
    210
    That your machine isn't correctly activated!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. dancer_69

    dancer_69 MDL Novice

    Nov 23, 2012
    19
    1
    0
    #15 dancer_69, Jul 26, 2013
    Last edited by a moderator: Apr 20, 2017
    (OP)
    If this is for me:

    Code:
    Windows is activated
    
    Windows currently running on your PC is activated.
    
    Current edititon
    Windows 8 Pro with Media Center
    Current product key
    *****-XXXXX
    
    Activated on
    11/4/2012
     
  16. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,574
    15,383
    340
    @dancer_69

    Have you seen this??
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,816
    1,998
    210
    Sorry, something is still wrong with either your Installation or your Activation or both!

    Also seems to be that you forget the following:
    "bcdedit -set TESTSIGNING ON" (without the "") which is part of that procedure!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  18. dancer_69

    dancer_69 MDL Novice

    Nov 23, 2012
    19
    1
    0
    Yes, I tried. No change. Still missing this entry.
     
  19. dancer_69

    dancer_69 MDL Novice

    Nov 23, 2012
    19
    1
    0
    #19 dancer_69, Jul 26, 2013
    Last edited: Jul 26, 2013
    (OP)
    What you mean? Aren't 2 different commands? If I get error at first how to procced to the next?
     
  20. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,816
    1,998
    210
    That's why I wrote firsat something is wrong with your Installation/Activation.

    Now tell us:
    • What Version +Build you use?
    • RTM/VL/MAK/KMS?
    • How you activated?
    • Wich Way/Apps?

    Fact is that the missing Menupoint Start-up Options isn't available in Non-Activated Windows 8! I had just installed Windows 8 on an extra HDD and unactivated that Menu point isn't there, only come up AFTER Activation!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...