Windows Freezing Issues (Things you can do)

Discussion in 'Windows 8' started by sunesio, Sep 2, 2013.

  1. sunesio

    sunesio MDL Novice

    Aug 31, 2013
    #1 sunesio, Sep 2, 2013
    Last edited: Sep 2, 2013
    I've had read from a few users complaining about some freezing issues
    and to keep the other threads a little bit tidy, this can be a place to find your cure.
    Some things could be bugging to hear over and over again, but you'd be surprised.
    This applies only to the users who never had a problem before (like on Windows 7)
    but can be in some points for other configurations useful as well.
    I'm not responsible for any problems with your hardware. You are doing this
    by your own risk.
    For the best effect use a clean / fresh installed system, so
    if there are any problems you can revert to the last state very fast.

    Or use a backup.
    It can also be useful to know that the issues aren't caused by any installed applications.


    - BIOS updates - First of all, you should go to the homepage of your manufacturer
    of your notebook or if you are on a desktop computer, the manufacturer of your mainboard.
    Look for the latest BIOS and look for the date.
    If you have never updated your BIOS
    it's most likely that there are newer ones or if you've updated it a long time ago you can
    still check the date.

    - Driver updates - Visit a page like for the latest hardware drivers.
    (At the moment of writing they are under construction, so it can happen that
    you'll not find your hardware at this time. But that page is a must-have for your bookmarks.)
    Don't expect that your mainboard / notebook manufacturer will have the newest drivers!
    In most of the cases they'll be only updated once after a new OS arrived (if ever!)
    and that's it. Don't rely on them.

    - Windows updates - Before you do anything else, be sure that you have all the updates.
    Please don't rely on the hardware drivers from the Windows updates.
    You should know your hardware and get it right from the manufacturer or from
    After a clean install you can set-up your Windows update setting manually and hide the hardware updates
    with a right click from the list. Do that, only if you know what you do.


    At this point we're focussing especially on hardware with Intel chipsets,
    so if you don't own Intel hardware, you can skip this point.

    First of all, go to station-drivers, click on the left on "Drivers"
    and look for "Chipsets cartes Mères & Mobile"
    Click on Intel, scroll down for "Intel® Chipset Device Software"
    and get the latest version. (Pack Version WHQL- in my case)
    Go back, this time choose the category "Chipsets Ata/Sata/Scsi"
    Intel again. (Note: If you're on a desktop computer be sure that your harddrives
    are connected to the Intel ports)
    Go for "Intel®Rapid Storage Technology (RST)"
    Choose WHQL" - which is important.
    Don't choose any other driver unless windows tells you that this one is not for your actual hardware.
    This one is by far the most performant and reliable driver.

    Extract both of them. (To different folders of course :D)
    For the next step i recommend a program like 7-Zip
    so that you can extract the infinst_autol.exe
    (from Intel Chipset drivers, not RST) which
    will get you access to the setup.exe in it.

    So go to your Chipset folder (not the RST folder)
    Create a shortcut of the extracted setup.exe on your desktop
    by clicking the file once! with your left mousebutton and then
    drag it with the right mousebutton to a free spot on your desktop.
    Choose the accordingly option in the popup.

    Right click on the file on the desktop and choose Properties.
    On target it should show something like D:\INF\Setup.exe (in my case)
    Change it that it looks like this D:\INF\Setup.exe -overall
    Press apply and start the setup.
    (Note: If you're on Windows 7, you also have to go to the Compatibility tab
    and choose Windows Vista Service Pack 2 for it in that field. Yes, i'm serious
    because otherwise some of the INFs wouldn't get updated.
    On some configurations it can happen that after clicking Setup nothing happens.
    (Or nothing will happen for a random amount of time.)
    Just reboot in this case and try again or give it enough time to open.

    Install it and after the process the installer asks you to reboot. Do it.
    This could have been already the fix for your issue. If not, read on.

    After that you're ready to install the RST drivers.
    I recommend to do it manually with the device-manager
    but you can also do it with setup.exe
    By doing it manually you don't have to install
    the Rapid Storage Manager, which can be
    quite useless for you anyway.

    In the device-manager you can find it in IDE ATA/ATAPI-Controller.
    After installing the chipset drivers it will most probably
    have a name like Intel(R) Blablabla SATA AHCI Controller or something like that.
    Click on it and exchange the driver with the new RST inf from your extracted folder.
    There is a subfolder named Drivers and AHCI. Then x32 and x64.
    Choose as necessary. AHCI folder is perfectly fine even for RAID configurations.
    If there is something completely different you should try the other way
    with setup.exe. It can happen that it will tell you that it isn't compatible
    with your current hardware. That's fine then, leave it.


    Try these techniques only if you hadn't any success or if you don't have an Intel chipset.

    BIOS Settings
    - Power Saving Modes
    If you have access to the Power Management modes in your BIOS
    (like C1, C6 etc.) you should try to disable them all. If your issues are gone you
    should turn them on, one by one to find the problem or consider to leave them all off.

    - HOT SWAP
    A underrated setting.
    If you have access to a Hot swap setting in your BIOS your best bet would be
    to enable it for all your harddrives. Try disabling it also, if it's already enabled.

    - Overclocking & Temps
    You should restore your default values to see if there is any difference.
    Most of the time people forgot that they have overclocked
    or the values are too high and the hardware has to clock down automatically.
    Check the temperatures and clean your computer from dust, in- and outside.- Load Setup Defaults (BIOS)
    Only after you wrote down the actual values.
    So in case you can go back if something has gone wrong.


    - Installing Hyper-V
    According to some sources there is a possibility that installing Hyper-V can fix your freezing issues.
    It was a workaround for the Preview of Windows 8 a year ago and it still can fix your problem.
    As stupid as it sounds, try it out. You can select it in Windows-Features.
    The reasons for that? Tbh, i don't know.

    - Running cmd with Admin privileges (bcdedit)
    Type the following:
    bcdedit /set useplatformclock true
    (Reboot. Any difference?)
    bcdedit /set useplatformtick yes
    (Reboot. Any difference?)
    bcdedit /set useplatformclock false
    (Reboot. Any difference?)
    bcdedit /set useplatformtick no

    - LPM (Link Power Management)
    Google for "Disable LPM registry" and follow the instructions on one of the sites.
    Reboot after that. It's mostly a fix for SSD drives but even if you're using a HDD it won't hurt and can help.

    - High Performance Mode
    Switch to High Performance in your Power Options.
    It will also disable Core-Parking which can also lead to problems.

    - Disable Windows Defender
    And use a free scanner like Avast.

    - Registry Values
    (Find them with regedit)



    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\I/O System]


    - Disable System Restore on all drives.

    - Disable Indexing by pressing Windows Key+E on your keyboard, right-click on your harddrives, Properties and untick "Allow files to on this drive to have contents indexed ..."
    After that, go to your Control Panel and type in the search field "Indexing" so that you can choose what folders Windows should be indexing. Disable them all, but Start menu, which you cannot disable, but that's fine. Just disable the others. You can also disable Windows Search by typing in services.msc, but you aren't able to use the Search within windows anymore. It's stuck together with the Indexing.

    - Get your pagefile a fixed size. e.g. Min. 1024MB, Max. 1024MB.
    Do this only if you know what you're doing or if this doesn't help, change it back
    to the old values. Don't disable the pagefile, it can lead to problems in a lot of applications.

    - Disable IPv6 - Google for that if you want.

    If there are any questions, feel free to ask.
    I hope this will help. In case you had success
    i would like to hear about it. Even if not. :)