Windows SIM Error when selecting image.

Discussion in 'Windows 8' started by cocachris89, Oct 29, 2014.

Tags:
  1. cocachris89

    cocachris89 MDL Senior Member

    Mar 1, 2013
    492
    147
    10
    #1 cocachris89, Oct 29, 2014
    Last edited by a moderator: Apr 20, 2017
    Hey everyone,

    Sorry if this isn't in the right area as I didn't know where to post this.

    I have Windows 7 Pro x64 installed on a new laptop and have Windows ADK (just DISM and Windows SIM v6.3.9600.17029).

    In Windows SIM, whenever I try to Select a Windows Image it comes up with an error:

    "Error opening Windows image at xxxxxxx"

    "An item with the same key has already been added"

    I have a VM of Windows 8.1 with Update 1 and it too has the same error. Attached is the error I receive.

    I've tried reinstalling the ADK, repairing the install and updating however I can't seem to solve the problem. o_O

    http://forums.mydigitallife.net/attachment.php?attachmentid=31941&stc=1

    UPDATE:

    I have done a fresh install of Windows 7 and Windows 8 in VMware Workstation; downloaded the latest Windows ADK, installed it and I receive the same message??? WTH is up with this?

    UPDATE 2:
    Is this just for me? pebkac? I just tried SIM on my old desktop and it, too, doesnt work o_O

    UPDATE 3:
    Here is the error log:

    Code:
    11:41 PM : This application requires version 6.3.9600.16384 of the Windows ADK.
    Install this version to correct the problem
    11:41 PM : 
    11:41 PM : Error opening Windows image at D:\Win7\install.wim.
    
    11:41 PM : 
    11:41 PM : System.ArgumentException: An item with the same key has already been added.
       at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
       at System.Collections.ObjectModel.KeyedCollection`2.InsertItem(Int32 index, TItem item)
       at Microsoft.ComponentStudio.ComponentPlatformInterface.WimInfo..ctor(String wimPath)
       at Microsoft.ComponentStudio.ComponentPlatformInterface.Cpi.OpenWim(String wimPath)
       at Microsoft.ComponentStudio.ImagePicker.GetImageInfoFromPath(String path)
       at Microsoft.ComponentStudio.ImagePicker.ValidateImageFileOrFolder(String fileOrFolder)
    
    UPDATE 4:

    So I found out that an original ISO of Windows 7/8/8.1 works fine, it's only the wims that I have integrated updates (security, hotfixes, IE11 etc.). Still kind of a pain.
     

    Attached Files:

  2. Flipp3r

    Flipp3r MDL Expert

    Feb 11, 2009
    1,487
    633
    60
    Are you just pointing to the install.wim? Copy the whole disk and then choose the install.wim.
    It will probably create a new catalog as well...
     
  3. cocachris89

    cocachris89 MDL Senior Member

    Mar 1, 2013
    492
    147
    10
    Yep, I have tried that too, and same problem. The only .wim that works is the Windows 10 TP :confused:
     
  4. abbodi1406

    abbodi1406 MDL KB0000001

    Feb 19, 2011
    7,375
    22,937
    240
    Did you loaded any answer file prior?
     
  5. cocachris89

    cocachris89 MDL Senior Member

    Mar 1, 2013
    492
    147
    10
    No, there isnt any answer files loaded as its a fresh install on a new laptop.
     
  6. cocachris89

    cocachris89 MDL Senior Member

    Mar 1, 2013
    492
    147
    10
    I can open x86 and x64 catalog files, however it still doesnt like to open .wim files.