Windows update just re-enabled itself again and changed things. How can I make sure it never starts?

Discussion in 'Windows 10' started by shodanx2, Jan 21, 2024.

  1. shodanx2

    shodanx2 MDL Novice

    Mar 6, 2023
    4
    3
    0
    How can I make sure it never restarts itself again ?

    I had the WaaSMedicSvc service disabled

    reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WaaSMedicSvc" /v Start /t REG_DWORD /d 4 /f

    And the Windows update service itself. I have re-installed windows 3 weeks ago and it had never started itself. What did I do to trigger this ? How can I make sure it does not restart again ?

    I need a windows automatic update supressor, does such a thing exists ?
     
  2. Dark Dinosaur

    Dark Dinosaur X Æ A-12

    Feb 2, 2011
    3,635
    5,007
    120
    well
    using group policy settings -
    you can set it to manual
    why you need to play with service,
    and disable them ..?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Dude Guyman

    Dude Guyman MDL Senior Member

    Jun 20, 2017
    271
    267
    10
    #4 Dude Guyman, Jan 21, 2024
    Last edited: Feb 3, 2024
    I've found Windows Update, Medic, and System Restore will re-enable themselves no matter what you do. To prevent any updates from actually happening though, I just use registry settings via registry files "Updates Enabled.reg" and "Updates Disabled.reg". These can be done in gpedit.msc too, but this is just faster.

    Updates Disabled.reg
    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate]
    "DoNotConnectToWindowsUpdateInternetLocations"=dword:00000001
    "DisableWindowsUpdateAccess"=dword:00000001
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]
    "UseWUServer"=dword:00000001
    
    
    Updates Enabled.reg
    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate]
    "DoNotConnectToWindowsUpdateInternetLocations"=-
    "DisableWindowsUpdateAccess"=-
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]
    "UseWUServer"=-
    
    
     
  4. shodanx2

    shodanx2 MDL Novice

    Mar 6, 2023
    4
    3
    0
    Thanks !

    I have discovered running WinGETUI, will also re-enable windows update.
    Because it immediately auto-installed something that contains
    "Microsoft Update Health Tools"

    And that apparently does re-enable everything and gives microsoft root access to my computer.

    I'll have to be more careful !

    However, I will try these registery entries for my next attempt ! See if that saves it !

    Thanks !