WindSLIC UEFI SLIC injector

Discussion in 'MDL Projects and Applications' started by nononsence, Oct 16, 2011.

  1. skirklan

    skirklan MDL Novice

    Mar 18, 2011
    9
    0
    0
    #881 skirklan, Jul 21, 2018
    Last edited: Jul 29, 2018
    Wrestling with a poweredge but one thing I've come across is that, when using no args version and after del * inside windslic dir and start over with the next version,
    ERROR: Open Bin FILE: \EFI\WindSLIC\slic.bin Not Found
    Perhaps leftover invisible commandline element from bcdedit but figured I'd point out noargs is maybe checking args.

    EDIT: hey, i'm a slow one. I get it I think. NM. I was thinking noargs meant the bin/msdm was loaded in the file and not that it had to still be provided. Sorry!
     
  2. skirklan

    skirklan MDL Novice

    Mar 18, 2011
    9
    0
    0
    #882 skirklan, Jul 22, 2018
    Last edited: Jul 24, 2018
    Still no joy using 2.2 bin however. no slic data or msdm table showing up. Probably doing something wrong as so much has changed from directions and parts available now.. I'll try again later.

    EDIT (the next day):
    Trying again with 2012R2. There was a poster posting possible success with 2012 R2. I, however, get the same results. No MSDM table and no slic marker even if using various vendor bins.

    That contributor guy had an alternate injection method as well which, upon trying to apply, I was greeted with a remark that the machine was not EFI so maybe it's dell uefi witchcraft. kthnx.
     
  3. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,701
    15,769
    340
    @skirklan

    What is the exact model of the server?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. skirklan

    skirklan MDL Novice

    Mar 18, 2011
    9
    0
    0
    Sorry I took so long. It was a PowerEdge R210 but it's already been repurposed (but still have 2 others). It was simply the first machine I was trying out the WindSLIC toolset with. I'd first gotten a successful bios mod doing the phoenix tool 2.66 route but was never able to find a way to burn in. Dell supplied bios update package didn't like it after SLIC injection. The R210 II I could have gotten my hands on had rubbish in the RWEverything report or something so phoenixtool wasn't able to inject its bios file. Not relevant I guess but that's how I found my way to non oprom windslic project.

    Thank you.
     
  5. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,701
    15,769
    340
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Dukers

    Dukers MDL Member

    Sep 17, 2009
    189
    84
    10
    Does it work with newer W10 builds?
     
  7. skirklan

    skirklan MDL Novice

    Mar 18, 2011
    9
    0
    0
    HWID activation no longer works without a valid key from which to upgrade unless I'm mistaken. You can, however, use KMS activation tools to run WIN10 without complaints, save from Defender which can be excluded or turn it off.

    You may try the gatherosstate tool and an older build, however in my case, 1709 and 1803 want valid previous version keys if you want a HWID activation. I could be wrong and it wouldn't be the first time. why not try it in vbox or vmware first?
     
  8. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    20,154
    27,229
    390
    You're mistaken, all sku's still can get a HWID established, Home + Pro (+N) by full upgrade from activated 7 SP1 to 10 or gatherosstate.exe and full upgrade from 8.1 Home/Pro KMS activated to 10 build 10240 or 10586 (when the hwid is established you can either upgrade to the most current build or clean install it).
     
  9. Dukers

    Dukers MDL Member

    Sep 17, 2009
    189
    84
    10
    Thanks @skirklan and @Enthousiast. So I think upgrade from W7 Pro + Daz's loader to 10 Pro (1803) is the way to go.

    I do not have any powerful machine here to test these things in VMs... :(
     
  10. DarkStar88

    DarkStar88 MDL Novice

    Aug 16, 2018
    1
    0
    0
    Dumb noob question, where's the installer itself? I can't see it on the github link.
     
  11. zobator

    zobator MDL Novice

    Aug 18, 2018
    1
    0
    0
    Mobo dead.

    I'v been using Windslic for a few years now on a Asrock z77 pro4 (acer file) and it worked perfectly.
    I'm moving to as Asrock z370 pro4, used the same installer and Acer files, and after a reboot the mobo died. The first 3 lines of bios are displayed (basically, bios version and date) then nothing. No memory size display, impossible to enter the uefi setup, cannot post. I did RMA the board.

    Did I do something wrong? Could Windslic bug the bios setup to the point it won't post anymore?
    OS was win7 with no driver whatsoever (in particular, no INF drivers).
     
  12. Avarege Joe

    Avarege Joe MDL Novice

    Nov 29, 2018
    5
    0
    0
    #894 Avarege Joe, Nov 30, 2018
    Last edited: Nov 30, 2018
    Hi! I have an ASUS H97-PRO mobo (Not GAMER version).
    I have a win 7 ultimate OS, on unfortunately a GPT partitioned SSD, so DAZ loader gives error.
    I have already searched the forum for a modified bios, but only found for GAMER version. Can I flash it to mine too?
    Sorry if this is a noob question. I tried to understand how to make this myself, but I'm too afraid that I'll mess things up..
     
  13. Rodion

    Rodion MDL Novice

    Dec 18, 2011
    7
    2
    0
    Nothing to FLASH here, WindSlic is a software emulator, modified bootx64.efi file
    read the topic before asking
     
  14. Avarege Joe

    Avarege Joe MDL Novice

    Nov 29, 2018
    5
    0
    0
    I did, and I understand that, but in post #835 and #836 they actually talking about flashing a modified bios to the motherboard. My question was that: can I use the same mod. bios with my mobo or not?
     
  15. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    20,154
    27,229
    390
    The subject of this thread is about a tool, similar to daz loader, but working on UEFI/GPT partitioned systems.

    The flashing you saw probably is about using a modified bios file, containing a slic, so the oem:slp and certificate will activate it (or even daz loader can do that on UEFI/GPT systems).
     
  16. Avarege Joe

    Avarege Joe MDL Novice

    Nov 29, 2018
    5
    0
    0
    I saw this, but OK, I will try my luck on the "ask for modified BIOS" thread first, sorry.
     
  17. Rodion

    Rodion MDL Novice

    Dec 18, 2011
    7
    2
    0
    Sorry, i dont know about that
    I used WindSLIC with Win7 and it worked perfectly for me for a long time
    Then installed Win10 upgrade and it was activated automatically, with no extra actions

    i dont like to modify BIOS for this reason
     
  18. jinvidia

    jinvidia MDL Member

    Aug 7, 2016
    110
    14
    10
    Hello Dev, I am using Windows 10 x64 in Legacy/CSM Mode. Is it possible to run Windows 7 UEFI image in vmware workstation ?.

    @frach - Are you successful in selecting the correct file for win 7 activation ?