XPS 15 9550 Boot Problem

Discussion in 'PC Hardware' started by palindrome, Feb 8, 2017.

  1. palindrome

    palindrome MDL Novice

    Feb 8, 2017
    2
    0
    0
    Hello, I just turned on my XPS today and was given an error upon it booting up into windows about the drive not being able to load or corruption (I'll update this post if I can find specific error, I stupidly barely read it). I than shut it off, assuming I was going to just wipe it and install linux after having had so many problems with win10. The strange thing is I can't even get it to boot into BIOS now. When turning it everything appears to turn on, including the backlit keyboard and the display. The display however will either be blank or shut off repeatedly, with no way to access the BIOS. Looking up Dell's BIOS recovery it appears they have a system to reset/restore the BIOS by following the instructions on dells site holding odwn ctrl+esc and plugging in the charger.

    Having tried it both with and without the USB method, I'm under the assumption something must have broken inside the computer. I haven't been able to open it yet though and check or try to remove the CMOS, since I don't have a torx screw driver at my dorm, but I was going to open it tomorrow and see if resetting the CMOS or if something was loose might be the problem. The laptop is still under the 1 year warranty, so I will just send it to Dell to have it fixed, however would rather not have to if it's just a BIOS error that I could simply fix.

    I was wondering if anyone had a recommendation or ever experienced a similar problem. Is it even worth resetting the CMOS or does this problem seem to be like a broken Mobo/other hardware issue? Also, is there a better way to flash BIOS version onto a computer, I had read and checked out a few tools but it appears most are aimed at older computers that have been tried and tested. Anyways, would appreciate any feedback I'm most likely just going to send it to Dell.
     
  2. Joe C

    Joe C MDL Guru

    Jan 12, 2012
    2,550
    1,391
    90
    Try removing the hard drive from your laptop and see if it can access the bios, if successful then start looking for a new hard drive.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. palindrome

    palindrome MDL Novice

    Feb 8, 2017
    2
    0
    0
    Thanks for the reply, I was going to try this and than also try removing CMOS. However, I was able to get BIOS to boot holding fn down which was really strange since it wasn't allowing any other keys to load stuff. Windows appears to have corrupted for some reason, might have been due to windows update. Anyways, removing drive probably would have solved this as well if it really was windows messing with the boot of BIOS, thanks for the recommendation :biggrin:.

    With this said, I was able to boot into BIOS finally and install a copy of xubuntu, all appears to be fine now.
     
  4. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,431
    1,486
    180
    fn+power is usually dell built in PSA diags on laptops