disabling or enabling windows defender win10 1903

Discussion in 'Windows 10' started by migalou, May 13, 2019.

  1. migalou

    migalou MDL Novice

    Jan 20, 2010
    2
    0
    0
    Hi,
    I'am testing windows 10 1903 in a vm and I can't turn off windows defender by script command.

    I run this command in powershell in admin mode : Set-MpPreference -DisableRealtimeMonitoring $True

    This command works with windows 1809 or prior

    In windows 10 1903, defender is always turned on, even after a reboot
    I've updated windows with last kb4495666 and it's the same bug.

    Is someone could help me, please ?
    Thanks
     
  2. ege914

    ege914 MDL Member

    Jun 29, 2015
    213
    38
    10
    you may need to disable tamper first idk, i delete defender completely.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Wetryshka

    Wetryshka MDL Novice

    Apr 16, 2017
    36
    3
    0
    Have you figure it out yet?
     
  4. pf100

    pf100 MDL Expert

    Oct 22, 2010
    1,684
    2,439
    60
  5. yanwah

    yanwah MDL Novice

    Apr 27, 2018
    21
    3
    0
    can you try disable using Group Policy?
     
  6. migalou

    migalou MDL Novice

    Jan 20, 2010
    2
    0
    0
    thanks pf100.
    defender-control tool is working.
    I could use it with a batch command line.
     
  7. bfoos

    bfoos MDL Guide Dog

    Jun 15, 2008
    425
    344
    10
    +1 for Defender Control. Fantastic little tool.