HP Compaq 6710b F.20 BIOS issues.

Discussion in 'BIOS Mods' started by coreburner, Oct 7, 2012.

  1. helmet605

    helmet605 MDL Junior Member

    Jan 21, 2011
    84
    4
    0
    #41 helmet605, Nov 21, 2012
    Last edited: Nov 21, 2012
    Hi, I used the above zip file to update my HP 6710b laptop from F.08 to F.16. I flashed it in Windows and it seemed to go alright. When it rebooted I got the following:

    "Your BIOS failed to complete the update. Please ensure that you follow the correct procedure and try again. This may require two sequential BIOS updates to complete the process."

    After a few seconds the laptop boots in to Win 7 and I used the SLIC tool kit and everything looks good. I did try to reflash it and it made no difference. Do you guys have any ideas to get rid of the error/warning?

    Thanks!!


    I got it fixed by going back to F.14 and then the F16 modded BIOS.
     
  2. pf100

    pf100 Duct Tape Coder

    Oct 22, 2010
    2,059
    3,346
    90
    4 months now since this post and no feedback on it? Does it work? If so, can you flash it over the unmodded HP F20 bios (HP 6710b)? Somebody please answer. Flashing my laptop with F20 was the biggest mistake I've made on a computer since I fried a $300 video card by cleaning it with a toothbrush 8 years ago. I've learned my lesson and will never update any bios again without checking with this forum first.

     
  3. urmel

    urmel MDL Novice

    Mar 21, 2013
    1
    0
    0
    #43 urmel, Mar 21, 2013
    Last edited: Mar 30, 2013
    Tried your hard developed solution and failed!

    I have flashed your rom.bin (using rompaq 4.78c) on a 6710b with original F.20 BIOS on it. Everything went fine... until reboot. Everything stopped, only a small green LED (a lock with the letter A at the lower right corner) kept flashing permanently. Any suggestions what to do next? I have the original HP BIOS file, a backup made with rompaq, but no usb floppy drive at my fingertips. Any way to recover the notebook without SPI-Programmer? Hoping for good news...

    Update: Obtained a usb floppy drive, copied HP original BIOS F.20 from extracted cab file to floppy, plugged the drive into the 6710b... and... it worked! The notebook flashed the BIOS and rebooted successfully. I also tried BIOS versions 16, 15 and 14, but they were not accepted by the recovery procedure. So I am still stuck without SLIC table and BIOS F.20...
     
  4. dagb

    dagb MDL Novice

    May 27, 2014
    1
    0
    0
    This thread is antique, and coreburner has not been active in the forum in over a year. But still:
    I read this as it *is* possible to modify and flash an F.20 BIOS on top of the original F.20 BIOS. Is that the correct interpretation?

    I also see that there are close to 200 downloads of the modded BIOS. One reported failure, and no reported successes. Hm...
     
  5. darcy

    darcy MDL Novice

    Jan 22, 2009
    8
    2
    0
    I Tried the above method to flash from f.20 to f.20 with 2.1 slic,
    and I am now the owner of a shiny new, "BRICK".

    I have tried recovery using a usb floppy drive without any luck so far (tried various roms... win key and b)
    the system reads the floppy then reboots in an endless loop.

    Darcy
    P.S. I realise that this is a very old thread but I have not found an answer anywhere else and thought that I had better warn anyone else from making the same mistake.
     
  6. Rachy

    Rachy MDL Novice

    Oct 17, 2019
    1
    0
    0
    Hey guys I update my HP Compaq 6710b from F.16 to F.20 directly from windows 8 and everything went fine but after rebooting my system won't load up to windows I keeps restarting after showing an error message "Your BIOS failed to complete the update. Please ensure that you follow the correct procedure and try again. This may require two sequential BIOS updates to complete the process."

    Is there anyone that could help me with a step to step illustration on what to do.
    Thanks
     
  7. PitMakot

    PitMakot MDL Novice

    Apr 28, 2016
    2
    0
    0
    can you reupload version F16 with slic 2.1?

    thanks