Microsoft Edge

Discussion in 'Windows 10' started by SAM-R, Mar 18, 2019.

  1. kaljukass

    kaljukass MDL Guru

    Nov 26, 2012
    2,847
    1,094
    90
    It is available on the developers website.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. adric

    adric MDL Expert

    Jul 30, 2009
    1,001
    856
    60
    #2902 adric, Jan 1, 2022
    Last edited: Jan 1, 2022
    Currently I am testing LTSC 2021 (19044.1) that does not have EDGE installed. I am contemplating about putting it back in because when selecting certain settings here and there, I am seeing critical alerts in the event viewer. MSoft seems to be striving at making a fully functioning OS more dependent on EDGE. I don't want things breaking down the road that may be related to not having Edge installed. I am not planning on using Edge as my default browser other than for verification purposes when my default browser has problems rendering correctly.

    What would be the best way to add the latest Edge back into the system - offline wim integration or online install (Enterprise msi)?
    Code:
    Unable to start a DCOM Server: Microsoft.MicrosoftEdge_44.19041.1266.0_neutral__8wekyb3d8bbwe!MicrosoftEdge.AppXeb42j1vh6rk395pm0vmcx57dxqjhej5d.mca as Unavailable/Unavailable. The error:
    "2147942402"
    Happened while starting this command:
    "C:\Windows\SystemApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\MicrosoftEdge.exe" -ServerName:MicrosoftEdge.AppXdnhjhccw3zf0j06tkg3jtqr00qdm0khc.mca
    
     
  3. xinso

    xinso MDL Guru

    Mar 5, 2009
    8,640
    10,488
    270
    #2903 xinso, Jan 1, 2022
    Last edited: Jan 1, 2022
    ChromiumEdge is mandatory package with LCU from 19044.1263 forward.
     
  4. adric

    adric MDL Expert

    Jul 30, 2009
    1,001
    856
    60
    #2904 adric, Jan 1, 2022
    Last edited: Jan 1, 2022
    That may be the case since my system is currently at 19044.1415, but why is Edge not showing or running correctly and giving errors as posted above?

    I was assuming Edge wasn't installed.

    Oooops :kick:Now that I think about it, I used W10UI to create a December wim and had SkipEdge=1 where 1 = do not install EdgeChromium with Enablement Package or Cumulative Update.

    But this is not a clean solution for me, since there are still a lot of Edge remnants left in the system once installed. I might as well set SkipEdge=0 and let what's missing be included to avoid errors popping up here and there..

    Time for a new .wim
     
  5. xinso

    xinso MDL Guru

    Mar 5, 2009
    8,640
    10,488
    270
    #2905 xinso, Jan 1, 2022
    Last edited: Jan 1, 2022
    Check C:\Program Files (x86)\Microsoft.
    Code:
    C:\windows\system32>dir /b "C:\Program Files (x86)\Microsoft"
    Edge
    EdgeCore
    EdgeUpdate
    Temp
    
    C:\windows\system32>
    
    Or

    C:\Windows\servicing\Packages\
    Microsoft-Windows-Internet-Browser-Package~31bf3856ad364e35~amd64~~10.0.19041.1266.mum
    Microsoft-Windows-Internet-Browser-Package~31bf3856ad364e35~amd64~xx-XX~10.0.19041.1266.mum

    Or

    You may try to
    1. remove Microsoft-Windows-Internet-Browser-Package~31bf3856ad364e35~amd64~~10.0.19041.1266

    PS:
    The installed Edge.wim is one way.

    2.
    a. reinstall 19041.1415 LCU
    or
    b. install Enterprise.msi Offline installer. Then next LCU will take care of it, no worries.

    Or

    Wait for expert come to help.
     
  6. kaljukass

    kaljukass MDL Guru

    Nov 26, 2012
    2,847
    1,094
    90
    Just install Edge and you're done. There is no need for any kind of additional chemistry at all.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. AveYo

    AveYo MDL Expert

    Feb 10, 2009
    1,693
    4,937
    60
    or you could just ignore dcom errors, windows always has them, and even microsoft themselves don't know how any of that works and officially say just that - ignore them
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. AveYo

    AveYo MDL Expert

    Feb 10, 2009
    1,693
    4,937
    60
    Chrome is a 3rd party program, and uninstalls just fine. I have no intention of ever touching that plague.
    Never had an issue with removed Edge, all links open just fine in Firefox, my default browser. From discord, too. Heck, I did had a portable chrome once and it worked the same.
    Maybe it's just you misconfiguring chrome as default browser? Do it from settings, not from within discord...
    Maybe try Brave or Vivaldi and see how those do?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. spanishfly

    spanishfly MDL Senior Member

    Dec 5, 2018
    352
    521
    10
    #2910 spanishfly, Jan 25, 2022
    Last edited: Jan 25, 2022
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. nosirrahx

    nosirrahx MDL Expert

    Nov 7, 2017
    1,038
    493
    60
    Is there some secret setting that stops Edge from randomly displaying a different language than it is set to?

    Everything in the OS and browser language settings is set to English but when I am in Dominican Republic random page elements and dialog boxes are displayed in Spanish.
     
  11. kaljukass

    kaljukass MDL Guru

    Nov 26, 2012
    2,847
    1,094
    90
    Does each installed Ege use its own User Data folder? If not, this is the first basic requirement that must be met.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. alwaysbeta

    alwaysbeta MDL Novice

    May 13, 2016
    3
    0
    0
    Both edges are installed versions and should be in separate data folders. Microsoft default settings, I have not additionally modified the data storage location.
     
  13. kaljukass

    kaljukass MDL Guru

    Nov 26, 2012
    2,847
    1,094
    90
    Should be or they are, its two different things and only You can check how they really are installed.
    Problem is thet anyone else can't do it and if don't know, not possible also know what's the reason may be.
    Knowing that they are installed, doersn't help any way, because we don't know where and how they are installed, there is several different ways.
    So, if You want to get any help, You must say very exactly, how these two are istalled and where and also where are the User Profile data stored.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. alwaysbeta

    alwaysbeta MDL Novice

    May 13, 2016
    3
    0
    0
    Sorry, I was not on the computer before, so I can't view it in detail. This is my data path.

    ------------
    Microsoft Edge 100.0.1181.0 (官方内部版本) dev (64 位)
    命令行 "C:\Program Files (x86)\Microsoft\Edge Dev\Application\msedge.exe" --no-startup-window /prefetch:5 --flag-switches-begin --flag-switches-end
    可执行文件路径 C:\Program Files (x86)\Microsoft\Edge Dev\Application\msedge.exe
    用户配置路径 C:\Users\alway\AppData\Local\Microsoft\Edge Dev\User Data\Default
    ------------
    Microsoft Edge 98.0.1108.62 (官方内部版本) (64 位)
    命令行 "C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe" --flag-switches-begin --flag-switches-end
    可执行文件路径 C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe
    用户配置路径 C:\Users\alway\AppData\Local\Microsoft\Edge\User Data\Default
    ------------