Setting a Static IP autounattend.xml Guide For Windows Unattended Installs.

Discussion in 'Windows 10' started by KedarWolf, Aug 9, 2019.

  1. whitestar_999

    whitestar_999 MDL Addicted

    Dec 9, 2011
    563
    242
    30
    I am not familiar with these,it was just my guess & experience that usually in such situations it is better to keep them simple when troubleshooting/implementing.Just try with simple version first & then add.
     
  2. KedarWolf

    KedarWolf MDL Senior Member

    Mar 17, 2016
    356
    217
    10
    #5 KedarWolf, Aug 9, 2019
    Last edited: Aug 10, 2019
    (OP)
    I have actually not tried installing Windows with those static IP settings yet but is literally the last thing I need to figure out to have the perfect unattend.xml file.
     
  3. tistou77

    tistou77 MDL Expert

    Mar 22, 2008
    1,416
    513
    60
    Hello

    It interests me too, just indicated IP Static (ipv4) and DNS 1 and 2

    Thanks
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Atari800XL

    Atari800XL MDL Addicted

    Apr 3, 2011
    737
    1,231
    30
    Thank you for that excellent write-up!
     
  5. tistou77

    tistou77 MDL Expert

    Mar 22, 2008
    1,416
    513
    60
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. tistou77

    tistou77 MDL Expert

    Mar 22, 2008
    1,416
    513
    60
    #12 tistou77, Aug 12, 2019
    Last edited: Aug 12, 2019
    Ok thanks, for route settings, how to create it ?

    My ipconfig /all

    Code:
    Configuration IP de Windows
    
       Nom de l’hôte . . . . . . . . . . : tistou-PC
       Suffixe DNS principal . . . . . . :
       Type de noeud. . . . . . . . . .  : Hybride
       Routage IP activé . . . . . . . . : Non
       Proxy WINS activé . . . . . . . . : Non
    
    Ethernet adapter Ethernet :
    
    Connection-specific DNS Suffix =>
    Description = > Intel(R) Ethernet Connection (2) I219-V
    DHCP Enabled => No
    Autoconfiguration Enabled = > Yes
    IPv4 adress => 192.168.0.1((Preferred)
    Subnet Mask => 255.255.255.0
    Default Gateway = > 192.168.0.254
    NetBIOS over TCPIP = > Disabled
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. KedarWolf

    KedarWolf MDL Senior Member

    Mar 17, 2016
    356
    217
    10
    255.255.255.0 is your subnet mask, your default gateway is what you log into your router with, like 192.168.1.1 or 192.168.2.1, when you set your IP4 settings manually you always need to put that in as well.

    The 192.168.*.**/24 is what you want your IP address to be with 24 making the 255.255.255.0 subnet mask. If your gateway is 192.168.0.1 ( what you login to your router/modem with) you need to do that in route like I did with the 0.0.0.0/0. The IP address in 192.168.*.**/24 must be different. See my ipconfig / all 192.168.2.25 is the IP address I set, 255.255.255.0 is the subnet mask, 192.168.2.1 is the gateway (same as what I log into my modem with) and 8.8.4.4 and 8.8.8.8 is the DNS.
     
  8. tistou77

    tistou77 MDL Expert

    Mar 22, 2008
    1,416
    513
    60
    #14 tistou77, Aug 12, 2019
    Last edited: Aug 12, 2019
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. KedarWolf

    KedarWolf MDL Senior Member

    Mar 17, 2016
    356
    217
    10
    #15 KedarWolf, Aug 12, 2019
    Last edited: Aug 12, 2019
    (OP)
    Route needs to be like this with the <Prefix>0.0.0.0/0</Prefix>

    Edit: And you need to add all the Metrics as well.

    Code:
                       <Routes>
                           <Route wcm:action="add">
                               <Identifier>1</Identifier>
                               <Metric>10</Metric>
                               <NextHopAddress>192.168.2.1</NextHopAddress>
                               <Prefix>0.0.0.0/0</Prefix>
                           </Route>
                       </Routes>
    
     
  10. KedarWolf

    KedarWolf MDL Senior Member

    Mar 17, 2016
    356
    217
    10
  11. tistou77

    tistou77 MDL Expert

    Mar 22, 2008
    1,416
    513
    60
    Ok I test, thanks so much ;)

    Must place it at a specific place in the .xml file ?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. tistou77

    tistou77 MDL Expert

    Mar 22, 2008
    1,416
    513
    60
    Yes, called "Eternet"
    Capture.PNG

    Tested and dosn't work (still auto settings)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. KedarWolf

    KedarWolf MDL Senior Member

    Mar 17, 2016
    356
    217
    10
    did you do an 'ipconfig /all'?