[SOLVED] Windows 10 higher DPI - Win8DpiScaling problem

Discussion in 'Windows 10' started by rafalek, Jul 18, 2015.

  1. YonderBoi

    YonderBoi MDL Novice

    Aug 21, 2015
    3
    1
    0
    After using the .cmd file fix for a day, unfortunately I've found that every time the computer goes to sleep the blurriness is back. Signing in and out does not fix the problem, only restarting the system. I only have one monitor. :(
     
  2. YonderBoi

    YonderBoi MDL Novice

    Aug 21, 2015
    3
    1
    0
    Here is the solution that worked for me, running with scaling set to my desired 125%. (Thanks to the original poster at TenForums.)

    Basically, you use a Logon script instead of Startup items or the Task Scheduler, but just in case here it is from the top.
    Open notepad and paste in the following three lines:

    REG ADD "HKCU\Control Panel\Desktop" /v DpiScalingVer /t REG_DWORD /d 0x00001018 /f
    REG ADD "HKCU\Control Panel\Desktop" /v Win8DpiScaling /t REG_DWORD /d 0x00000001 /f
    REG ADD "HKCU\Control Panel\Desktop" /v LogPixels /t REG_DWORD /d 0x00000078 /f

    Save the file as DPI_FIX.cmd someplace easy for you to find. Open the Group Policy Editor (enter gpedit.msc from the search bar). In User Configuration, click on Windows Settings then Scripts (Logon/Logoff). Double click Logon in the right pane. In the Scripts tab, click Add, then Browse, then navigate to your .cmd file, click Open, click OK, click Apply, click OK. Then sign out or reboot. Login to your account the first time after adding this script so it will be applied. It may not take effect the first time (if so sign out or reboot again). After that, it should work every time.
     
  3. lomticksoftoast

    lomticksoftoast MDL Member

    Nov 12, 2009
    186
    142
    10
    #44 lomticksoftoast, Sep 6, 2015
    Last edited: Sep 6, 2015
    Hi,
    The registry changes seem to hold across restarts using newer Insider Previews

    Thank you all for figuring this out!

    Initial Test
    I did the registry changes manually. I think I had to manually create DWORD "LogPixels"
    Coincidentally, the next restart after making the REG changes, my PC upgraded to Insider Preview:10512.

    I never needed to create a log-in Task or Auto-start, the settings just hold!
    Same story after upgrade to Insider Preview:10532

    Maybe, I'm just lucky?

    By the Way
    I have a second Insider Preview PC with a small screen and default DPI REG settings. The second PC Insider Preview registry settings are the same as the original builds. I think, the only difference with the new builds is that they stop "auto-resetting" our DPI REG changes.


    Standard REG changes Used:
    REG ADD "HKCU\Control Panel\Desktop... DpiScalingVer /t REG_DWORD /d 0x00001018 /f
    REG ADD "HKCU\Control Panel\Desktop ... Win8DpiScaling /t REG_DWORD /d 0x00000001 /f
    REG ADD "HKCU\Control Panel\Desktop ... LogPixels /t REG_DWORD /d 0x00000078 /f
     
  4. Mr.Claw

    Mr.Claw MDL Novice

    Nov 25, 2015
    1
    0
    0
    Just tried the registry fix by creating a task. Everything on my screen becomes really tiny on reboot.
    I think this fix is only for 125% scaling? What do I need to change to make it compatible with 250% scaling? Mine is a 4K display.

    Thanks in advance.
     
  5. WaltC

    WaltC MDL Addicted

    Mar 8, 2014
    518
    123
    30
    #46 WaltC, Nov 25, 2015
    Last edited: Nov 25, 2015
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. woffko

    woffko MDL Novice

    Jan 23, 2008
    25
    5
    0
    TH2 release uses the same scaling method as windows 8.1, when you set DPI scaling manually via old GUI and brand new blurred, when you set in modern UI. SO for me problem solved.
    font rendering could be much better when using windows 10 method, but it is already better then 10240. Unfortunately I don't have any 4k or 8k display to check how it looks on modern display.
     
  7. salvaenlaluna

    salvaenlaluna MDL Novice

    Dec 11, 2015
    1
    0
    0
    Thanks a thousand times!

    I've registered myself into this forum just to be able to thank you for your link.

    I find it unbelievable that MS has not been able to solve this problem by themselves and (thanks god) people have to code this kind of programs in order to make it work properly.

    It works perfect for me, thanks again!
     
  8. joeyjoey

    joeyjoey MDL Novice

    Feb 25, 2016
    25
    2
    0
    #51 joeyjoey, Feb 25, 2016
    Last edited by a moderator: Apr 20, 2017
    Ok here is how to truly fix it

    Previously, this issue was solved in Windows 8.1 with a checkbox in the Control Panel for "Let me choose one scaling level for all displays". In Windows 10, this checkbox is no longer available. However, there IS a way to replicate the feature in Win10 through normal Control Panel features.

    First, here's what it looked like in Win8.1:
    youtube.com/watch?v=sE3IUTPy1WA

    For Windows 10, if you don't want to manually hack the registry as mentioned in the first post, there is still a way to revert it.

    1. Before doing anything, open up regedit and verify the current registry values. Here is what mine were with a default Win 10 installation:

    Code:
    DpiScalingVer = 0x00001000
    LogPixels = 0x00000078
    Win8DpiScaling = 0x00000000
    
    And as expected, some windows were blurry, such as Device Manager.

    2. Go to Control Panel -> Display. Then click on "set a custom scaling level". Simply change this to the scaling level you want. And if you want 125% and its already at 125%, then you will need to first change it to 100%, log off, then change it back to 125% and logoff again:
    tenforums.com/attachments/tutorials/18812d1431359609-dpi-scaling-level-displays-change-windows-10-a-custom_dpi-1.png

    3. Check the blurry windows such as Device Manager and verify that they are no longer blurry!

    4. Verify the registry settings again. Here is what mine look like AFTER the change:
    Code:
    DpiScalingVer = 0x00001000
    LogPixels = 0x00000078
    Win8DpiScaling = 0x00000001
    
    As you can see, the 'Win8DpiScaling' value is now correct at '1'. The 'LogPixels' setting was the same because I was previously at 125% and I stayed at 125%. Interestingly the 'DpiScalingVer' setting did not change to 0x1018 like recommended earlier in this thread. I wonder if that's necessary or not. Nonetheless, the blurriness is gone.

    5. In the new Settings panel in Windows, you will notice this message under "Settings -> System -> Display" in red letters which warns you that "a custom scaling level is set". I'm assuming this warning is just letting you know that you are now using one scaling factor across all monitors.
    i.imgur.com/JcQi1dt.png

    Anyway, after that everything should be good again, just like with Win8.1.
    Voila, no more blurriness. No reg hacking.
     
  9. tony359

    tony359 MDL Novice

    Dec 13, 2015
    1
    0
    0
    Hi
    Just wanted to say thank you all for your help. I was having the same issue and this forum helped me.
    In fact, I noticed that with the anniversary update running the script mentioned at the beginning is permanent and is basically having the same effects that joeyjoey mentioned.

    Only "downside" is the display panel now reports the scaling at 175% ;)

    Nice to see MS listening!

    Thanks! ;)