[TOOL] EzWindSLIC: Easily activate Windows 7/Vista/Server 2008-2022 on UEFI-GPT

Discussion in 'MDL Projects and Applications' started by Exe Csrss, Apr 9, 2021.

?

Should I use powershell in this script to add more features? Vista will no longer be supported.

Poll closed May 7, 2021.
  1. Yes

    5 vote(s)
    55.6%
  2. No

    4 vote(s)
    44.4%
  1. failure35

    failure35 MDL Novice

    Jan 12, 2020
    3
    0
    0
    I heard that using non-local KMS server activation is not ideal in terms of privacy because it sends some sort of usage data to host server and it's also easy for Microsoft to detect you are using illegal activation method. Is it the case with this tool? If not, do you collect any data with this program? Does it cause any additional resource usage? Is it safe generally? I appreciate your answer.
     
  2. Carlos Detweiller

    Carlos Detweiller Emperor of Ice-Cream

    Dec 21, 2012
    5,329
    5,692
    180
    This tool is not using KMS but OEM:SLP. OEM:SLP activation is a completely offline process and does not send any data anywhere. There's actually no data at all which could be sent.

    It's essentially the same as Windows Loader. Windows Loader can install its emulation boot loader on BIOS/MBR (legacy) installations but not on UEFI/GPT. EzWindSLIC fills that gap and can emulate SLIC if your installation is UEFI/GPT.
     
  3. failure35

    failure35 MDL Novice

    Jan 12, 2020
    3
    0
    0
    #343 failure35, Nov 20, 2021
    Last edited: Nov 20, 2021
    It's very relieving to know that but i still have some questions. While using this tool, it asks me which brand i want to use and it's automatically selecting Dell for me for activating Server 2022 DataCenter. What is the differences between selecting different brands for activation and why such useful tool like this free?
     
  4. Carlos Detweiller

    Carlos Detweiller Emperor of Ice-Cream

    Dec 21, 2012
    5,329
    5,692
    180
    Basically, the brand does not matter, activation-wise. You can select a brand matching (or closely matching) your actual brand mainboard, but it's a matter of taste, not a necessity.
    For Server 2022, we only know the Dell stuff so far, thus it's the only choice, currently. Will change in the future.

    All stuff on this board is created for learning purposes. Plus, commercializing an activator (legally a gray area) would be like painting a big red X on one's forehead. MS will go after you in no time.

    So, just enjoy and don't forget thanking the author of the tool.
     
  5. failure35

    failure35 MDL Novice

    Jan 12, 2020
    3
    0
    0
    Thank you for direct answers and also thanks to author and other people who contributed developing this tool. Seems better than KMS alternatives.
     
  6. Sajjo

    Sajjo MDL Member

    Feb 6, 2018
    1,891
    2,645
    60
    #346 Sajjo, Nov 20, 2021
    Last edited: Nov 20, 2021
    @Baldiman TV @Carlos Detweiller
    Running build 20348.169:
    en-us_windows_server_2022_x64_dvd_620d7eac.iso
    and
    SW_DVD9_Win_Server_STD_CORE_2022__64Bit_English_DC_STD_MLF_X22-74290.iso

    ASUS from 2013 with i7-4700HQ and latest bios, unmodified - on this system it works as expected.
    I don't have a Celeron system to test.

    ( :D looks kinda stupid with ASUS motherboard and DELL SLIC :) )

    20-11-2021 14.07.03.ls.jpg

    20-11-2021 14.07.59.ls.jpg

    20-11-2021 14.06.25.ls.jpg
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Carlos Detweiller

    Carlos Detweiller Emperor of Ice-Cream

    Dec 21, 2012
    5,329
    5,692
    180
    If you have the ASUS SLIC/cert/key, you are gratefully invited to share it with us. Until then, "working but looking stupid" has to do. :p
     
  8. FreeStyler

    FreeStyler MDL Guru

    Jun 23, 2007
    3,546
    3,773
    120
    Whereas this was working fine on Hyper-V Guest on Windows 10 there seems to have changed something (on Hyper-V) on Windows 11.
    With secure boot disabled, after installing and rebooting i am presented with a error message, eg: ERROR: Load Image: Access Denied

    upload_2021-11-25_20-14-48.png

    Tried the obvious, eg: uninstall, reinstall, clean OS but all result to no avail....so conclusion: Windows 11 breaks Hyper-v support
     
  9. kdawg6969

    kdawg6969 MDL Novice

    Nov 14, 2021
    5
    0
    0
    i have 2 new intel z690 motherboards.

    using the /force option, one was able to activate, the other is not able to get activated.

    One is MSI board, other is Asrock board.

    I dunno why the Asrock board won't activate.
     
  10. Jonny5isalivetm

    Jonny5isalivetm MDL Novice

    Aug 21, 2012
    19
    0
    0
    #350 Jonny5isalivetm, Dec 16, 2021
    Last edited: Dec 16, 2021
    Hello

    I tried to activate on a UEFI Windows 7 x64 with a gigabyte z390 mobo but after a reboot it still has the countdown timer to auto activation ?

    Tried it multiple times :<

    Please help

    cancel my cries, I did a reinstall and it worked
     
  11. dream1979

    dream1979 MDL Novice

    Dec 17, 2012
    4
    0
    0
    Hello,

    I have problems using EzWindSlic on DELL R320 / R330 servers.
    I Have several R320 and 2 R330 servers here.

    On a few of the R320 I have the slic 2.3 "visible" on some not, on the 330s I have the slic 2.4 on one enabled on the other off.

    As I boot my machines from an NVME drive I'm using clover to boot the machines.

    Now for the problem, on none of the Servers could I activate a slic 2.5 OS with WindSlic, how ever, ofcourse I can drop the 2.4 on the R330 with clover and inject any other slic with no issue.

    But the R320s are stubborn, no matter what I tryed, clover can't drop the slic 2.3 thus I can not succesfully inject a higher slic, also WindSlic is not able to activate with a higher slic on force mode.
    I tryed with the enabled and the diabled servers

    Clover is the latest version, created with BDU 2.1

    Does anyone have an Idea how i get rid of the SLIC 2.3 in the R320s?
     
  12. Sajjo

    Sajjo MDL Member

    Feb 6, 2018
    1,891
    2,645
    60
    @fjallerx
    Code:
    acpidump.exe -n slic
    Could you post output?
     

    Attached Files:

    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. fjallerx

    fjallerx MDL Novice

    Jul 25, 2019
    3
    0
    0
    sure thing
    Code:
    acpidump.exe -n slic
    The table signature SLIC does not exist.Could not get ACPI table with signature
    [SLIC], AE_ERROR
    ...ayyy. that's not good is it
     
  14. Sajjo

    Sajjo MDL Member

    Feb 6, 2018
    1,891
    2,645
    60
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. CaptainKirk1966

    CaptainKirk1966 Former MDL Guru

    Oct 31, 2009
    2,329
    1,198
    90
    @Sajjo - the mgadiag already indicated no slic present either with windslic installed or not installed. Why would acpidump or rw-everything show different?
     
  16. Sajjo

    Sajjo MDL Member

    Feb 6, 2018
    1,891
    2,645
    60
    Yes, you are correct. :oops:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. ruslanshchur

    ruslanshchur MDL Member

    Sep 13, 2020
    245
    61
    10
    Offtopic:
    *Acer, not HP, yes, I have HP, but EzWindSLIC works fine on my HP, but not on my Acer
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  18. fjallerx

    fjallerx MDL Novice

    Jul 25, 2019
    3
    0
    0
    i ended up reinstalling windows in mbr and using daz loader (only installed in gpt the first time around because rufus with bios/uefi-csm setting doesn't play well with .iso created by the simplix updatepack tool, the machine had troubles reading the flash drive, and then the installation couldn't advance past the partition selection; seems like rufus tend to not want to come out and play when using anything other than untouched .iso. installing untouched windows in uefi-csm was smooth-sailing). had to delete an efi partition on hdd (installed windows on ssd) because it was still trying to load the previous windows installation. maybe the efi partition being messed up had something to do with windslic failing...

    @Sajjo grateful for the help!!