[TOOL] EzWindSLIC: Easily activate Windows 7/Vista/Server 2008-2022 on UEFI-GPT

Discussion in 'MDL Projects and Applications' started by Deleted member 1435102, Apr 9, 2021.

?

Should I use powershell in this script to add more features? Vista will no longer be supported.

Poll closed May 7, 2021.
  1. Yes

    5 vote(s)
    55.6%
  2. No

    4 vote(s)
    44.4%
  1. Chuterix

    Chuterix MDL Member

    Apr 18, 2022
    239
    94
    10
    i think i’ve had this happen on vmware 15 before with the aio script (windows 7 is my main os/daily driver for now)
    have you tried the normal traditional script?
    i only have mbr disk running windows 7 with daz loader installed so i can’t test it on real hw to see if there’s issue.
    if there’s another report of certificate installation failure, there’s a serious problem in the aio script somewhere @Dir3ctr1x
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. Hacker?pcs

    Hacker?pcs MDL Member

    May 28, 2009
    162
    61
    10
    #382 Hacker?pcs, Sep 9, 2022
    Last edited: Sep 9, 2022
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Chuterix

    Chuterix MDL Member

    Apr 18, 2022
    239
    94
    10
    first,
    i doubt 15 and 16 make a difference for 7, only difference is 15 is the last vmware pro for 7 host. (i could upgrade OS but i’m sticking with 7 for a while) this is probably why i gave detail on version

    anyways, glad traditional script is working for you (and probably for everyone else too)
    @Dir3ctr1x fix your aio script pls asap; ur certificate extraction method is broken
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Ok i'll look into it...
    But can you confirm whether 3.61 AIO works or not?
     
  5. Hacker?pcs

    Hacker?pcs MDL Member

    May 28, 2009
    162
    61
    10
    #386 Hacker?pcs, Sep 9, 2022
    Last edited: Sep 9, 2022
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. EzWindSLIC 3.62f
    fix catostrophic bug in aio script
     
  7. Pieter de Zwart

    Pieter de Zwart MDL Novice

    Dec 24, 2019
    2
    0
    0
    Can't get it to work on Server 2022. Installs just fine, but Windows still says it's not activated.
     
  8. Sajjo

    Sajjo MDL Member

    Feb 6, 2018
    1,952
    2,791
    60
    @Pieter de Zwart
    Post some screenshot's/log's so we can have a closer look.
    :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. Carlos Detweiller

    Carlos Detweiller Emperor of Ice-Cream

    Dec 21, 2012
    5,775
    6,351
    180
    This might be a case of RSDP not being in ROM. Here is the passage from the Windows Loader Read me.txt (generally also applies to other SLIC solutions):
     
  10. therussian1

    therussian1 MDL Novice

    Sep 23, 2022
    4
    1
    0
    Hello! I have the same problem as Pieter. When I run EZWindSLIC 3.62f, no matter if classic or AIO, all installs fine but no activation.When I use the script to view SLIC table it says "no SLIC found". I tried with ASUS, Dell, HP but no good.Forceful mode ON changed nothing. My system is Asus X552CL notebook with Windows 7 Ultimate x64, EFI. Please help.Where can I find the log file?
     
  11. Hi,
    please post output of
    Code:
    bcdedit -enum
    from admin cmd.
     
  12. therussian1

    therussian1 MDL Novice

    Sep 23, 2022
    4
    1
    0
  13. Chuterix

    Chuterix MDL Member

    Apr 18, 2022
    239
    94
    10
    looks like your system is still booting from the original bootmgfw.efi efi entry, try going jnto the uefi bios and changing the boot order to boot from windslic.efi or another “windows boot manager” instance
    try different ones until you’re activated
    not sure if what i highlighted was important or it’s just where boot manager resides and nothing else
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. therussian1

    therussian1 MDL Novice

    Sep 23, 2022
    4
    1
    0
    #395 therussian1, Sep 25, 2022
    Last edited: Sep 25, 2022
    Unfortunately in BIOS is a really strange situation. I have a SSD with Win 10 in HDD bay (that at the moment is removed) and a HDD with Win 7 x64 in DVD bay with adapter.If the SSD with Win 10 is removed, the BIOS shows nothing at "Boot option priorities", when I start the system it goes straight to BIOS, and I have to check every time "Save settings and exit" to be able to start Win 7. The log I got is with only the HDD in the DVD bay.
    If I put both the HDDs, in BIOS I have only 2 options, 1 boot manager from the SSD and one boot manager from the HDD.No other options.
    Can't I just overwrite the original bootmgfw.efi with your patched version? I can fix the boot if necessary by restoring the UEFI partition from a backup image.
    LE: At Boot Override there is no entry. When choosing "Launch EFI Shell from filesystem device" it says "not found". With both the HDDs in place I also have to 2 entries at Boot override, one for each HDD.
    About a year ago I had only 1 HDD in its slot, with Win 7 x64 MBR, working perfectly. For work I had to move to Win 10 x64, turn the HDD to GPT, and messed up my notebook, it was very slow on 4500 rpm HDD.Now I got the SSD for Win 10 and tried to return to Win 7 for home tasks and gaming (slow HDD in DVD bay, but fast enough for Win 7). Not an option to convert the HDD to MBR, I have a 450GB partition full of data that I don't want to move elsewhere, and I want to keep the HDD as GPT for Win 10 fallback if the SSD malfunctions.
     
  15. Chuterix

    Chuterix MDL Member

    Apr 18, 2022
    239
    94
    10
    No, WindSLIC.efi loads bootmgfw.efi so overwriting it would be useless.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. therussian1

    therussian1 MDL Novice

    Sep 23, 2022
    4
    1
    0
    #397 therussian1, Sep 25, 2022
    Last edited: Sep 25, 2022
    I found this https://forums.mydigitallife.net/threads/windslic-uefi-slic-injector.29740/ and it says
    Just renamed WindSLIC.efi to bootmgfw.efi and copied everything from WindSLIC folder to "EFI\Microsoft\Boot" overwriting the original "bootmgfw.efi. Now I have an activated copy. Might have worked also with
    but I didn't try. I still like the old ways.
     
  17. siliconbeaver

    siliconbeaver MDL Junior Member

    Apr 29, 2022
    86
    21
    0
    need advice,

    I have an old ECS motherboard GF7100PVT-M3. No SLIC table. hence my trial of Windows 7 Pro activation failed.
    It was running XP. Any chance I can try next? I prefer Win7 if possible.

    Thanks,

    Serg008 is NOT here. BIOS mod would be last I can ask
     
  18. Chuterix

    Chuterix MDL Member

    Apr 18, 2022
    239
    94
    10
    if you're using mbr partition table, then have you used daz loader?
    if that fails have you tried kms_vl_all? if that fails then you've got bad slic, and bios mod would be only option
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  19. siliconbeaver

    siliconbeaver MDL Junior Member

    Apr 29, 2022
    86
    21
    0