dell dimension 5150c

Discussion in 'BIOS Mods' started by throbber, Apr 26, 2011.

  1. throbber

    throbber MDL Addicted

    Mar 13, 2008
    580
    32
    30
    seems like some dells cannot be modded with a 2.1 slic.so i was wondering before i waste my time if anybody knows if dell dimension 5150c with a A07 BIOS can be done??
     
  2. buzz123

    buzz123 MDL Junior Member

    May 9, 2009
    55
    10
    0
    I have had success on the Dimension 2400 (A05) using the Phoenix tool (V1.84) here:

    http://forums.mydigitallife.net/thr...-to-Modify-Phoenix-Dell-Insyde-EFI-Bios-Files

    http://forums.mydigitallife.net/thr...de-Dell-EFI-BIOSes?highlight=phoenix+mod+tool

    Only took a minute and it created a replacement for the Dell BIOS with SLIC 2.1!

    If the 5150C has a similar BIOS loader to 2400 (appears to be so to me) it should work just fine!

    I could try doing the mod for you, but no guarantees! I mighta just got lucky on my 2400!
     
  3. zahnoo

    zahnoo MDL Senior Member

    Feb 2, 2011
    387
    35
    10
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. tqhoang

    tqhoang MDL BIOS Modder

    Apr 29, 2008
    1,376
    266
    60
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. ZaForD

    ZaForD MDL Expert

    Jan 26, 2008
    1,180
    177
    60
    @buzz123,
    Thanks Dude
    The kids are using an old 5150c, looks they may get an upgrade this weekend. :)

    @tqhoang,
    While your right throbber should have searched the forums before posting.
    You may want to check the links you redirect too.
    The file you linked to is for a Dimension E510 which I believe is an AMD based PC.
    Now it maybe the right BIOS for both PC's, but I wouldn't risk it on my Dimension 5150c. ;)
     
  6. tqhoang

    tqhoang MDL BIOS Modder

    Apr 29, 2008
    1,376
    266
    60
    Doh! Sorry about the mistake.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. ZaForD

    ZaForD MDL Expert

    Jan 26, 2008
    1,180
    177
    60
    @buzz123,
    Your mod worked. :worthy:
    Strange thing is it failed a couple of times, I didn't get the whole error but it was something like this:
    (PC rebooted to quick to read the rest)

    So, I made my own version, which had the exact same Hash as yours. It too failed.
    I thought I'd give your one, one last try and it worked fine. :confused:


    @throbber,
    Do you have any problems with power management or fans ?
    At times mine revs up and sounds like a Helicopter coming in to land, then after a minute or two the fan slows down is its back to being almost slient again.
    This happens every couple of hours or so. o_O


    @tqhoang,
    No worries Dude, I've made far worse. :p