Disable CSM -> won't boot

Discussion in 'PC Hardware' started by kbal, Apr 24, 2019.

  1. kbal

    kbal MDL Junior Member

    Mar 17, 2015
    53
    12
    0
    I wanted to go full UEFI, but when I disable CSM my PC boots 1 time to go in to UEFI, but on next reboot I get blank screen (no UEFI screen) and 04, or sometimes 03 error, and I have to reset CMOS.

    Secure boot is disabled
    My GPU is UEFI capable (GTX 970)
    Fatal1ty Z370 Gaming K6

    Any of you guys had simillar problems?
     
  2. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    11,753
    11,912
    340
    #2 Yen, Apr 25, 2019
    Last edited: Apr 25, 2019
    Ermm....could you describe your way how to go 'full' UEFI?

    You know by just disabling CSM you lose ability to boot from any MBR?

    You'd have your OS installed on GPT scheme.....means either conversion or fresh GPT installation....
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    23,730
    33,243
    390
    And i would also want to see the OS mentioned:)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. kbal

    kbal MDL Junior Member

    Mar 17, 2015
    53
    12
    0
    Win 10. But OS makes no difference since I get stuck before UEFI.
    Found a lot of similar stories on internet, people even move to different boards to "fix" this :(
     
  5. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    23,730
    33,243
    390
    Why not just let CSM enabled? You should still be able to boot and install in legacy bios and uefi.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. kbal

    kbal MDL Junior Member

    Mar 17, 2015
    53
    12
    0
    Have you ever used BIOS with CSM enabled? Let's just say, it's not HD. Fonts are as large as in some 1990 BIOS, so it's very hard to find what you're looking for, especially if it's burried in some submenu. And thank God my mouse has an DPI switch, Anything above 600 makes it usless. You can't hit anything.
     
  7. Joe C

    Joe C MDL Guru

    Jan 12, 2012
    3,123
    1,800
    120
    How often do you need to access your bios? If your fonts are too large in your bios screen, check your monitor settings and adjust from there. I've never experienced any font size issues by enabling/disabling CSM
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    23,730
    33,243
    390
    #8 Enthousiast, Apr 26, 2019
    Last edited: Apr 26, 2019
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. kbal

    kbal MDL Junior Member

    Mar 17, 2015
    53
    12
    0
    So, nobody knows the answer to my question.
     
  10. Hadron-Curious

    Hadron-Curious MDL Guru

    Jul 4, 2014
    3,574
    531
    120
    Have you checked if there is any BIOS update?
     
  11. kbal

    kbal MDL Junior Member

    Mar 17, 2015
    53
    12
    0
    Using latest BIOS (2019/4/15), but I had the same problem before.

    I think it has to do something with Board-GPU incompatibility. Guess no UEFI till I upgrade :(
     
  12. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    11,753
    11,912
    340
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    23,730
    33,243
    390
    With CSM it still is UEFI, but with the compatibility support for legacy bios.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    11,753
    11,912
    340
    #14 Yen, Apr 27, 2019
    Last edited: Apr 27, 2019
    I still think it could be UEFI settings related.
    According to the thread Asrock could not reproduce the issue. BUT a few people are encountering it.
    And it 'disappeared'...at one user...after a few BIOS updates. Anyway if that would be the reason nobody would have that problem anymore...

    Normally BIOS / UEFI address default resolutions via default driver any GPU should know...

    I would explicitly try to alter settings like IGPU Multi-Monitor (external VGA only / both) and the resolution of the UEFI screen (if changeable)...or disable FHD support there.
    Change whatever is related to appearance of the UEFI setup GUI. (style / entry page etc...)
    ..and have a look if it works.....

    Alternatively try to use onboard VGA to check there if its PCIE GPU related....
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. kbal

    kbal MDL Junior Member

    Mar 17, 2015
    53
    12
    0
    Best I could manage was to set:

    Launch PXE OpROM Policy
    Launch Storage OpROM Policy
    Launch Video OpROM Policy


    to UEFI only, but leave CSM Enabled.

    Manual states:

    CSM
    Enable to launch the Compatibility Support Module. Please do not disable unless you’re running a WHCK test.

    UEFI is in HD mode now, and I had no problems installing from GTP Win 10 install USB key. Main partition is GTP now, System Information reports BIOS Mode is UEFI.