DMICFG locked DMI as read-only?

Discussion in 'Windows XP / Older OS' started by emfi2r, Oct 5, 2007.

  1. emfi2r

    emfi2r MDL Novice

    Sep 10, 2007
    13
    0
    0
    #1 emfi2r, Oct 5, 2007
    Last edited: Oct 5, 2007
    Hello,

    I used dmicfg.exe (in pure dos from boot floppy) to edit dmi table of the Intel/AMI BIOS on an intel
    D815EEA motherboard. Wanted to set oem as Gateway.

    It uses Intel 80802 FWH device.

    Evidently It was a success, however, I noticed I mispelled Gatway (forgot the "y") now it says "GATWA" without quotes.

    I ran dmicfg again, but now I can't change the Manufacturer.
    Dmicfg pops up "ERROR! Problem with operation, DMI is read-only.

    I researched the 82802 FWH, and know which pins are reset, etc. but nothing worked by shorting (with 10k resistor) the rst# pin to Vil (if high, resets the lock-bits to 0F,or access all), if Vil is low, then read only.

    Question is, did dmicfg set it as read-only, or not?

    Anyone know how to reset it with software?
    Or jumping?

    It is soldered, or I'd stick it in my burner.
     
  2. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    10,938
    10,476
    340
    Hmm. IMO dmicfg is too old to work properly at newest bioses. At my case it wrote the DMI entry, but it wasn't persistent.

    A fullflash of original bios with clear cmos and "Load Default/Optimized Settings" should do the job.

    Yen
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...