Have SLIC, how to activate?

Discussion in 'Windows Vista' started by ReaLiTY, Feb 2, 2008.

  1. ReaLiTY

    ReaLiTY MDL Novice

    Dec 30, 2007
    23
    0
    0
    I have a sony laptop with vista home premium pre-installed. I checked Everest and my Pheonix BIOS has SLIC. I want to upgrade to Vista Ultimate. I currently have thee vista retail DVD. The question is how would i activate the new vista ultimate? Furthermore, will this de-activate after installing the Final Release of SP1 ?

    Thanks in advance :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    10,938
    10,477
    340
    #2 Yen, Feb 3, 2008
    Last edited: Feb 3, 2008
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. ReaLiTY

    ReaLiTY MDL Novice

    Dec 30, 2007
    23
    0
    0
    Hey Yen thanks for the reply. i got the sony oem cert already. I can't seem to find a sony oem key for Ultimate though. Will it still activate with another Ultimate key from another OEM brand ? like Asus ?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    10,938
    10,477
    340
    #4 Yen, Feb 3, 2008
    Last edited: Feb 3, 2008
    I don't know for sure. Give it a try.
    Could you please upload your bios anyway? I want to figure out how Sony did it!

    I'm not able to modify other Sony bios so far.

    Thanks!

    Edit: Check your PM!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. longboy

    longboy MDL Novice

    Jan 3, 2008
    21
    0
    0
    I have sony laptop. I think I can send bios.
     
  6. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    10,938
    10,477
    340
    #6 Yen, Feb 7, 2008
    Last edited: Feb 7, 2008
    Oh yes, please!

    I need one with SLIC! For some reason 'reality' doesn't send it, even though I've helped him out via PM :(
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. longboy

    longboy MDL Novice

    Jan 3, 2008
    21
    0
    0
    I try use winphlash 1.3 and 165 version to backup bios. But winphlash,stops responding. Laptop uses vista business and there is some security software (etrust security itm) My model is sony VGN-FZ11S. I search web for sony bios flasher but can not find any. Do you have an idea?
     
  8. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    10,938
    10,477
    340
    #8 Yen, Feb 7, 2008
    Last edited: Feb 7, 2008
    AFAIK there is no special sony flasher!

    Are you using 64 bit Vista? I don't have Phoenix bios and don't know why it's not working. There are 32 and 64 bit versions of winphlash available. And winphlash needs a dummy bios. Otherwise it won't save the current bios.

    There is a way to save it directly :

    Install HwDirect (at 64 bit Vista you probably have to disable driver signature enforcement, by pressing f8 at Vista startup and choose it. This will last only for one session) to make it run.
    Goto memory dump and enter as physical address FFF00000, size fffff!

    Press dump, right click into the code display, select all, right click again, select copy!

    Now open winhex, paste the code into a new file, choose ASCII HEX.
    Save and upload the file.

    A bit complicated I know......but with these steps you are able to save any bios which size is <= 1Mbyte!

    I think Sony doesn't like to provide their SLIC bios!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. ReaLiTY

    ReaLiTY MDL Novice

    Dec 30, 2007
    23
    0
    0
    sorry Yen for the late reply. I was having trouble getting the BIOS with the app you recommended. I will try your new instructions.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    10,938
    10,477
    340
    Yeah Sony tries to make it hard to get a bios....
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. longboy

    longboy MDL Novice

    Jan 3, 2008
    21
    0
    0
    I am using 32 bit vista. I made dummy bios before as you said. I will try with hwdirect as you said. Yes it is little complicated for me, but I think I can do. Sony software support does not good as it's products.
     
  12. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    10,938
    10,477
    340
    Thanks for your effort. I'll have a look at it to see .....:)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    10,938
    10,477
    340
    #14 Yen, Feb 11, 2008
    Last edited: Feb 11, 2008
    The bios you've dumped is to open with PBE!
    You have to add one more zero byte at the end of the file and change it into *.ROM

    The correct dump would be:
    Physical address: FFF00000 , size: 100000, not FFFFF.
    This was my fault!

    The SLIC is located at ACPI7.ROM. The table ID at BIOSCOD1.ROM and probably BIOSCOD3.ROM

    Thank you very much.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    10,938
    10,477
    340
    Thanks again. I've managed it to work before as well .(Added a zerobyte 00)
    We need to reverse the BIOSCOD module........

    I have to wait till April. Maybe someone else want to try to understand how Sony fixes the OEM table ID........
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. atifsh

    atifsh MDL Junior Member

    Jun 4, 2008
    69
    1
    0
    can i have that vista ultimate oem slic key for sony.

    got the certeficate but no keys.....
    pls email to atifsh@gmail.com