Help with a bricked Samsung laptop

Discussion in 'BIOS Mods' started by kenvenin, May 27, 2014.

  1. kenvenin

    kenvenin MDL Novice

    May 27, 2014
    2
    0
    0
    Hello,
    I was performing a bios update for my samsung laptop but my it froze for nearly 3 hours I had to forcefully power it off and it won't start. Nothing but a black screen. My bios is a phoneix and I was updating from 13FD to 15FD through the official samsung bios update tool. I'm not sure where to start with the bios recovery process. I have a rom & 2 bin files I downloaded from the internet. Any help?
    Model: Samsung NP700Z5AH
    Thanks in advance.
     
  2. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    11,098
    10,766
    340
    Have you tried to remove battery and power cord for an hour and restart it? Or to start it without battery..or to push power button and then plug in the power cord?..
    TBH the chances to recover Phoenix BIOSes especially for Samsung / Sony devices are not good. Usually Phoenix BIOSes can be recovered using Crisis method.
    Phoenix EFIs are different, though.
    But you need to know how to initialize the process, usually by pressing a key combination and power button...I guess the ROM file is the BIOS (it is usually multiple of 1 MByte in size)
    You can upload the ROM file to sendspace to have a look....if it is a BIOS or EFI at least....

    I am sorry for you. It is a faulty Samsung update.
    Samsung provides an update tool and it downloads the BIOS from their server and flashes it 'live' through windows....with this method a machine can brick (higher risk compared to 'non live' update methods / DOS methods).

    It is absolutely not your fault and Samsung should (IMHO) pay for the damage....maybe call their hotline...this is really annoying what Samsung did...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. kenvenin

    kenvenin MDL Novice

    May 27, 2014
    2
    0
    0
    #3 kenvenin, May 28, 2014
    Last edited: Jun 2, 2014
    (OP)
    @Yen I've tried all methods on the internet related to resetting cmos but no luck.
    For now I just want to know how to prepare a pen drive for the recovery process, if there is any. In case it doesn't work does that mean I have to have a motherboard replacement? because it's already out of warranty and they'll blame me anyway. Sorry for asking you so many questions and thanks for your reply.
    All bios files I have now: mediafire.com /?cd64ks7mks9gs8f
    Update:
    I've checked the bios, it's an EFI bios. I now know there's an rtc reset switch in the memory opening and I've tested it. The laptop starts up with a high fan noise so, that's a start. Next, I need to know how to prepare a flash drive.
    Update 2:
    Actually the rtc reset noises were illusions. Now I know there's a switch labeled "Crisis" just below rtc reset switch. When I bypass it the flash drive led powers on, which it didn't before. Andyp's tool doesn't come up with possible recovery names so, I used a hex editor on .rom file which phoenix tool extracted from the original bios, instructions from a Russian website, and the only readable text I found, was "D:\03FDM010\Projects\NikeProHrv\temp\X64\BootCpuDxe.pdb".
    So, in summary I've found the recovery initiating switch and it started reading the usb drive but it seems the file names I put were wrong.
    File Names:
    03fdm010
    03fdm
    03fdm010x64
    03fdmx64
    03fdm010HW
    03fdmHW
    bios
    biosn
    mx25l5121e
    mx25l5121eHW
    with .rom & .bin