HP Insyde BIOS recovery steps.

Discussion in 'BIOS Mods' started by kallisti5, Jul 23, 2012.

  1. Kevinot

    Kevinot MDL Novice

    Jun 10, 2018
    42
    13
    0
  2. theCurseOfHackintosh

    Sep 1, 2020
    1
    0
    0
    #662 theCurseOfHackintosh, Sep 8, 2020
    Last edited: Sep 8, 2020
    Is it possible to Flash modified Bios using This Method? I have HP DV6 with I5 2410M.
    I can Flash original HP Bios using This Method, but Not Donovan6000 mod (https://forums.mydigitallife.net/th...5068-donovan6000-mods-microcode-update.77793/).
    I want to modify it myself, by adding a Module to it. I can't add it to Bin file (entcrypted) to Flash with insydeflash, but i can add it to DEC file, but can't Flash the decrypted DEC file with insydeflash, and This recovery Flash gives me an error, because Signature...
     
  3. tqhoang

    tqhoang MDL BIOS Modder

    Apr 29, 2008
    1,570
    350
    60
    I had to use the recovery method described on the first post here, but IIRC I wasn't able to do it from a USB stick. The USB stick was getting disconnected since the USB controller was getting reset as part of the flash process.

    Just going by memory, I had to boot my original HP formatted hard drive and put the files into the hidden drive partition (should have the directory structure Hewlett-Packard/Bios/Current). Then follow the recovery process in the first post here.

    If you get it to work, please let us know.
     
  4. SaraCom

    SaraCom MDL Novice

    Oct 15, 2020
    1
    0
    0
    LatinMcG:

    I'm trying to update BIOS to the latest version on my working HP Elitebook 850 G1 laptop (Win10) off of the Firmware Management on the Diagnostics UEFI partition on the notebook SSD. I see the current BIOS L71_0148.bin in the EFI|HP\BIOS\Current folder and tried to update it to L71_0149.bin, but the flash was aborted with an error " the .bin file cannot be validated." Obviously, I need a .sig file in the Current folder. Do you know how to create one or do you happen to know any websites? Thanks.
     
  5. Omar Maged Mohamed

    Omar Maged Mohamed MDL Novice

    Dec 3, 2020
    1
    0
    0
    I wonder if anyone can help please? I have an HP Pavilion X2 detachable laptop (10-n000na) and was trying to reinstall windows 10 the latest build 20h2. It got stuck at the formatting bit and tried to delete partitions but it won't do it, tried using different versions of windows using a USB flash drive or USB Disk drive but still won't do it and the system diagnostic says the BIOS application is corrupt. I tried to flash the BIOS using a USB flash drive but when I try the key combination like Window key + B or Window + V Or any other key combination but nothing happens and searched so much for this but can't find a solution. Do you know how to get it to flash the BIOS please?
     
  6. xxxUserPLxxx

    xxxUserPLxxx MDL Novice

    Dec 14, 2020
    2
    0
    0
    Alright I've got a weird one.
    It's an HP G62-b20SW with i3 350M and Intel HD.
    I got 01439.fd.DEC and .sig, both renamed to 01439.fd and 01439.sig.
    I can't boot it, even after pressing Windows+B. But sometimes I get CMOS Battery Alert, since I disconnected my CMOS Battery.
    After Pressing Enter to reboot my system, I get the same thing. Two Caps-Lock blinks.
    Anyone knows what could be the issue here?
    I'm almost certain it's not a reflow thing, since everything worked great until I flash custom BIOS.
     
  7. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,715
    1,604
    180
    when u run the exe some version it creates usb recovery.. that can be used.
     
  8. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,715
    1,604
    180
    try different version.. change OS to win 7 and such in hp site and check previous version #
     
  9. xBorealis

    xBorealis MDL Novice

    Dec 29, 2020
    2
    0
    0
    #669 xBorealis, Dec 31, 2020
    Last edited: Jan 1, 2021
    Ladies and gents, esteemed community members. A cry for help from here, in exasperation. Here are the particulars of my case:

    About a week or so ago I experienced BIOS corruption and CMOS errors 501/502 on my HP dv6tqe laptop (bricked).
    The machine shipped with Windows 7 Home Premium 64 Bit and features the 2nd gen. (SandyBridge) Intel Core i7-2630QM CPU with a 1 GB discrete Radeon 6700M GPU and 6 GB RAM. I upgraded this to 12 GB, utilizing the 4 GB stick from the original config + an additional 8 GB. Also, I subsequently opted to "upgrade" the machine to run Windows 10 Home 64 Bit.

    Device specifics:
    Cust. Model dv6t-6100,
    Rev.: 1657-110
    PCID: 058xx-xxxxx-..

    I cannot boot the laptop and am experiencing the blank screen with no GUI or means of interaction. I get two long caps lock blinks in a row, then short pause, then repeats. I use this machine for my professional work, so this is a rather unfortunate situation.
    I have endeavored to follow Post #1 by @LatinMcG to the letter and also referenced posts #655, 656. #372 to name a few:

    1) Formatted a USB stick both as FAT32 and FAT16 (default), naming it HP_Tools. (From a desktop alternative)
    2) Downloaded and executed HP UEFI Support Environment (SP54668) to create the HP_Tools UEFI boot USB stick.
    3) Find System Board ID in the bios. Bricked, but device specifics under battery indicate Rev. 1657-110.
    4) Obtain latest BIOS update for your laptop. Done. Using SP55068 (but have also downloaded SP53216, SP54024. 53112)
    5) Run Phoenixtool on the bios you wish to recover. Done, albeit I am unsure whether I ran Phoenixtool with the correct modifiers/parameters. I will clarify further on this as needed. The output files were 01658.Bin.Dec and RSA.Sig. As an alternative, I used @LatinMcG's SP55068 output files from Post #656.
    6) Place both of these files on the usb stick at Hewlett-Packard/Bios/Current. Done.
    7) Change file names to match Rev.#: 01658.Bin.DEC-> 01657.BIN; RSA.SIG -> 01657.SIG. Done.
    8) (Disconnect battery and power adapter,) Plug in the USB stick, hold Win + B, (Connect power) and Power On. Done.
    9) Wait for system to flash. Does not seem to happen. USB is definitely accessed and is running with indicator light blinking in various cycles, but no cigar it appears.
    Have tried numerous iterations over the past week, using Phoenixtool generated files, LatinMcG's output file from the same as indicated above, using FAT32/16, with SSD, CMOS battery connected/disconnected, 12 GB RAM, 4 GB RAM (have not tried 2 GB only).

    What am I missing?

    Thank you in advance!
     
  10. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,715
    1,604
    180
    time to get ch341a programmer...
     
  11. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,715
    1,604
    180
    #672 LatinMcG, Feb 21, 2021
    Last edited: May 9, 2021
    asprogramer or flashrom 1.21 gui should work for you with ch341a
     
  12. DV6255

    DV6255 MDL Novice

    Mar 30, 2021
    1
    0
    0
  13. Bochoide

    Bochoide MDL Novice

    Jun 9, 2021
    1
    0
    0
    Hello to everybody¬°

    I have a sony Vaio VPCSB4Y9E which flashed by mistake with another Bios Insyde.

    Could someone help me, the laptop has been bricked, I have read a lot of information but nothing works.

    I comment on the symptoms: The laptop turns on the screen, it stays off for 30 seconds (black screen) and later the sony and insyde bios logo appears, but after 2 or 3 seconds it turns off automatically, which does not give me time to be able to configure nothing of the bios or boot from pendrive.

    I have tried a multitude of key combinations to boot from USB and nothing, all without success. If someone can help me please?

    Thanks very much
     
  14. Yasooo

    Yasooo MDL Novice

    Nov 26, 2021
    3
    1
    0
    Hello to everybody,

    i have a HP pavilion g6 1302sk laptop that dosen't boot screen stays black and the lock caps blink twice each second , which is a corrupted bios , i have tried to download the bios update from the official site HP support using the serial number of my pc and i have got a sp60864.exe, which i extracted using 7.ZIP as LatinMcG mentioned, and i have got 4 bin files 0166CF66.BIN | 0184DF66.BIN | 0338AF66.BIN | 01666F66.BIN | and many other files but nothing with the extension fd or sig, the REV of my PC is 1670 - 130 so i think the 01666F66.BIN is the correct bios update , i used phoenix tool 250 to decrypt the 01666F66.BIN and got 2 extra files 01666F66.BIN.DEC and RSA.SIG i have renamed both to 01666.BIN AND 01666.SIG and used HP UEFI SUPPORT ENVIRONEMENT ( sp62598.exe ) to create the structure on my USB and i got Hewlett-Packard folder contaning 3 folders bios / BIOSUpdate and SystemDiags than i copied the two created files 01666.BIN AND 01666.SIG to BIOS/CURRENT and BIOS/Previous
    and tried to boot with pressing on POWER +WIN + B Keys for 3 secs and than releasing the power button but keeping pressing on the WIN+B but nothing happen , the display stays black and the laptop keeps running and lock caps blinking twice each second.

    i have tried all the solution mentioned but no luck !!
    what did i do wrong ?
    any solution please ?

    Help please @LatinMcG !
     
  15. Asparagus Lover

    Asparagus Lover MDL Member

    May 17, 2019
    202
    48
    10
    Hello.
    What if 01666.BIN is not the right one for your laptop. Why not to add the other files to the USB too?
     
  16. Yasooo

    Yasooo MDL Novice

    Nov 26, 2021
    3
    1
    0
    hello @Asparagus Lover, thanks for your reply, i tried your suggestion by putting all the 4 bin files (0166CF66.BIN | 0184DF66.BIN | 0338AF66.BIN | 01666F66.BIN) and 4 .sig files generated with phoenix tool in bios/current and bios/previous but no luck nothing happened !
     
  17. Yasooo

    Yasooo MDL Novice

    Nov 26, 2021
    3
    1
    0
    Hello Everyone ,
    problem solved only by following these steps:

    1. remove CMOS battery and after a few minutes i plugged it again

    2. connect AC power adapter and press power button

    3. laptops starts normally maybe you will get an error msg "The CMOS checksum is invalid, The BIOS will be reset to the default configuration and will be rebooted."

    4. try to reboot again if the screen turns black again repeat the same steps but this time try to Upgrade bios to F.29(if you have F.24)

    5. Everythings works fine (restart/shutdown have no effect)

    in my case i did follow these steps and didn't get that error message, tried to reboot and everythings works fine.

    Good luck to everyone !
     
  18. Marco7601

    Marco7601 MDL Novice

    Apr 19, 2022
    3
    0
    0
    #679 Marco7601, Apr 19, 2022
    Last edited: Apr 24, 2022
    Hello i have a hp dv6 6010 el and when try to flash a bios the pc freeze and i m shutdown but at restart i give blank screen and caps lock blink 2 times.what can i do to restore the bios? thanks. My bios is F.1b sp 55068. Edit:i resolve my bios issue Yesterday thanks to all
     
  19. Simple07

    Simple07 MDL Addicted

    Nov 15, 2012
    573
    218
    30