Mod Your Own Bios / Discussions on BIOS Transcoding

Discussion in 'BIOS Mods' started by hellohello, Jul 12, 2007.

  1. Raider0001

    Raider0001 MDL Novice

    Dec 4, 2007
    26
    0
    0
    Ive maded my own bios winflash says it has bad license so i have made it and flased in DOS mode (using floppy :p ) now what do i have to do to remove emulated slic (paradox with asus oem slic) ? what to do to activate static slic ?

    Edit. It seems that bios mod was done properly but there is no slic so i beg for EPOX 8NPA7I bios mod that works i posted in Requests some time ago but no replays
    I need it quickly, havin bad expierienc with vista - games are crashing, sound is chopping od desktop, overclocking looks like too tooo high even when i lower it (xp was super stable)
     
  2. fmazzotta

    fmazzotta MDL Novice

    Nov 15, 2007
    5
    0
    0
    Bios mod for Asus w5a

    It is possible to mod bios for an asus w5a?
    If yes, how can I flash it?
    Thank You :)
     
  3. Mauritsius

    Mauritsius MDL Novice

    Nov 12, 2007
    6
    0
    0
    If SLIC already present?

    I have a Shuttle SP35P2 Pro which comes with shuttles own SLIC table and as there is no cert and key for shuttle, as far as i know, im trying to mod it.

    Adding a new SLIC table with the Award ISA method actually works, as adding goes, but it leaves me with 2 SLIC tables (reported by everest) in bios (shuttles first then my newly added SLIC) which doesn’t activate vista.

    I've reed about renaming the original SLIC in the 4 post in this thread from Yen, but have some questions...
    - Does this apply to Award?
    - Is this the way to go when the original SLIC seems fully functional (maybe replace the original instead)?
    - What does a "not active or only mapped a half" SLIC table mean?
    - How to know which SLIC-string that’s part of the SLIC table itself? There are only 2 SLIC strings in the entire bios and both are in ACPITBL.BIN, one at the very beginning and a second at the middle. My guess is that string at the middle is part of the SLIC table but how to be sure of that?

    If someone (Yen?) could explain a little bit more how to approach a mod with a SLIC table already present it would be appreciated. Is there a way to replace the existing SLIC with a new one or is renaming the way to go?

    TIA Mauritsius
     
  4. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    11,834
    12,163
    340
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. joebloggs1881

    joebloggs1881 MDL Expert

    Jun 15, 2007
    1,049
    22
    60
    When I tried to mod my Gigabyte GA-945GCM-S2L. I got the following :

    Adding ISA.bin 75.9%

    9gcms2l.bin have not enough space for adding ROM (over 1000B0h bytes)


    done!


    All the methods give the same message and there's a bios.rom file in the same folder

    Same as reported by r4v3n on 8/30. Any suggestions?

    Thks
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    11,834
    12,163
    340
    Cbrom does not show up to 100% by adding the ISA module, that's NO ERROR. It's all right.
    I would go for the isa method, cause it's no Asus board.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. bouncy

    bouncy MDL Novice

    Sep 19, 2007
    1
    0
    0
    ok i dont want to sound dumb but when it comes to bios's i really havent a clue. i too have a shuttle bios with an existing slic table and i too want rid so i cant use say for example an asus table. in laypersons terms, how do i do this?
     
  8. anko

    anko MDL Junior Member

    Nov 19, 2007
    77
    4
    0
    Hi guys I mod my bios (award) using the instractions on first page. My board is the DFI LANPARTY UT 790FX-M2R and i used asus slick table. Everything was ok and i had my modded bios but when I tried to flash it to the board from windows (using winflash) i got a message saying: Invalid Windows Licence in Bios.
    What's wrong and i got that message? Should I flash the board through DOS or i just have to forget it (before screwing my board)?
     
  9. swabe2

    swabe2 MDL Novice

    Jan 31, 2008
    17
    0
    0
    lazy question ...
     
  10. swabe2

    swabe2 MDL Novice

    Jan 31, 2008
    17
    0
    0
    ok, been reading alot, and Mauritsius, we had the exact same experience, I tried the isa method and it gave me 2 slic tables.

    Further investigation shows that apcitbl already have a slic table.

    I tried what Yeng suggested, ISA Method and renaming the slic of shutle to TEST. Upon checking on
    everest, the slic information looks alright. but vista is still not activated

    I already tried changing the key and using the certificate, but no luck,

    I ran out of ideas, anyone ?

    *update
    ok, atlast vista activated! :D it seems that i forgot inserting the right slic, so a recap on what I did

    1) extract acpi table from bios and released
    2) hex edit , change oem id and oem table in rdst, insert the slic table replacing the slic table of my bios (since mine already have one)
    3) added the acpi table
    4) flashed the bios
    5) change cd key and oem certificate slmgr.vbs -ipk <new product key>
    and slmgr.vbs -ilc C:\oemcert.xrm-ms
     
  11. mm888

    mm888 MDL Novice

    Oct 20, 2007
    12
    0
    0
    Hi

    First of all, thanks for the great tutorial of mod BIOS. I've tried my own BIOS and it works. However, I've encountered strange activation problem with Vista x64 with certain OEM's ISA.BIN. I'm interested to know if anyone who have the same problem?

    M/B:
    Gigabyte M55Plus-S3G v1.0 AWARD BIOS F9

    Symptom:
    It turned to not activated by using Acer & HP ISA.BIN on Vista x64. But no problem with ASUS & DELL ISA.BIN.
    However, it does work on Vista x86 (Only verified Acer ISA.BIN):confused:
     
  12. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    11,834
    12,163
    340
    That's normal!
    Some of the SLICs are for Vista 32 bit activation only!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. mm888

    mm888 MDL Novice

    Oct 20, 2007
    12
    0
    0
    Thanks Yen! BTW, I was wondering if it is safety to mod AWARD BIOS prior to year 2005? I have old MB with old AWARD BIOS and would like to install Vista. Please advice! Thanks in advance.
     
  14. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    11,834
    12,163
    340
    It depends on the bios itself. At Award bios there will be no problem if it has got a ACPI module (RSDT table) and enough free space to apply the isa module.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. mm888

    mm888 MDL Novice

    Oct 20, 2007
    12
    0
    0
    Much appreciated! Thank you Yen!
     
  16. Marotick

    Marotick MDL Novice

    Oct 11, 2007
    15
    0
    0
    #99 Marotick, Feb 9, 2008
    Last edited by a moderator: May 23, 2017
  17. Linux4ever

    Linux4ever MDL Novice

    Jan 25, 2008
    28
    3
    0
    I have tried the Method 1 - Easy Auto Method for AMI bios. And now my mobo is dead, it can't even POST. It shows nothing on the screen... :(. I have K9A2 Platinum V1.0 board.