Windows 10 Enterprise update problem

Discussion in 'Windows 10' started by Moksu, Feb 5, 2018.

  1. Moksu

    Moksu MDL Novice

    Feb 12, 2017
    16
    7
    0
    What might cause a problem for my Windows 10 Enterprise to not get latest updates via 'Windows Updater' I just get a 'device is up to date' message.
    And need to download updates manually from Microsoft site.
    (Using Enterprise as a home computer)
     
  2. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    12,419
    13,505
    340
    Is it a x86 or x64 system?
     
  3. Moksu

    Moksu MDL Novice

    Feb 12, 2017
    16
    7
    0
    I am running x64 system.
     
  4. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    12,419
    13,505
    340
    Hmmm, and you are sure you didn't modify the install in any way that blocks WU from working?
     
  5. Moksu

    Moksu MDL Novice

    Feb 12, 2017
    16
    7
    0
    I did use programs like W10Privacy + shutup10.. Could those have a feature somewhere what disables Windows Updates?
    is there a 'reset' button for windows updates
     
  6. abbodi1406

    abbodi1406 MDL KB0000001

    Feb 19, 2011
    7,159
    21,918
    240
    Telemetry level 0 = no updates

    disable preview builds policy active = no January cumulative updates
     
  7. abbodi1406

    abbodi1406 MDL KB0000001

    Feb 19, 2011
    7,159
    21,918
    240
    It should not be enabled, default not configured is enough
     
  8. Moksu

    Moksu MDL Novice

    Feb 12, 2017
    16
    7
    0
    Yeh, i got those policies 'not configured'.

    Where can I change Telemetry level to 1 so I can get updates?
     
  9. abbodi1406

    abbodi1406 MDL KB0000001

    Feb 19, 2011
    7,159
    21,918
    240
    Code:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\DataCollection]
    "AllowTelemetry"=dword:00000001
    make sure this path don't have AllowTelemetry value
    Code:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\DataCollection]
     
  10. abbodi1406

    abbodi1406 MDL KB0000001

    Feb 19, 2011
    7,159
    21,918
    240
    I don't have anything else to suggest

    did you set Defer options? (i.e. defere feature updates to 0 or 365 days)
     
  11. pf100

    pf100 MDL Addicted

    Oct 22, 2010
    632
    442
    30
  12. jcc2

    jcc2 MDL Novice

    Mar 23, 2010
    23
    5
    0
    In my x86 test machine update to .214 done manually worked fine. In my x64 test machine the same manual update said system is up to date, but checking version with Winver confirmed that it had updated from .192 to .214

    JCC
     
  13. archangeliques

    archangeliques MDL Novice

    May 2, 2017
    37
    9
    0
    I have an update on another thread.

    Link.