[XP] Svchost.exe using 99% CPU (Windows Update)

Discussion in 'Windows XP / Older OS' started by f33nix, Dec 16, 2013.

  1. f33nix

    f33nix MDL Member

    Apr 4, 2012
    153
    84
    10
  2. odiea

    odiea MDL Member

    Jul 31, 2009
    137
    40
    10
    Server 2003 will do the same thing unless you follow your procedure.
     
  3. 5aLIVE

    5aLIVE MDL Novice

    Dec 14, 2012
    18
    2
    0
    I fixed the WU/svchost problem by installing IE8 and KB289878. I can now download updates without svchost going into meltdown which is welcome. Up until now I always had IE6 as a secondary browser to run some legacy software I use from time to time.

    IE8 doesn't run well on this old box and it doesn't display pages properly when using the legacy software. Is there any way I can revert back to IE6 without breaking Windows Update?
     
  4. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,382
    1,456
    180
    m fighting this right now on dimension 4600 .. fun
    did sp2 first.. and also sp3 cds.. both did it
     
  5. f33nix

    f33nix MDL Member

    Apr 4, 2012
    153
    84
    10
    I think you can have one or the other, just not both.
    So you can fix the svchost.exe and cure the meltdown or you can leave it so the old software you use works. Perhaps you need to play with IE8 settings to have it run in compatibility view settings.
    I myself have not used IE for years as main browser either.
     
  6. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,382
    1,456
    180
    someone mentioned a fix from safemode no net and installing ms installer 3.1
    then the one from the site mentioned above.

    maybe with a prog called dial a fix, buggy but sometimes worked for me
     
  7. 5aLIVE

    5aLIVE MDL Novice

    Dec 14, 2012
    18
    2
    0
    #7 5aLIVE, Dec 21, 2013
    Last edited: Dec 21, 2013
    Thank you for your reply f33nix.

    I have some good news to report, it turns out I can have my cake and eat it. Using a netbook with XP SP3 and IE6 installed and windows updates turned off I downloaded and installed KB2898785.

    After restarting the netbook I turned on windows updates back on and typed wuauclt.exe /detectnow to check for updates. After a very brief spike from svchost/wuauclt I had a list of updates to download and install.

    So it appears Microsoft have fixed the problem (for now). I just need to restore a drive image on the PC I run legacy software prior to the recent IE8 install to check it works too.
     
  8. RJARRRPCGP

    RJARRRPCGP MDL Member

    Feb 24, 2010
    227
    21
    10
    #8 RJARRRPCGP, Dec 21, 2013
    Last edited: Dec 21, 2013
    I'm afraid it's a new bug with XP Windows Update. Even XP with 2013 updates had the same problem, where it stays at the "Checking for the latest updates for your computer" screen with that animation forever.

    (BTW, reminds me of web sites that just show a loading animation forever because of NoScript blocking a script.)

    And it looks like this time, Microsoft is covering it up.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. f33nix

    f33nix MDL Member

    Apr 4, 2012
    153
    84
    10
    Cheers this information will help the thread out :clap3:
     
  10. 5aLIVE

    5aLIVE MDL Novice

    Dec 14, 2012
    18
    2
    0
    Happy to help.:) Today I restored the backup image on my "legacy" PC (which uses IE6) and installed KB2898785.
    Windows successfully detected the latest batch of updates without a hitch.:dance:
     
  11. tonto11

    tonto11 MDL Addicted

    Jun 18, 2012
    594
    261
    30
    @f33nix

    Thank you , it worked like a charm
    finally broke the logjam :worthy:

    ...T
     
  12. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,382
    1,456
    180
    yep worked here too.. updates fixed it eventualy.